Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Data recovery from an WD My book External Drive


  • Please log in to reply
No replies to this topic

#1 ressurection

ressurection

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:01:35 PM

Posted 01 June 2013 - 07:47 AM

I have an WD 1.5TB My book external drive that isn't working properly and I want to recover the data that I had stored in it. I have tried some solutions by myself based on some suggestions I read online (including this one , which directed me here) so it's possible I've already taken some wrong steps to get my files back and that's why I include a long description/history of what I've done.

 

The problem started off two weeks ago, as my computer would not detect the drive when I connected it. I tried on two other computers, and with a different USB cable, and still nothing (although the drive appeared to turn on if I pressed its on/off button) so I ended up removing the enclosure and connecting the drive though sata (I thought this was the best section to post the problem since the drive is supposed to be external and the problem started as it).

FInally the drive was detected in the computer but no partition was found so I ended up creating one with the maximum space possible hoping that it would be of any help (which obviously wasn't) so I erased it and later created it again. I did all of this in disk management (I'm using windows 7 64bit), and also blindly converted the disk from GPT to dynamic and back to GPT hoping it would be of any help.

I tried looking up my problem online, and found some data recovery programs which I have ran, but either no files are found, or some files that aren't any good to my (doc files with over 1 GB or images with about 200 MB) are located.

Eventually I found the site mentioned above, and ran test disk (from windows, not from partedmagic). In the partition table type step, testdisk had detected an EFI GPT type, so I choose that one and ran the quick and deeper searches which found 2 different partitions but with a note that the partition could not be recovered.

 

I have no idea about what I can do or try next and any help or suggestion would be greatly appreciated.

Thanks for taking the time to read this.



BC AdBot (Login to Remove)

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users