Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Connecting to OCE Scanner in local subnet thru "Shortcut folder"


  • Please log in to reply
2 replies to this topic

#1 drwmbt

drwmbt

  • Members
  • 98 posts
  • OFFLINE
  •  
  • Local time:07:09 PM

Posted 31 May 2013 - 09:23 AM

Hi guys,

 

A problem that is plaguing an office where I work at. This OCE Commercial style scanner was installed before I get on board with my team here and they setup shortcuts on a network share to access the FTP'd directory for their digital scans thru windows explorer

 

Only 1 Windows 7 machine out of 15 is NOT connecting it keeps trying to launch internext explorer instead of indexing into the FTP with windows explorer.

 

All settings have been checked and they are identical machines built from the same image, on the same OEM workstations.

 

I even tried turning off passive FTP mode in internet options on the 1 computer that isnt working and that didnt help even though all the others have passive mode ON and can still connect directly thru windows explorer.

 

Easy thing would be for the employee to just "deal with it" theres no reason why clicking the files from ie (when it prompts for download) couldnt be saved to the Hard drive that way, but i still am curious why this is happening on identical damn machines.

 

ETA: I am not sure if networking was a better place for this post although all other machines ARE working properly and even an windows xp machine has zero problems connecting to this FTP'd directory. It has to be windows 7 issue causing this problem.

 

 

Thanks for any insight,

DRW


Edited by drwmbt, 31 May 2013 - 10:30 AM.


BC AdBot (Login to Remove)

 


#2 drwmbt

drwmbt
  • Topic Starter

  • Members
  • 98 posts
  • OFFLINE
  •  
  • Local time:07:09 PM

Posted 31 May 2013 - 03:00 PM

Ok guys, turns out this is in fact a windows 7 problem.

 

As i investigated online I was told to add certain keys to the registry. I am EXTREMELEY weary of doing things of this nature (and knowing that several other PC's worked) so I decided to simply compare the two registries for any inconsistencies and lo and behold there was an entire Key missing from the registry named "FTP" in the HK_CLASS_ROOT section of the registry. Do not hesitate to create a .reg with this information if your "FTP" key is missing and you do not have a working registry from an identical computer to compare with:

 

 

Open notepad and copy/paste/save the below registry fix as "Regfix.reg"

 

Windows Registry Editor Version 5.00
 
[HKEY_CLASSES_ROOT\ftp]
 @="URL:File Transfer Protocol"
 "AppUserModelID"="Microsoft.InternetExplorer.Default"
 "EditFlags"=dword:00000002
 "FriendlyTypeName"="@C:\\Windows\\system32\\ieframe.dll,-905"
 "ShellFolder"="{63da6ec0-2e98-11cf-8d82-444553540000}"
 "Source Filter"="{E436EBB6-524F-11CE-9F53-0020AF0BA770}"
 "URL Protocol"=""
 
[HKEY_CLASSES_ROOT\ftp\DefaultIcon]
 @=hex(2):25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,00,74,00,25,\
   00,5c,00,73,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,75,00,72,00,\
   6c,00,2e,00,64,00,6c,00,6c,00,2c,00,30,00,00,00
 
[HKEY_CLASSES_ROOT\ftp\shell]
 @="open"
 
[HKEY_CLASSES_ROOT\ftp\shell\open]

 

 

I cannot for the life of me explain why two identical computers populated with identical images of windows 7 would have such a minute inconsistency in the registry but this absolutely fixed the problem (after a restart of course)


Edited by drwmbt, 31 May 2013 - 03:04 PM.


#3 hamluis

hamluis

    Moderator


  • Moderator
  • 55,887 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:07:09 PM

Posted 31 May 2013 - 03:50 PM

Thanks for sharing your solution...happy computing :).

 

Louis






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users