Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

To Help With The "memory Leaks" In Firefox


  • Please log in to reply
6 replies to this topic

#1 nosnhoj#3

nosnhoj#3

  • Members
  • 245 posts
  • OFFLINE
  •  
  • Location:127.0.0.1
  • Local time:06:04 PM

Posted 12 April 2006 - 07:13 PM

Hello,


I used to ignore the fact that the cache in Firefox would take no time at all to become full, as monitored by an extension in the status bar. And also the fact that with the addition of many extra's, RAM usage would also suffer a bit more than I would like. But after reading this and trying it out, I am a much happier human being.

To help with the "memory leaks" in Firefox:

1. Open about:config in Firefox and Right-Click in the page to create a New --> Boolean.

2. Cut/Paste the following into the text field that pops up:
config.trim_on_minimize

3. Select True, press Enter and Restart Firefox.

This has worked great in my browser. A note as well, this is a Windows tip only, and not for Mac. Here is the link for the whole story: Cybernet Technology News



Hope this helps,

nos :thumbsup:
When I'm right, I'm right....
And when I'm wrong, I could have been right....
So I'm still right, cause I could have been wrong.

BC AdBot (Login to Remove)

 


#2 nosnhoj#3

nosnhoj#3
  • Topic Starter

  • Members
  • 245 posts
  • OFFLINE
  •  
  • Location:127.0.0.1
  • Local time:06:04 PM

Posted 07 May 2006 - 12:10 AM

Hi all,

Here are some additional settings that are usefull for memory usage in Firefox:

1. Open a new tab and type about:config into the Address bar. Press Enter. Locate the following: browser.cache.memory.enable and make sure that it's value is set to true

2. Right-click any blank area in the about:config window and choose New --> Integer from the pop-up menu.

3. The New Integer Value box will open. Copy and paste this setting name into the open dialog box: browser.cache.memory.capacity

4. In the Enter Integer Value box that opens, enter -1 to preserve Firefox's default operational mode which are set as follows:

Physical RAM 	 Memory Cache (in KB)
32 MB 				 2048 
64 MB 				 4096
128 MB 				8192
256 MB 				14336
512 MB 				22528
1 GB 				  32768
2 GB 				  45056
4 GB 				  59392

5. To customize the setting to your computer's physical memory, start with these suggestions, and try it out:
For RAM sizes between 512BM and 1GB:-----> 15000
For RAM sizes between 128MB and 512M:-----> 5000
Note: If you have less than 128MB of RAM, you may consider adding more if you use Firefox as your primary browser, otherwise leave your setting at the default level.

After a bit of surfing, you should have an idea how Firefox is reacting to the initial decrease in memory usage. If you have 1 GB of RAM for example, you may find that increasing the value to 20000 KB works well.

This can be monitored by opening the Task Manager (Ctrl+Alt+Del)or(Right-click task bar-->choose Task Manager) If you don't like the settings, or want to go back to the default setting for comparison, set the value back to -1.

Here is the page on MozillaZine that discusses this topic: Browser.cache.memory.capacity

Hope this helps,

nos :thumbsup:
When I'm right, I'm right....
And when I'm wrong, I could have been right....
So I'm still right, cause I could have been wrong.

#3 nosnhoj#3

nosnhoj#3
  • Topic Starter

  • Members
  • 245 posts
  • OFFLINE
  •  
  • Location:127.0.0.1
  • Local time:06:04 PM

Posted 04 June 2006 - 03:07 AM

To help with the "memory leaks" in Firefox:

1. Open about:config in Firefox and Right-Click in the page to create a New --> Boolean.

2. Cut/Paste the following into the text field that pops up:
config.trim_on_minimize
3. Select True, press Enter and Restart Firefox.

This has worked great in my browser.




I posted this awhile back, and at the time it was true, but lately I had seen a performance decrease, especially when launching Firefox, Minimizing and Maximizing FF when other "memory hogging programs" were also running, and even a little browsing lag. As for the browsing lag, I didn't actually notice this until I applied the settings below.

First Change:

1. Open about:config in Firefox and Right-Click in the page to create a New --> Boolean.

2. Cut/Paste the following into the text field that pops up:
config.trim_on_minimize
3. Select False, press Enter and Restart Firefox.


What seemed to be happening was since I run several large applications at once, and switch between them constantly, FF was giving away it's RAM when it didn't need to, so after switching from say Photoshop, back to FF, I would get a lag. After changing this setting to false, the lag went away considerably.

Second Change:

Disable Google Prefetch: (not to be confused with windows prefetch)

1. Type "about:config" the address bar.

2. Scroll down to the setting "network.prefetch-next" and set the value to "False".

Disableing this increased my browsing speed considerably, and now I am not getting things in my cache that I havn't even visited, like cookies and images. Here is the Google page that talks about this setting:

http://www.google.com/help/features.html#prefetch


Change Three:

Install the Firefox Preloader.

Go to http://sourceforge.net/project/showfiles.php?group_id=129464 and download this program.

Make sure before you install this program that you determin about how long FF currently takes to load. Then, after installing this, see if it actually does speed the launching of FF up.


These tips are from my own personal tweaking, and depending on the amount of features you have added to FF, your results may vary greatly. Also, none of the above is harmfull to your PC, and all settings are totally reversable, with the exception to the Firefox Preloader, which because it is a third party program, it has it's own set of precautions.

These tips may benefit users that utilize many extra features that FF offers. I mention this because I am one such user.


nos :thumbsup:
When I'm right, I'm right....
And when I'm wrong, I could have been right....
So I'm still right, cause I could have been wrong.

#4 noelckc

noelckc

  • Members
  • 86 posts
  • OFFLINE
  •  
  • Local time:11:04 AM

Posted 12 July 2006 - 04:08 AM

How do i undo the first thing?the first reply, how do i undo it?

#5 hillbillygreek

hillbillygreek

  • Members
  • 397 posts
  • OFFLINE
  •  
  • Location:SC
  • Local time:08:04 PM

Posted 12 July 2006 - 11:48 PM

In about:config, scroll down to config.trim_on_minimize, right click on it & choose reset. That will erase the value. The next time you open Firefox, the entire entry should be gone.

#6 toshibauser

toshibauser

  • Members
  • 174 posts
  • OFFLINE
  •  
  • Local time:08:04 PM

Posted 14 July 2006 - 06:07 PM

hi, i did the first thing, but what exactly did it accomlish???

#7 hillbillygreek

hillbillygreek

  • Members
  • 397 posts
  • OFFLINE
  •  
  • Location:SC
  • Local time:08:04 PM

Posted 15 July 2006 - 05:42 PM

Read the article Here .




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users