Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

windows wont boot, black screen with blinking underscore


  • Please log in to reply
3 replies to this topic

#1 macros

macros

  • Members
  • 4 posts
  • OFFLINE
  •  
  • Local time:05:26 PM

Posted 28 May 2013 - 08:33 AM

Hi there,

I have ACER 5745 Model, and have windows 7 ultimate and Linux OS on my drives. Windows 7 is in C drive and Linux is in E drive. While I was working on my windows 7 system, the electricity went off and since my battery is dead, so my system shut down immediately while I was working on internet. Well this thing has happened many times before but every-time I was able to restart my system. But since last time whenever I am trying to boot my windows only a black screen appears with an underscore blinking in top left corner. I have later on logged into Linux to check whether it is functioning or not, and it is working fine, but when I try to log into windows it does not boot up. When I press power button, it goes past POST, till the point where options appear whether I want to choose Linux or Windows. When I choose Linux it works fine but with windows the problem of black screen with blinking underscore appears.I have tried everything from using F2 and going into 'set up' , pressing F12 and going into 'boot', but nothing seems to work. I have tried F8 to check into safe mode but of no use as safe mode doesn't appear even after repeatedly pressing F8. I have then checked "Memtest 86" and have done 11 passes. I have tried to boot from CD to do system repair but the system doesn't pick up even my CD, even though I selected the boot option "boot from CDROM". I have also tried removing my battery and allowing my system to cool down but that also didn't worked. Please dont ask me to format as I have important files and softwares on my C-Drive. So looking for a solution. The only thing that is working is Linux, and I am  able to retrieve some of my files through linux, but I need to work on windows. Much help appreciated!!! below mentioned are the commands that I have tried on Linux TILL NOW!!


Edited by macros, 28 May 2013 - 03:10 PM.


BC AdBot (Login to Remove)

 


#2 macros

macros
  • Topic Starter

  • Members
  • 4 posts
  • OFFLINE
  •  
  • Local time:05:26 PM

Posted 28 May 2013 - 01:44 PM

I have also ran a command on Linux now "sudo fdisk -l" and following was the result



Disk /dev/sda: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders, total 976773168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x2bd2c32a
 
   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *          63   104454629    52227283+   7  HPFS/NTFS/exFAT
/dev/sda2       104454691   976771071   436158190+   f  W95 Ext'd (LBA)
/dev/sda5       104454693   534530744   215038026    7  HPFS/NTFS/exFAT
/dev/sda6       534530808   933532081   199500637    7  HPFS/NTFS/exFAT
/dev/sda7       933533696   973121535    19793920   83  Linux
/dev/sda8       973123584   976771071     1823744   82  Linux swap / Solaris


SO CAN ANYONE HELP ME NOW!!! OR I WOULD HAVE TO BREAK IT DOWN :smash:


#3 macros

macros
  • Topic Starter

  • Members
  • 4 posts
  • OFFLINE
  •  
  • Local time:05:26 PM

Posted 28 May 2013 - 03:07 PM

and from sudo update-grub following was seen

Generating grub.cfg ...
Found linux image: /boot/vmlinuz-3.2.0-35-generic
Found initrd image: /boot/initrd.img-3.2.0-35-generic
Found linux image: /boot/vmlinuz-3.2.0-34-generic
Found initrd image: /boot/initrd.img-3.2.0-34-generic
Found linux image: /boot/vmlinuz-3.2.0-33-generic
Found initrd image: /boot/initrd.img-3.2.0-33-generic
Found linux image: /boot/vmlinuz-3.2.0-32-generic
Found initrd image: /boot/initrd.img-3.2.0-32-generic
Found linux image: /boot/vmlinuz-3.2.0-31-generic
Found initrd image: /boot/initrd.img-3.2.0-31-generic
Found linux image: /boot/vmlinuz-3.2.0-30-generic
Found initrd image: /boot/initrd.img-3.2.0-30-generic
Found linux image: /boot/vmlinuz-3.0.0-12-generic
Found initrd image: /boot/initrd.img-3.0.0-12-generic
Found memtest86+ image: /boot/memtest86+.bin
Found Windows 7 (loader) on /dev/sda1
done

and for sudo uname -a, it shows following

-Aspire-5745 3.2.0-35-generic #55-Ubuntu SMP Wed Dec 5 17:45:18 UTC 2012 i686 i686 i386 GNU/Linux

and for sudo lsb_release, it says

No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 12.04.1 LTS
Release: 12.04
Codename: precise

and also I ran the following command 'sudo dd if=/dev/sda of=mbr.bin bs=512 count=1" and following was seen:

1+0 records in
1+0 records out
512 bytes (512 copied, 6.0347e-05 s, 8.5 MB/s

much help appreciated, I have gone nuts, as I have been working to solve this thing for more than 24 hours!!  :smash:


Edited by macros, 28 May 2013 - 03:08 PM.


#4 Chris Cosgrove

Chris Cosgrove

  • Moderator
  • 6,744 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Scotland
  • Local time:12:56 PM

Posted 31 May 2013 - 05:40 PM

Hi,

 

While my experience with Linux is just above the zero mark, I have run into this problem with Windows. The last time, after two hours of frustration, I made a note of at least one solution. Boot up your computer and tap the F8 key during the BiOS screen. With a bit of luck you will be taken to a screen which calls itself 'Boot choice' or something similar. Here you will find a list of the drives on your computer. It looks very similar to the Boot priority list in the normal BIOS screens - which was the source of my frustration.

 

Select your hard drive from this list, press enter, and you should be able to boot Windows.

 

If pressing F8 doesn't take you to this screen, shut down and try again. No guarrantees, but this solved my problem when all I was getting was the blank black screen with a blinking cursor.

 

Chris Cosgrove






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users