Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

FlashOffliner/ILMerge/other over arching issues


  • Please log in to reply
No replies to this topic

#1 reenmini

reenmini

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:02:41 PM

Posted 22 May 2013 - 03:08 PM

Hey there everyone! I just joined because I am unable to figure out my problem on my own! YAY IGNORANCE! This is a long, unfortunate issue for me, so please be patient.

 

Backstory:

 

I am an avid fan and user of the program "Flash Offliner" which I have no doubt many of you may be aware of. I recently had to do a clean reinstall of my operating system to fix a boot issue *which is now gone thankfully*...when I realized after the fact that I did not back up any of my drivers or relevant dlls. WHOOPS.

 

Fortunately, everything I use works just fine still...except for FlashOffliner, which will load up like normal but fail to load the flash FOPS it uses, and instead generates a blank screen which reads like a failed internet connection page that plainly states "Navigation to the webpage was cancelled". Furthermore, when closing that screen it produces a file download pop up displaying the SWF of the flash game I just tried to open, asking if I wish to save it or find a file online to open it.

 

That last detail is what has vexed me the most, for what I have tried to solve it is thus:

 

1-Google produces NO HELP WHATSOEVER in regards to flash offliner. No support pages, no obscure forum posts, not one iota of help. DeadSoul, the original creator, has LONG SINCE vanished from the face of the earth along with the original website for his work. The ONLY thing I could find were download links for the program itself from various sources.

2-I happen to have a laptop on which FlashOffliner still works perfectly. I used Dependency Walker to identify the dlls which it uses to run and I individually copied them all into a new folder with the Flash Offliner exe in order to try statically loading it on the computer which it doesn't work on. NO DICE.

3-I'm now trying to use ILMerge to combine the dll's with the exe, in the hopes that making it a completely standalone program might fix the issue. The command I'm using in the elevated command line is:

 

"C:\Users\Me\Desktop\FlashOffliner\ILMerge.exe" C:\Users\Me\Desktop\FlashOffliner\FlashOffliner.exe C:\Users\Me\Desktop\FlashOffliner\*.dll /target:winexe /wildcards /out:C:\Users\Me\Desktop\Test.exe

 

It generates the following error:

 

ILMerge.Merge: Could not load assembly from the location 'C:\Users\Me\Desktop\FlashOffliner\FlashOffliner.exe'. Skipping and processing rest of arguments.

       at ILMerging.ILMerge.Merge()

       at ILMerging.ILMerge.Main(String[] args)

 

The locations listed are all correct, so I'm not at all sure why ILMerge is failing to load the exe for Flash Offliner. Both of the computers in this situation are running Windows 7: the laptop is running ultimate. The desktop is running home premium. I don't imagine that should make a difference, but the information is there if anyone knows otherwise.

 

 

That's it! Tell me what I'm doing wrong, for the love of all that is sacred.



BC AdBot (Login to Remove)

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users