Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Is my firewall on?


  • Please log in to reply
5 replies to this topic

#1 Zone out

Zone out

  • Members
  • 88 posts
  • OFFLINE
  •  
  • Local time:04:28 AM

Posted 21 May 2013 - 05:49 AM

Hi.

 

I am new to Linux and I am using a live CD with mint mate.  I wanted to open GUFW so I could see for myself that the firewall was on for when I go on the net, but there seems to be no way to open it.  If someone knows how to open it could you let me know how. 

 

The other thing that I would like to know is if the firewall is on by default because when I try to find out I get these confusing results.

 

sudo ufw status   =>   status: inactive

 

sudo ufw enable   =>  firewall is active and enabled on system startup

 

sudo ufw status   =>   status: active

 

So is the firewall "active and enabled on system startup", and if so why does it say inactive when I first ask?



BC AdBot (Login to Remove)

 


#2 rburkartjo

rburkartjo

  • Members
  • 3,971 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:austin,tx
  • Local time:01:28 PM

Posted 21 May 2013 - 06:24 AM

open a terminal and run this command sudo ufw status. it will ask your for you password enter it then hit the enter key on your help board. you should then get this message in the terminal

Status: active

 

here is an example

 

ray@ray-desktop:~$ sudo ufw status
[sudo] password for ray: 

Status: active

 


quote:He that would live in peace & at ease, Must not speak all he knows,nor judge all he sees.'

#3 Zone out

Zone out
  • Topic Starter

  • Members
  • 88 posts
  • OFFLINE
  •  
  • Local time:04:28 AM

Posted 21 May 2013 - 09:06 PM

Thanks for the post.

 

I did use the sudo ufw status command, (it does not ask for a password) at first it says inactive.  Then when I enter "sudo ufw enable" it says " firewall is active and enabled on system startup".  If I enter sudo ufw status then it says active.  What I don't understand is why it initially says the firewall is inactive but when I turn it on it says it was "active and enabled on sartup".



#4 Bezukhov

Bezukhov

    Bleepin' Jazz Fan!


  • Members
  • 2,618 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Providence, R.I.
  • Local time:02:28 PM

Posted 21 May 2013 - 11:30 PM

Thanks for this thread. I have been using linux for a while and never gave a thought to a firewall. Now I will give it plenty of thought.


To err is Human. To blame it on someone else is even more Human.

#5 jacksonbird03

jacksonbird03

  • Banned Spammer
  • 29 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:11:58 PM

Posted 22 May 2013 - 02:28 AM

Hey for your query you just try this few steps...

 

open a terminal and run this command sudo ufw status. it will ask your for you password enter it then hit the enter key on your help board. you should then get this message in the terminal

Status: active, if active means your firewall is active...



#6 Gordon C

Gordon C

  • Members
  • 68 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:NC
  • Local time:02:28 PM

Posted 23 May 2013 - 11:16 AM

My box acted the same way: inactive, then active after being enabled. When I subsequently rebooted and then asked for status it reported active without having to be enabled again. So..... you have to enable it one time then it runs on boot automatically. BTW, I'm running Ubuntu 12.04. Other versions may exhibit different behaviors. Thanks for the question.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users