Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Problem with webcam driver


  • Please log in to reply
6 replies to this topic

#1 Rhabdo

Rhabdo

  • Members
  • 24 posts
  • OFFLINE
  •  
  • Gender:Female
  • Local time:10:06 AM

Posted 17 May 2013 - 05:20 PM

I have a Dell Inspiron 1545 running Windows 7. Today I tried to use the webcam and it wouldn't work. The waiting signal (blue spinning circle) just kept going but the screen stayed black. Then I started getting messages that a USB port on my computer wasn't working properly. I went to the Dell website to run a webcam diagnostic.

 

This is what they said:

 

"Dell PC Diagnostics did not identify any hardware faults. 
Good news! No hardware issues were found during the scan. If you’re still experiencing problems with your system you might try one of the following steps:
• Perform a System Restore to revert back to a previous configuration before the problem began
• Visit the Drivers and Downloads page to ensure your system is up to date
• Check the Troubleshooting page for hot topics or top solutions related to the issue you’re experiencing
 
Depending on the outcome of tests performed during the scan, additional troubleshooting may also be available in the test summary below. Scroll down to view these results.
 
Camera:Integrated Webcam
Capture To Screen Test    Passed 
Capture To File Test    Passed"
 
This same problem happened about 4-5 months ago when I was getting help for the prioritize VPN virus/malware(?). The moderator sent me a link where I could download the drivers and it worked great! However, I don't have the link anymore.
 
I do have the CD that came with my computer though. So I uninstalled the driver for the webcam and tried to use the CD to re install; it turns out there is also something wrong with my CD driver (it says the CD is blank and wants me to indicate if I want to use it like a USB or make it re-writable).
 
I tried to find the driver online but ended up falling prey to one of those schemes where you have to download 20 other programs in the hopes of getting what you want but never do. I know I should know better, but it was cleverly disguised. This led to problems very reminiscent of my prioritize VPN fiasco. So I decided the best course of action would be to restore to a prior point in time. Which I did. My computer tells me it was successful. While the DELL webcam center icon is back nothing happens when I click on it. Literally nothing.
 
I would appreciate any help or guidance you could give me. 
 
If this is the wrong forum to post in I apologize and hope someone can point me in the right direction. 
 
Thank you in advance!

Edited by hamluis, 18 May 2013 - 07:09 AM.
Moved from Win 7 to Internal Hardware - Hamluis.


BC AdBot (Login to Remove)

 


#2 caperdog

caperdog

  • BC Advisor
  • 954 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Nova Scotia
  • Local time:11:06 AM

Posted 18 May 2013 - 09:53 AM

http://www.dell.com/support/troubleshooting/ca/en/cadhs1/Product/inspiron-1545

 

Drivers and Downloads tab

Input catagory



#3 Rhabdo

Rhabdo
  • Topic Starter

  • Members
  • 24 posts
  • OFFLINE
  •  
  • Gender:Female
  • Local time:10:06 AM

Posted 20 May 2013 - 10:08 AM

I wasn't able to find a webcam driver at that link. However, I'm not sure I need one as it appears that my webcam will work fine with programs like Skype. I just can't open the Dell Webcam Central program. Does that mean the driver is ok? 

 

On the support site there was a link to download the Webcam Central program itself, which I did and then restarted my computer . . . and it still doesn't work.

 

Any suggestions?



#4 Anshad Edavana

Anshad Edavana

  • Members
  • 2,805 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:India
  • Local time:08:36 PM

Posted 20 May 2013 - 10:12 AM

Hi

 

Yes, your webcam is OK as you can open it in Skype. Uninstall the "Webcam central" software and re-install it. Here is the download link -

 

http://ftp.us.dell.com/monitors/Dell_SX2210-Monitor_Webcam%20SW%20RC1.1_%20R230103.exe



#5 Rhabdo

Rhabdo
  • Topic Starter

  • Members
  • 24 posts
  • OFFLINE
  •  
  • Gender:Female
  • Local time:10:06 AM

Posted 21 May 2013 - 08:18 PM

My computer won't let me uninstall Webcam Central. I click "uninstall" and wait and nothing happens.

 

If I get impatient and click "uninstall" again right away a message pops up that I have to wait for the current program to finish uninstalling, so it's doing something.

 

Thoughts?



#6 Anshad Edavana

Anshad Edavana

  • Members
  • 2,805 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:India
  • Local time:08:36 PM

Posted 22 May 2013 - 07:11 AM

Hi

 

You can use Revo Uninstaller to remove corrupted programs. Here is the download link. 

 

http://www.revouninstaller.com/revo_uninstaller_free_download.html

 



#7 Rhabdo

Rhabdo
  • Topic Starter

  • Members
  • 24 posts
  • OFFLINE
  •  
  • Gender:Female
  • Local time:10:06 AM

Posted 23 May 2013 - 03:45 PM

It worked! I did have to go here http://www.dell.com/support/troubleshooting/ca/en/cadhs1/KCS/KcsArticles/ArticleView?docid=266612

to find the Webcam Central program to reinstall, but it seems to be working fine now.

 

Thanks for your help :)






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users