Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Difficulty networking from Windows 7 to Win XP computers


  • Please log in to reply
12 replies to this topic

#1 BobTroll

BobTroll

  • Members
  • 37 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Leicester, UK
  • Local time:09:13 AM

Posted 13 May 2013 - 03:55 AM

I am in the process of replacing an ageing Hewlett Packard laptop computer.  It has always connected wirelessly to the Internet via a local area network, which includes the following devices:

 

Huawei EchoLife HG520b wireless ADSL router.  Wireless protocols 802.11b and 802.11g.  IP address 192.168.1.1.  I have configured the DHCP server on the router, so that it allocates a different fixed IP address to designated computers.

 

LAN Network storage drive.  Host name "NAS".  Fixed IP address "192.168.1.253".  Group name "WORKGROUP".  No domain.  SMB Server enabled (Read & Write).  User Name "Guest".  SMB password = null.  Documents are saved in the "PUBLIC" folder on “NAS”.  Wired Ethernet connection to the router.

 

Medion Desktop Computer.  Windows XP 32-bit Home Edition (SP3).  IP address 192.168.1.13 (allocated by DHCP).  Computer Name "DESKTOP".  Workgroup name WORKGROUP".  No domain.  User Name "Bob L****".  The User Account is not password protected.  The Guest User account is disabled.  This computer connects to the router with a wired Ethernet connection.  File and printer sharing are enabled.  Avast Antivirus.  Zone Alarm free firewall.  The firewall is configured to place the IP addresses of my specified computers and the LAN drive in the trusted zone.

 

HP LaserJet LJ1018 printer.  USB connection to the "DESKTOP" computer, with printer sharing enabled.

 

(Old) Laptop computer.   Windows XP 32-bit Professional Edition (SP3).  IP address 192.168.1.11 (allocated by DHCP).  Computer Name "HP-LAPTOP".  Workgroup name "WORKGROUP".  No domain.  User Name "Bob L****".  The User account is password protected.  This computer connects to the router wirelessly.  File and printer sharing are enabled.  Avast Antivirus.  Zone Alarm free firewall.  The firewall is configured to place the IP addresses of my other specified computers and the LAN drive in the trusted zone.

 

I am trying to configure a new laptop computer:

 

(New) Laptop computer.  Windows 7, 64-bit Professional Edition (SP1).  IP address 192.168.1.12 (allocated by DHCP).  Computer Name "SAMSUNG-LAPTOP".  Workgroup name "WORKGROUP".  No domain.  Network type is "Home", without a Windows 7 Homegroup.  (However, I have also tried "Work" - which made no difference.)  User Name "Bob L****".  The User account is password protected (same User Name and password as the HP-LAPTOP).  I installed Avast Antivirus, but experienced networking problems.  Consequently, I uninstalled Avast and installed Microsoft Security Essentials.  Windows firewall. 

 

The advanced sharing settings of the "SAMSUNG-LAPTOP" are:

 

Network discovery - on

File and printer sharing - on

Public folder sharing - on

Media streaming - on

File sharing for devices that use 40 or 56 bit encryption - on

Password protected sharing - off

Allow windows to manage homegroup connections - on (but not applicable)

 

The “DESKTOP” and “HP-LAPTOP” computers can access shared files on every computer (including the “SAMSUNG-LAPTOP”).  They also have full access to shared files on the “NAS” drive via the SMB server.  The “HP-LAPTOP” can print wirelessly to my laser printer (using the USB connection from the “DESKTOP” computer).

 

However, I am experiencing great difficulty accessing the network from the Windows 7 “SAMSUNG-LAPTOP”.  The situation is as follows:

 

When I configured the Windows 7 computer, Network Discovery identified all of the other devices - and I was able to access shared files on the “DESKTOP” computer.  I installed the HP LaserJet as a network computer and I also mapped four shared drives, which reside on the “DESKTOP” computer.  Everything seemed to work OK.

 

However, the “SAMSUNG-LAPTOP” has never managed to access shared files on the “HP-LAPTOP” or the “NAS” drive.  If I select either of these external devices, a Windows security pop-up asks me to provide the following information:

 

Enter Network Password - Enter your password to connect to:  “DESKTOP”  (or “HP-LAPTOP” or “NAS”)

The next field, which is labelled SAMSUNG-LAPTOP\Bob L..., asks me to enter a password.

 

However, I have never created a "Network Password" - and it makes no difference whether I enter a user name (and password for the “HP-LAPTOP” or “NAS” drive) or leave the fields empty.  The error message always reads "Logon failure.  unknown user name or bad password."

 

More recently, I have experienced the same problem, when I try to access shared files on the “DESKTOP” computer from the “SAMSUNG-LAPTOP”.  Furthermore, when I open the Network & Sharing Center and click on "See full map", the menu reports that Windows cannot discover any computer or device.

 

However, the router and the other devices respond OK, if I ping them from the “SAMSUNG-LAPTOP”.  Furthermore, the list of Network folders in Windows Explorer still includes:

 

“DESKTOP”

“HP-LAPTOP”

“NAS”

“SAMSUNG-LAPTOP”

 

I have discovered that following “workaround” usually enables the “SAMSUNG-LAPTOP” to access the network printer and shared files on the “DESKTOP” computer.

 

  1. Reboot the “SAMSUNG-LAPTOP”
  2. Following the reboot, the “SAMSUNG-LAPTOP” reports that it cannot open mapped drives.  This might be because Windows Explorer attempted to open the mapped drives, before it had established a wireless connection to the router.
  3. Open Network and Sharing Center / Advanced Sharing settings.  Turn off network discovery and file and printer sharing.
  4. Return to Windows Explorer and select Network in the folder list.  This generates a pop-up warning that Network Discovery is turned off.  Click on the warning to enable Network Discover and File Sharing.  Click on View / Refresh.
  5. This workaround enables the “SAMSUNG-LAPTOP” to access shared files - and print via the laser printer on the DESKTOP computer.  However, it does not allow me to access “HP-LAPTOP” or the “NAS” drive.  And sometimes, I need to repeat the process several times. 

 

I have Googled this problem - and it seems many people have experienced similar difficulties. Consequently, I have tried the following suggestions:

 

In Local Security Policy/Security Options -

Accounts: Limit local use of blank passwords to console logon only - changed to "disabled"

Network security: LAN Manager authentication level - changed to "LM and LTLM - use NTLMv2 session security if negotiated"

 

I have not changed:

Domain controller: LDAP server signing requirements (not defined)

Microsoft network client: Send unencrypted password to third-party SMB servers (Disabled)

Network access: Sharing and security model for local accounts (Classic - local users authenticate as themselves)

 

I have also experimented, by disabling the anti-virus and Zone Alarm firewall on the XP computers (on a temporary basis).  Unfortunately, none of these suggestions made any difference.

 

I have never experienced networking problems between the older Windows XP computers (Win XP to Win XP or Win XP to “NAS” drive).  The Windows XP computers can also access shared files on the new Windows 7 computer.  This problem only seems to affect outward networking from the Windows 7 64-bit computer.

 

I am at my wits end, and shall appreciate some help and advice, please.

 

 



BC AdBot (Login to Remove)

 


#2 chrisd87

chrisd87

  • Members
  • 811 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:NC
  • Local time:03:13 AM

Posted 13 May 2013 - 07:38 AM

Have you tried typing guess as a username and no password to see if it'll let you in? I've heard about the same setup on people's pc and the username guess would let them in.


"Like car accidents, most hardware problems are due to driver ɹoɹɹǝ."

 


#3 BobTroll

BobTroll
  • Topic Starter

  • Members
  • 37 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Leicester, UK
  • Local time:09:13 AM

Posted 13 May 2013 - 09:01 AM

Have you tried typing guess as a username and no password to see if it'll let you in? I've heard about the same setup on people's pc and the username guess would let them in.

 

Thank you.

 

I have just tried that with the HP-LAPTOP (I had to enable the guest account on that machine).  Unfortunately, it didn't work - and I received an error message:

 

\\HP-LAPTOP is not accessible. You might not have permission to use this network resource. Contact the administrator of this server to find out if you have access permissions.  Login failure: account currently disabled.

 

Then, I disabled the Zone Alarm firewall on HP-Laptop.  That enabled the Windows firewall automatically, so I also needed to disable the Windows firewall. 

 

I tried to establish a connection once again, with the same result.

 

I get the same error message, if I try to access shared documents in the Guest account on the NAS server.



#4 chrisd87

chrisd87

  • Members
  • 811 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:NC
  • Local time:03:13 AM

Posted 13 May 2013 - 11:15 AM

Also I believe you posted this in your first post, but you do have the same account on the windows 7 pc "Samsung" as you do on the "HP" ?

 

Also make sure that these services are enabled on all computers and set to automatic:

 

       o Computer Browser
       o DHCP Client
       o DNS Client
       o Network Connections
       o Network Location Awareness
       o Remote Procedure Call (RPC)
       o Server
       o TCP/IP Netbios helper
       o Workstation


Edited by chrisd87, 13 May 2013 - 12:27 PM.

"Like car accidents, most hardware problems are due to driver ɹoɹɹǝ."

 


#5 BobTroll

BobTroll
  • Topic Starter

  • Members
  • 37 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Leicester, UK
  • Local time:09:13 AM

Posted 13 May 2013 - 01:03 PM

Thank you.

 

Yes.  The User Name is the same on the Samsung, the HP-LAPTOP and also on the Medion DESKTOP.

 

I have checked the services on the three computers.  The ones you have identified are definitely enabled (and started).

 

These services do not apply to the SMB server on the NAS drive.  Fortunately, network difficulties with the NAS drive are not a major problem, because I can use Filezilla (or Internet Explorer) to access files, via the FTP protocol.

 

However, I do not understand why the Samsung can never access shared files on the HP-LAPTOP - or why I need to adopt a tortuous "workaround", to access my files on the Medion DESKTOP computer.



#6 hispaladin

hispaladin

  • Members
  • 245 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Middle of a corn field
  • Local time:03:13 AM

Posted 13 May 2013 - 04:30 PM

 

However, the “SAMSUNG-LAPTOP” has never managed to access shared files on the “HP-LAPTOP” or the “NAS” drive.  If I select either of these external devices, a Windows security pop-up asks me to provide the following information:

 

Enter Network Password - Enter your password to connect to:  “DESKTOP”  (or “HP-LAPTOP” or “NAS”)

The next field, which is labelled SAMSUNG-LAPTOP\Bob L..., asks me to enter a password.

 

The reason that I can see as to why it will not accept your username and password even though they are the same is that it is referring to the account on the samsung (SAMSUNG-LAPTOP\Bob L....)  if there is an option to use a different username or account enter HP-LAPTOP\Bob L... and your password and see if it will allow you in.  



#7 Sneakycyber

Sneakycyber

    Network Engineer


  • BC Advisor
  • 6,130 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Ohio
  • Local time:04:13 AM

Posted 13 May 2013 - 09:55 PM

Have you disabled simple file sharing on the Xp pro machine? If your using the same name and password on both computers you need to have password protected sharing turned ON on both computers. Try mapping a network drive to the HP-Laptop's shared folder and select use different username and password. Use HP-Laptop\(your username) then type in your passwords.

Edit: have you read any of the numerous threads on here for networking Windows 7 and Windows XP such as This one

Edited by Sneakycyber, 13 May 2013 - 09:58 PM.

Chad Mockensturm 
Network Engineer
Certified CompTia Network +, A +

#8 BobTroll

BobTroll
  • Topic Starter

  • Members
  • 37 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Leicester, UK
  • Local time:09:13 AM

Posted 21 May 2013 - 10:33 AM

Thank you.

 

I have searched various forums on this and other websites, but without finding a definitive answer to this specific problem

 

Your previous reply at http://www.bleepingcomputer.com/forums/t/477124/network-win7-and-xp/ was helpful and I installed LLTD on the Win XP computers.  This has enabled the Win 7 computer to display the Network Map correctly.  Following the installation of LLTD, the Network Map shows the following connections:

 

Samsung-Laptop and HP_LAPTOP - which are connected wirelessly to the modem/router (TROLLHAUGEN-Huawei).

The DESKTOP computer has a wired connection to TROLLHAUGEN-Huawei (via a "Switch" in the modem/router).

TROLLHAUGEN-Huawei uses an ADSL connection to the Internet

 

Win 7 also discovers the NAS drive - but states that the device cannot be placed in the map.

 

I attach a screen print, Network Map.gif

 

Windows Explorer lists the following devices under "Network":

 

DESKTOP

HP-LAPTOP

NAS

SAMSUNG-LAPTOP

 

I attach a screen print, Windows Explorer.gif

 

Unfortunately, installation of LLTD has not resolved the fundamental problem.  Win 7 still demands a Network Password, if I try to establish a connection from the Samsung laptop to the HP_LAPTOP or the NAS drive - and it will not accept any User Name or password that I enter.

 

Turning to the settings on the XP pro machine, simple file sharing is enabled.

 

The Sharing and Security model for local accounts (in Local Security Policy on the XP Pro machine) is set as "Guest only - local users authenticate as Guest".  I tried changing this setting to  "Classic - local users authenticate as themselves" - which made no difference.

 

I had previously mapped several shared drives on the Win XP DESKTOP machine.  However, when I tried to map a drive on the Win XP Pro laptop computer, Win 7 Pro would not allow me to connect to the Win XP Pro laptop, so I was unable to browse for folders.

 

To summarise:

 

I can establish a stable network connection from either of the XP computers to any other device on the network .

I cannot establish a network connection from the Win 7 machine to the Win XP Pro laptop or to the NAS drive.

I have discovered a "workaround", which allows me to establish a network connection from the Win 7 machine to the Win XP DESKTOP computer (and its shared printer).

 

However, there have been three interesting developments.

 

I own a  holiday cottage, with an ADSL connection to the Internet.  The computer hardware at the cottage includes a BT HomeHub 3 wireless router.  I took my Win 7 Pro laptop and the Win XP Pro laptop to the cottage - and had no difficulty establishing network connections between the computers.  The connections were stable and I did not have to adopt any "workarounds" or enter passwords.

 

My son has a Netgear router.  He also owns a NAS drive, with identical hardware, firmware and configuration to my NAS drive.  I took my Win 7 Pro laptop to my son's home - and tried to establish a network connection to his NAS drive.  My Win 7 laptop requested a user name and password.  I entered "SMB\guest" with no password - and established a trouble-free connection to his NAS drive.

 

My son visited me at home with his Windows 7 (Home Premium) 64-bit laptop computer.  He was unable to establish a connection to my NAS drive or to my Win XP computers. 

 

These factors suggest to me that there might be an issue with the TROLLHAUGEN-Huawei router at my home - and not with the Win 7 Pro laptop computer.

 

However, that does not explain why I have difficulty networking from the Win 7 machine only, and not from (or between) the Win XP machines.  Furthermore the configuration of the Router appears to be correct.

Attached Files



#9 BobTroll

BobTroll
  • Topic Starter

  • Members
  • 37 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Leicester, UK
  • Local time:09:13 AM

Posted 23 May 2013 - 01:32 PM

Eureka !!

 

I have replaced the Huawei Echolife HG520b router (wireless protocols 802.11b/g) with a TP-Link TD-W8961ND router (wireless protocols 802.11b/g/n).

 

I have copied all of the relevant settings from the Huawei router to the TP-Link router - but I have not changed any settings on the Win 7 or Win XP computers.  Having configured the new router, Internet access and networking seem to work perfectly. 

 

The Win 7 laptop can access shared files and printers on my local network without any problems whatsoever.  The XP computers still have unimpeded access to shared files on the Win 7 computer - and the Win 7 computer has allowed me to map the NAS drive. 

 

Thankfully, purchase of the new router seems to have resolved my difficulties.  However, I would love to find out why the old router worked with my previous Win XP network - but caused major problems, as soon as I added a Win 7 computer.

 

Does anyone have an answer to this conundrum?



#10 Sneakycyber

Sneakycyber

    Network Engineer


  • BC Advisor
  • 6,130 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Ohio
  • Local time:04:13 AM

Posted 29 May 2013 - 12:14 AM

Did the previous router have had a firwall between the Lan and Wireless networks? I worked on an ADSL network last year and the ISP made no hints to it in the setup of the ( determined to be GATEWAY with wireless and Statefull firewall.) Double check the manual or Advanced setup guide for the old one. The isp's response is once Our box is connected to the internet and passes diagnostic test. The rest is up to you.
Chad Mockensturm 
Network Engineer
Certified CompTia Network +, A +

#11 BobTroll

BobTroll
  • Topic Starter

  • Members
  • 37 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Leicester, UK
  • Local time:09:13 AM

Posted 29 May 2013 - 03:46 AM

Did the previous router have had a firwall between the Lan and Wireless networks? I worked on an ADSL network last year and the ISP made no hints to it in the setup of the ( determined to be GATEWAY with wireless and Statefull firewall.) Double check the manual or Advanced setup guide for the old one. The isp's response is once Our box is connected to the internet and passes diagnostic test. The rest is up to you.f the

The "user manual" for the old router was little more than a "quick start guide", which made no mention of a firewall between the LAN and wireless network.  The user interface of the router did not include any settings that might be relevant.

 

I configured the firewalls on each computer, so that the local IP addresses were in the Trusted zone.  Then, I also turned off the firewalls on each computer (as an experiment).  I even turned off the firewall that protected the router from the WAN (which did not resolve the problem).

 

Furthermore, the old router did permit traffic between the XP computers - and from the XP computers to the NAS drive.  There were no problems whatsoever, until I added the Win 7 Pro computer to the network.    



#12 Sneakycyber

Sneakycyber

    Network Engineer


  • BC Advisor
  • 6,130 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Ohio
  • Local time:04:13 AM

Posted 30 May 2013 - 07:01 PM

Hmm I will have to research a bit more that was just one setting that could cause that.
Chad Mockensturm 
Network Engineer
Certified CompTia Network +, A +

#13 BobTroll

BobTroll
  • Topic Starter

  • Members
  • 37 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Leicester, UK
  • Local time:09:13 AM

Posted 31 May 2013 - 03:02 AM

Hmm I will have to research a bit more that was just one setting that could cause that.

 

Many thanks.  No urgency, because I shall be away from home for the next two weeks.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users