Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Stronghold Crusader Vs. The Blue Screen Of Death


  • Please log in to reply
9 replies to this topic

#1 Andrew

Andrew

    Bleepin' Night Watchman


  • Moderator
  • 8,258 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Location:Right behind you
  • Local time:05:50 PM

Posted 10 April 2006 - 02:48 PM

I have a Dell Optiplex GX110 running Windows XP Pro sp2 with all critical updates and patches. The system is usually remarkably stable and this problem is surely perplexing.

Whenever I play Stronghold Crusader my computer will eventually craash and burn. Sometimes it will be fairly soon, other times I can play for hours before tBSoD ruins my fun.

I've noticed, however, that while it otherwise happens randomly, it will without fail crash if any of my archers fire at any enemies (though strangely, shooting at lions and such doesn't have the same effect.)

And I don't get the ordinary "...has encountered a problem and needs to close..." message. No, this one is much more frightening. Firsts, the game completely locks up, even the sound freaks out and sounds like a scratched CD. Then the screen goes black. Then the BSoD appears and tells me that the memory dump was successful. The computer is now completely unresponsive and I am left only with the option of a hard reboot. Upon loggin in, I receive an message stating that "Windows has recovered from a serious error..." and it goes on to ask that I submit a report to MS.

Does anyone know of what may be the culprit and how it can be fixed?

Here are my specs (don't laugh):
MS Windows XP Pro sp2
Intel Celeron 677MHz
512 MB SDRAM
NVidia GeForce M/MX 440, 64MB RAM

BC AdBot (Login to Remove)

 


#2 Heretic Monkey

Heretic Monkey

  • Members
  • 1,122 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:NCSU
  • Local time:08:50 PM

Posted 10 April 2006 - 03:29 PM

Have you been able to play the game before without any problems, or has it been doing that since you installed it?

#3 Andrew

Andrew

    Bleepin' Night Watchman

  • Topic Starter

  • Moderator
  • 8,258 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Location:Right behind you
  • Local time:05:50 PM

Posted 10 April 2006 - 03:50 PM

I used to be able to play it on my old (old, old) Windows 98 machine. I upgraded about a year ago and just started to play it again about a week ago. It's never run properly under XP.

#4 Wizdabest

Wizdabest

  • Members
  • 684 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:08:50 PM

Posted 10 April 2006 - 05:31 PM

would this be an instance to change the compatibility mode?

(I don't know, just throwing something out there)

#5 Andrew

Andrew

    Bleepin' Night Watchman

  • Topic Starter

  • Moderator
  • 8,258 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Location:Right behind you
  • Local time:05:50 PM

Posted 10 April 2006 - 06:21 PM

In order to do that, won't I need to uninstall and then reinstall the game with compatability features enable or can I simpy change the setting on the game's .exe file?

#6 Wizdabest

Wizdabest

  • Members
  • 684 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:08:50 PM

Posted 10 April 2006 - 08:10 PM

you could try (and which I believe is) right clicking on the icon> then go to the compatability tab, then switch it to windows 98(?). I've never done/had to do it before but I believe thats it.

Edited by Wizdabest, 10 April 2006 - 08:11 PM.


#7 Gothmog

Gothmog

  • Members
  • 172 posts
  • OFFLINE
  •  
  • Local time:08:50 PM

Posted 11 April 2006 - 02:41 AM

have you patched the game with an update? there might be a game fix if you haven't. otherwise test to see if it only crashes when you do certain operations ie attacking w/ archers. I never played SC so I'm not much help.

If you don't want to perform a RAM dump everytime you crash you can goto Control panels>System>Advanced tab>"Startup and Recovery" settings button and in the bottom dropdown box select a type of "write debugging information". I chose none, cuz I'm not gonna use any debug info and it makes fatal crashes less painful since I get back to running faster with no mem dump.

#8 Andrew

Andrew

    Bleepin' Night Watchman

  • Topic Starter

  • Moderator
  • 8,258 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Location:Right behind you
  • Local time:05:50 PM

Posted 13 April 2006 - 04:23 PM

I attempted to play under Compatability mode set for Windows 98 but to no avail. It actually amde things worse! As soon as a game was started (that is a game scenario within the game program) it froze up.

It has the latest patch (it came already patched out of the box).

#9 twistofcain1976

twistofcain1976

  • Members
  • 61 posts
  • OFFLINE
  •  
  • Location:Saskatchewan
  • Local time:08:50 PM

Posted 18 April 2006 - 02:11 PM

I had a similar blue screen error while playing farcry just last week.
I repeated it a few times, but since shuting my system down for a few days it's seemed fine so far.
the error said something about "critical error" or "memory dump" and started a % done , i never let it complete, but rather hard rebooted.

if it happens again i'll make a better note of what it's saying, maybe the same thing.

#10 Andrew

Andrew

    Bleepin' Night Watchman

  • Topic Starter

  • Moderator
  • 8,258 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Location:Right behind you
  • Local time:05:50 PM

Posted 19 April 2006 - 10:31 AM

but since shuting my system down for a few days it's seemed fine so far.


Hmmm....

I don't usually shut my computer down, but rather tell it to "Hibernate". Could that have something to do with it?




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users