Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Something keeps stealing focus


  • Please log in to reply
7 replies to this topic

#1 Firskov

Firskov

  • Members
  • 4 posts
  • OFFLINE
  •  
  • Local time:04:09 PM

Posted 03 May 2013 - 08:45 AM

Hey Bleeping Computer forums, i'm new here but i was recommended this site by a friend.

 

Lately i've been having an issue with my computer where something keeps stealing focus. This is a problem i've come to realise a lot of people have had, and its caused a lot of stress, and so while searching the interwebz, i was able to find a lot of answers on how to fix it. 

 

Most of these answers have been to find the process taking focus and terminating it, however i've been unable to figure out what is stealing focus after trying several different programs. 

Also, most people seem to be losing focus once an hour or so, however it's happening way more often for me (It happened twice while creating my account, and so far it's happened 3 times while writing this thread).

 

I've checked my regedit and the ForegroundLockTimeout is at 30d40, which i have been informed is right. I've also run a fullsystem scan to see if i've been infected with something, but nothing came up. The computer is only a month old, and i've been careful, so i was doubting that would be it anyway.

 

So if anyone can shed some light on the problem, that would be fantastic, as this is really driving me crazy.



BC AdBot (Login to Remove)

 


#2 Julia G

Julia G

  • Members
  • 138 posts
  • OFFLINE
  •  
  • Gender:Female
  • Location:EUROPE
  • Local time:09:09 AM

Posted 03 May 2013 - 09:43 AM

Have you tried   http://technet.microsoft.com/en-us/sysinternals/bb896653.aspx        

 

Installation

Simply run Process Explorer (procexp.exe).

The help file describes Process Explorer operation and usage. If you have problems or questions please visit the Sysinternals Process Explorer Forum.


Edited by Julia G, 03 May 2013 - 12:43 PM.


#3 dc3

dc3

    Bleeping Treehugger


  • Members
  • 30,372 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:Sierra Foothills of Northern Ca.
  • Local time:07:09 AM

Posted 03 May 2013 - 10:15 AM

It would help if you post the make and model of this computer.

 

Please explain what you are mean by stealing or taking focus.


Family and loved ones will always be a priority in my daily life.  You never know when one will leave you.

 

 

 

 


#4 Firskov

Firskov
  • Topic Starter

  • Members
  • 4 posts
  • OFFLINE
  •  
  • Local time:04:09 PM

Posted 03 May 2013 - 02:04 PM

I have tried Process Explorer previously, but was unable to find anything.

 

It's an MM-vision computer. MM-vision is a Danish brand that assembles computers using components with good quality.

 

 

Motherboard: Gigabyte GA-B75M-D3H

RAM: Kingston HyperX 8GB DDR3-1600 RAM

Harddrive: Seagate 1000GB SATA3 6Gb/s (7200rpm)

Graphics: EVGA GeForce GTX660 2GB GDDR5

 

By stealing focus, i mean that the window i have opened randomly gets "unselected", as if something else is opened as the main window. I dont physically see anything on the screen, i just see the window that is currently open being grayed out at the top, and i'm unable to write anything until i click on the page again to get focus. With regular programs like Microsoft Word or my browser, this just means that i'm unable to write anything and unable to scroll up and down the screen, however when i run fullscreen programs, these get closed, as if i've alt-tabbed out of them. I can open them again, but it's a bother if i'm in the middle of something. 

 

My computer has been on for a couple of hours now, and i've noticed that it's not happening at the moment. So it's mostly for the first hour after i turn on my computer that i'm having issues, and they seem to resolve themselves as the computer is kept on for longer. 



#5 dc3

dc3

    Bleeping Treehugger


  • Members
  • 30,372 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:Sierra Foothills of Northern Ca.
  • Local time:07:09 AM

Posted 03 May 2013 - 02:26 PM

I will be more than glad to help you with this, but if it is a custom build and only a couple of months old I would suggest talking to the shop where you purchased this about this problem.  The one thing that you could do here would be to have this topic moved to the Am I Infected? What Do I Do? forum where they will be able to determine if this virus related.  One type of virus scan will not find all types of infections, this could be virus related.


Edited by dc3, 03 May 2013 - 02:27 PM.

Family and loved ones will always be a priority in my daily life.  You never know when one will leave you.

 

 

 

 


#6 Firskov

Firskov
  • Topic Starter

  • Members
  • 4 posts
  • OFFLINE
  •  
  • Local time:04:09 PM

Posted 03 May 2013 - 02:35 PM

Yeah definitely, i'll contact the place where i had it built. The main reason i came here first, is that it's a friday, so they wont be able to help me until monday. Decided if someone here could help me, then that would probably be the quickest way to fix the problem :-)

 

Yeah, i'll definitely have it moved to the Am I Infected? subforum, to try and figure out if it is a virus.

Can i move it, or do i need a moderator to do so for me?


Edited by Firskov, 03 May 2013 - 02:35 PM.


#7 dc3

dc3

    Bleeping Treehugger


  • Members
  • 30,372 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:Sierra Foothills of Northern Ca.
  • Local time:07:09 AM

Posted 03 May 2013 - 03:51 PM

I have requested that this topic be moved.  Let us know how things turn out.


Family and loved ones will always be a priority in my daily life.  You never know when one will leave you.

 

 

 

 


#8 Firskov

Firskov
  • Topic Starter

  • Members
  • 4 posts
  • OFFLINE
  •  
  • Local time:04:09 PM

Posted 13 May 2013 - 08:08 PM

I'm gonna resurrect a by now semi-old thread, and tell people that i have found my problem. It was the configuration program/tool/whatever for TP-link, the net card thingy in my computer, which was stealing focus. It wasn't something i actively used anyway, so i just  disabled the bugger and the problem is now fixed. If anyone else has a similar problem, doing this might help, so try it out :-)






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users