Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Laptop computer won't recognize ethernet connection


  • Please log in to reply
7 replies to this topic

#1 TheJBizz

TheJBizz

  • Members
  • 33 posts
  • OFFLINE
  •  
  • Local time:06:59 PM

Posted 29 April 2013 - 07:26 PM

Hello!
 
I'm using an ancient IBM/Lenovo Thinkpad T60 that was originally running Windows XP that is now using Linux Mint 14.
 
For some reason, my computer isn't taking any wired ethernet connection either in XP or in Mint.
When I run ifconfig in Mint, it tells me there is an ETH0 connection:
 
eth0      Link encap:Ethernet  HWaddr 00:15:58:32:08:cb  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:16 Memory:ee000000-ee020000
 
but it won't recognize an ethernet cable connecting into it. I bought a PCI Express gigabit ethernet card and installed the drivers for it, and the system recognizes there is another ethernet port when it's plugged in:
 
eth1      Link encap:Ethernet  HWaddr 00:13:3b:0c:24:f5  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:47 Base address:0xe000
 
but that port won't take a connection either. I can get WiFi connections on it just fine. Does anyone know what could cause this? Moreover, does anyone know if this can be fixed?


Edited by TheJBizz, 29 April 2013 - 07:29 PM.


BC AdBot (Login to Remove)

 


#2 YourTechBoy

YourTechBoy

  • Members
  • 10 posts
  • OFFLINE
  •  
  • Local time:06:59 PM

Posted 29 April 2013 - 08:12 PM

Why not restore BIOS to factory defaults. It should make all the ports and connections go into reset. If not, then check for updates in Windows. 

-------------------------------------------------------------------------------------------------

 

 
We need more information on Linux. Start a command shell and enter these commands:
 
lspci -v > lspci.txt
 
which will list your pci devices in a file called lspci.txt
 
ifconfig -a > ifconfig.txt
 
which will list your network interfaces in a file called ifconfig.txt
 
Please post the contents of lspci.txt and ifconfig.txt here on Bleepingcomputers.com.
If you need chat service, please contact me at sayansaha1@live.com
 
I will be glad to help! 

Edited by YourTechBoy, 29 April 2013 - 08:12 PM.


#3 TheJBizz

TheJBizz
  • Topic Starter

  • Members
  • 33 posts
  • OFFLINE
  •  
  • Local time:06:59 PM

Posted 29 April 2013 - 08:18 PM

I'm not sure how to restore the BIOS (or, to be honest, what a BIOS is).

 

lspci.txt:

 

00:00.0 Host bridge: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT Express Memory Controller Hub (rev 03)
    Subsystem: Lenovo ThinkPad T60/R60 series
    Flags: bus master, fast devsel, latency 0
    Capabilities: <access denied>
    Kernel driver in use: agpgart-intel

00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03) (prog-if 00 [VGA controller])
    Subsystem: Lenovo ThinkPad T60/R60 series
    Flags: bus master, fast devsel, latency 0, IRQ 16
    Memory at ee100000 (32-bit, non-prefetchable) [size=512K]
    I/O ports at 1800 [size=8]
    Memory at d0000000 (32-bit, prefetchable) [size=256M]
    Memory at ee200000 (32-bit, non-prefetchable) [size=256K]
    Expansion ROM at <unassigned> [disabled]
    Capabilities: <access denied>
    Kernel driver in use: i915
    Kernel modules: intelfb, i915

00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)
    Subsystem: Lenovo ThinkPad T60/R60 series
    Flags: fast devsel
    Memory at ee180000 (32-bit, non-prefetchable) [size=512K]
    Capabilities: <access denied>

00:1b.0 Audio device: Intel Corporation NM10/ICH7 Family High Definition Audio Controller (rev 02)
    Subsystem: Lenovo ThinkPad T60/R60 series
    Flags: bus master, fast devsel, latency 0, IRQ 46
    Memory at ee240000 (64-bit, non-prefetchable) [size=16K]
    Capabilities: <access denied>
    Kernel driver in use: snd_hda_intel
    Kernel modules: snd-hda-intel

00:1c.0 PCI bridge: Intel Corporation NM10/ICH7 Family PCI Express Port 1 (rev 02) (prog-if 00 [Normal decode])
    Flags: bus master, fast devsel, latency 0
    Bus: primary=00, secondary=02, subordinate=02, sec-latency=0
    I/O behind bridge: 00002000-00002fff
    Memory behind bridge: ee000000-ee0fffff
    Prefetchable memory behind bridge: 0000000040000000-00000000401fffff
    Capabilities: <access denied>
    Kernel driver in use: pcieport
    Kernel modules: shpchp

00:1c.1 PCI bridge: Intel Corporation NM10/ICH7 Family PCI Express Port 2 (rev 02) (prog-if 00 [Normal decode])
    Flags: bus master, fast devsel, latency 0
    Bus: primary=00, secondary=03, subordinate=03, sec-latency=0
    I/O behind bridge: 00003000-00004fff
    Memory behind bridge: ec000000-edffffff
    Prefetchable memory behind bridge: 00000000e4000000-00000000e40fffff
    Capabilities: <access denied>
    Kernel driver in use: pcieport
    Kernel modules: shpchp

00:1c.2 PCI bridge: Intel Corporation NM10/ICH7 Family PCI Express Port 3 (rev 02) (prog-if 00 [Normal decode])
    Flags: bus master, fast devsel, latency 0
    Bus: primary=00, secondary=04, subordinate=0b, sec-latency=0
    I/O behind bridge: 00005000-00006fff
    Memory behind bridge: e8000000-e9ffffff
    Prefetchable memory behind bridge: 00000000e4100000-00000000e41fffff
    Capabilities: <access denied>
    Kernel driver in use: pcieport
    Kernel modules: shpchp

00:1c.3 PCI bridge: Intel Corporation NM10/ICH7 Family PCI Express Port 4 (rev 02) (prog-if 00 [Normal decode])
    Flags: bus master, fast devsel, latency 0
    Bus: primary=00, secondary=0c, subordinate=13, sec-latency=0
    I/O behind bridge: 00007000-00008fff
    Memory behind bridge: ea000000-ebffffff
    Prefetchable memory behind bridge: 00000000e4200000-00000000e42fffff
    Capabilities: <access denied>
    Kernel driver in use: pcieport
    Kernel modules: shpchp

00:1d.0 USB controller: Intel Corporation NM10/ICH7 Family USB UHCI Controller #1 (rev 02) (prog-if 00 [UHCI])
    Subsystem: Lenovo ThinkPad T60/R60 series
    Flags: bus master, medium devsel, latency 0, IRQ 16
    I/O ports at 1820 [size=32]
    Kernel driver in use: uhci_hcd

00:1d.1 USB controller: Intel Corporation NM10/ICH7 Family USB UHCI Controller #2 (rev 02) (prog-if 00 [UHCI])
    Subsystem: Lenovo ThinkPad T60/R60 series
    Flags: bus master, medium devsel, latency 0, IRQ 17
    I/O ports at 1840 [size=32]
    Kernel driver in use: uhci_hcd

00:1d.2 USB controller: Intel Corporation NM10/ICH7 Family USB UHCI Controller #3 (rev 02) (prog-if 00 [UHCI])
    Subsystem: Lenovo ThinkPad T60/R60 series
    Flags: bus master, medium devsel, latency 0, IRQ 18
    I/O ports at 1860 [size=32]
    Kernel driver in use: uhci_hcd

00:1d.3 USB controller: Intel Corporation NM10/ICH7 Family USB UHCI Controller #4 (rev 02) (prog-if 00 [UHCI])
    Subsystem: Lenovo ThinkPad T60/R60 series
    Flags: bus master, medium devsel, latency 0, IRQ 19
    I/O ports at 1880 [size=32]
    Kernel driver in use: uhci_hcd

00:1d.7 USB controller: Intel Corporation NM10/ICH7 Family USB2 EHCI Controller (rev 02) (prog-if 20 [EHCI])
    Subsystem: Lenovo ThinkPad T60/R60 series
    Flags: bus master, medium devsel, latency 0, IRQ 19
    Memory at ee444000 (32-bit, non-prefetchable) [size=1K]
    Capabilities: <access denied>
    Kernel driver in use: ehci_hcd

00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e2) (prog-if 01 [Subtractive decode])
    Flags: bus master, fast devsel, latency 0
    Bus: primary=00, secondary=15, subordinate=18, sec-latency=32
    I/O behind bridge: 00009000-0000cfff
    Memory behind bridge: e4300000-e7ffffff
    Prefetchable memory behind bridge: 00000000e0000000-00000000e3ffffff
    Capabilities: <access denied>

00:1f.0 ISA bridge: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge (rev 02)
    Subsystem: Lenovo ThinkPad T60/R60 series
    Flags: bus master, medium devsel, latency 0
    Capabilities: <access denied>
    Kernel modules: leds-ss4200, lpc_ich, intel-rng

00:1f.2 IDE interface: Intel Corporation 82801GBM/GHM (ICH7-M Family) SATA Controller [IDE mode] (rev 02) (prog-if 80 [Master])
    Subsystem: Lenovo Thinkpad T60 model 2007
    Flags: bus master, 66MHz, medium devsel, latency 0, IRQ 16
    I/O ports at 01f0 [size=8]
    I/O ports at 03f4 [size=1]
    I/O ports at 0170 [size=8]
    I/O ports at 0374 [size=1]
    I/O ports at 18b0 [size=16]
    Capabilities: <access denied>
    Kernel driver in use: ata_piix

00:1f.3 SMBus: Intel Corporation NM10/ICH7 Family SMBus Controller (rev 02)
    Subsystem: Lenovo ThinkPad T60/R60 series
    Flags: medium devsel, IRQ 11
    I/O ports at 18e0 [size=32]
    Kernel modules: i2c-i801

02:00.0 Ethernet controller: Intel Corporation 82573L Gigabit Ethernet Controller
    Subsystem: Lenovo ThinkPad T60
    Physical Slot: 2
    Flags: bus master, fast devsel, latency 0, IRQ 44
    Memory at ee000000 (32-bit, non-prefetchable) [size=128K]
    I/O ports at 2000 [size=32]
    Capabilities: <access denied>
    Kernel driver in use: e1000e
    Kernel modules: e1000e

03:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection (rev 02)
    Subsystem: Intel Corporation Device 1010
    Physical Slot: 3
    Flags: bus master, fast devsel, latency 0, IRQ 45
    Memory at edf00000 (32-bit, non-prefetchable) [size=4K]
    Capabilities: <access denied>
    Kernel driver in use: iwl3945
    Kernel modules: iwl3945

04:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168 PCI Express Gigabit Ethernet controller (rev 06)
    Subsystem: Realtek Semiconductor Co., Ltd. Device 0123
    Physical Slot: 4
    Flags: bus master, fast devsel, latency 0, IRQ 47
    I/O ports at 5000 [size=256]
    Memory at e4104000 (64-bit, prefetchable) [size=4K]
    Memory at e4100000 (64-bit, prefetchable) [size=16K]
    Capabilities: <access denied>
    Kernel driver in use: r8168
    Kernel modules: r8168

15:00.0 CardBus bridge: Texas Instruments PCI1510 PC card Cardbus Controller
    Subsystem: Lenovo ThinkPad T60/R60 series
    Flags: bus master, medium devsel, latency 168, IRQ 16
    Memory at e4300000 (32-bit, non-prefetchable) [size=4K]
    Bus: primary=15, secondary=16, subordinate=17, sec-latency=176
    Memory window 0: e0000000-e3ffffff (prefetchable)
    Memory window 1: 44000000-47ffffff
    I/O window 0: 00009000-000090ff
    I/O window 1: 00009400-000094ff
    16-bit legacy interface ports at 0001
    Kernel driver in use: yenta_cardbus
    Kernel modules: yenta_socket
 

 

ifconfig.txt:

 

eth0      Link encap:Ethernet  HWaddr 00:15:58:32:08:cb  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:16 Memory:ee000000-ee020000

eth1      Link encap:Ethernet  HWaddr 00:13:3b:0c:24:f5  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:47 Base address:0xe000

irda0     Link encap:IrLAP  HWaddr 00:00:00:00  
          NOARP  MTU:2048  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:8
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:2803 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2803 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:243424 (243.4 KB)  TX bytes:243424 (243.4 KB)

wlan0     Link encap:Ethernet  HWaddr 00:18:de:74:b8:6f  
          inet addr:192.168.1.5  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::218:deff:fe74:b86f/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:148316 errors:0 dropped:0 overruns:0 frame:0
          TX packets:112636 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:168098745 (168.0 MB)  TX bytes:17286414 (17.2 MB)
 


Edited by TheJBizz, 29 April 2013 - 08:21 PM.


#4 YourTechBoy

YourTechBoy

  • Members
  • 10 posts
  • OFFLINE
  •  
  • Local time:06:59 PM

Posted 29 April 2013 - 09:23 PM

Not to worry, that's what I am here for! Now, the main problem is driver issues. You should install the driver for your Linux or windows usage. Now, I may be able to send you a driver for your required pc.

What happened was that your Ethernet driver was not correctly installed or detected. It will be fixed but you must install the Ethernet driver.

Before we do all of that, when you boot your computer, it should say Press ---- for BIOS. Pres that key and go to the last page, and press Factory defaults or what it says!

Hope everything works well. Thank you for letting me be a part of your computer help. I am a student IT.

#5 TheJBizz

TheJBizz
  • Topic Starter

  • Members
  • 33 posts
  • OFFLINE
  •  
  • Local time:06:59 PM

Posted 29 April 2013 - 10:23 PM

Hm. I just reset my computer, and nothing came up about the BIOS. Looking up the BIOS for my computer shows only stuff for Windows (which I suppose makes sense - it came packaged with XP.)

 

I guess I'm screwed?



#6 YourTechBoy

YourTechBoy

  • Members
  • 10 posts
  • OFFLINE
  •  
  • Local time:06:59 PM

Posted 30 April 2013 - 04:33 PM

No, don't you worry! Ok I will do the process for you. First, give me all specifications or just model name. Don't give up, I will provide a solution for you! 

 

Ex. Dell Inspiron 15R



#7 TheJBizz

TheJBizz
  • Topic Starter

  • Members
  • 33 posts
  • OFFLINE
  •  
  • Local time:06:59 PM

Posted 01 May 2013 - 04:56 PM

Just figured it out! I'm running an IBM Thinkpad T60. In order to get into the BIOS, I had to press the ThinkVantage button at startup when prompted. That opened up another prompt that allowed me to look at the BIOS, which I then reset to defaults. I can get a wired connection now. Thank you for all of your help!

 



#8 YourTechBoy

YourTechBoy

  • Members
  • 10 posts
  • OFFLINE
  •  
  • Local time:06:59 PM

Posted 01 May 2013 - 05:41 PM

Thank you for letting me help your pc. Now, since I am a student IT, I was wondering if you could fill out a survey. It is for my record so that I can show to my professor. Can you fill it out for me? Please, only 1 minute survey. 

Mod Edit:  Removed survey link.  Please...do not ask members to fill out surveys or any other form of solicitation.  We appreciate your volunteeing your knowledge, as we all do...but asking anything in return is likely to viewed as using the roum in a manner it was never intended to be used, IMO - Hamluis.

 

 

Also if you need me, just add me to your contacts! I am always avaliable!

 

YourTechBoy

Mod Edit:  Removed email address, spambot protection - Hamluis.


Edited by hamluis, 02 May 2013 - 12:54 PM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users