Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Printer Problems


  • Please log in to reply
2 replies to this topic

#1 salviablue

salviablue

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:10:44 AM

Posted 07 April 2006 - 07:18 AM

I have looked through many web pages of info on "spoolsv.exe, 'error 1068: dependency service or group failed to start' and 'Error: you have to be an administrator to perform this task' but I am logged into windows as an administrator! " but to no avail.
I think some how all these things are connected. I shall start from the beginning. This machine had a lexmark z33 and a brother hl-5150d installed, one for colour and one for mass printing (B&W). Everytime windows was started up the 'found new hardware - brother hl-5010d, looking for software to install' business appeared. After going through this process a couple times, essentially reinstalling the already installed software, i just continued to cancel install, but the printer worked fine.
The lexmark printer was used after some time of inactivity and the lexmark ink levels thing program kept popping up at windows startup even though the printer worked fine. Now, after having two printer program jobbies appearing everytime windows was booted, we decided to relocate the lexmark to another computer and uninstall all to do with the lexmark other than the basic drivers (keeping in mind this is my fathers computer and he has a tendency to loose install disks!).
suddenly, the windows can no longer find a printer to print to (when receiving a user input print command) . When i go into printers and faxes in control panel there are no printers listed. If i click on add printer, i get an error message "operation could not be completed''. so i initially though reinstalling the brother printer to the tune of 'Add printer: operation could not be completed' during the install. I then tried uninstalling the lexmark and brother printers in add/remove programs in control panel only to be told "error: you have to be an administrator to perform this task" even though i am logged in as an administrator with an admin account!
Next I thought, hang on where is the printer spooler gone in task manager? So i tried running the spooler 'spoolsv.exe' in the run command box. spoolsv.exe briefly appeared in TM before promptly disappearing. I then tried to run it in admin tools whence i was assaulted with "Error 1068: dependency service or group failed to start"?
HELP?!?!?!?!?!?!?!?!PLEASE????

BC AdBot (Login to Remove)

 


m

#2 nosnhoj#3

nosnhoj#3

  • Members
  • 245 posts
  • OFFLINE
  •  
  • Location:127.0.0.1
  • Local time:03:44 AM

Posted 07 April 2006 - 10:21 AM

Hello,

First off, you may want to create a system restore point.

--Press the Windows Key + R to open the Run prompt, in the text field type, msconfig
Click the Launch System Restore tab, tick the
option. After you have done a restore checkpoint, folow the below instructions.

1. Press the Windows Key + R to open up the Run Prompt. Or click Start-->Run.

2. In the text field, type Services.msc and the Services applet should pop up.

3. Scroll until you find the listing for Print Spooler, and under the Status Column note if it is started or not.

4. Either way, Right-Click on Print Spooler, click Properties--> Dependancies. See which, if any, files the Print Spooler is dependant on to run properly.

There will be two boxes of dependancies: You will be focusing on the top box-

5. Go back to the Services applet and locate what you found under dependancies. ie (RPC remote procedure call). Check to see the status of the entry/entries.

6. If the RPC is the only entry that the spooler is dependant on, and the RPC is also not started, Right-Click on it, Properties. Set the Startup type to automatic, Apply, OK.

7. Do the same for the Print Spooler.

8. Exit all windows and restart like normal. You may also want to uninstall your printers software and upon restarting give it a fresh installation.

NOTE: There may be two listings of the RPC, one is the locator, and the other is the one you are looking for. Keep the RPC Locator set to manual.


Hope this helps,

nos :thumbsup:

When I'm right, I'm right....
And when I'm wrong, I could have been right....
So I'm still right, cause I could have been wrong.

#3 salviablue

salviablue
  • Topic Starter

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:10:44 AM

Posted 11 April 2006 - 03:55 PM

Thankyou for the reply. The problem seems a little closer to resolvement? The program the spooler was dependant on was disabled, but this program is something to do with the lexmark of which i still cannot uninstall, all attempts at uninstalling result in the 'Error: you have to be an administrator to perform this task' assault! ????




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users