Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Can't sync 2 Win7 systems


  • Please log in to reply
1 reply to this topic

#1 hedera

hedera

  • Members
  • 91 posts
  • OFFLINE
  •  
  • Local time:04:44 PM

Posted 10 April 2013 - 01:53 PM

I have a home network using an AT&T U-Verse DSL router, 2Wire 3800HGV-B, software version 6.3.7.50-plus.tm. (We don't really need everything this does but when we first got it we had TV, which we've cancelled.) On this network I have 2 HP Pavilion s5280ts running Win7 Pro 64-bit, connected via Ethernet, and one ThinkPad T530 laptop, wireless, also running Win7 Pro 64-bit. We have a 2-story house; the router is on the 2nd floor, the ThinkPad normally lives on the first floor directly below the router, sometimes in the room next to that. The house is almost square and has an 800-square-foot footprint; it's never very far away, and distance from the router doesn't seem to affect this.

 

The T530 is a replacement for an old Dell 1420 running Win7 Ultimate 64-bit, which I built myself; I bought the T530 online, as I did the HP. I use GoodSync Pro to synchronize a list of folders between one of the HPs and the T530, because I work on both systems. The HP must be able to connect to the laptop without a password. I never had any trouble with this while using the Dell. I shut down all my systems every night. My userid is the same on both systems and uses the same password on both systems.

 

Since I brought up the T530, I've gotten a network password prompt almost every day when I try to connect from the HP. So far the only way I can successfully connect without a password, so I can run the GoodSync synchronization jobs, is to rename the HP and reboot it, sometimes twice, sometimes only once. After that, I have full network access to the T530 until the next morning. Once I forgot to turn the Thinkpad off at night, the permission was still there next day. The person who posted the rename-and-reboot solution (I forget where) claimed that something in the connecting computer's registry got corrupted, and the double rename-and-reboot would clear the entry. He didn't give details. I'd love to know how to prevent this instead of just fix it.

 

This is driving me nuts. There has to be a way to configure the system so the network permissions on the ThinkPad will reliably survive overnight cold boot on both systems.

 

I've checked all the sharing credentials on both boxes. At one point I discovered that Network sharing and File discovery were off on the Thinkpad, I turned them back on. They are always on when I check. All the sharing credentials are the way Windows says they should be: Network discovery and file share on, password protection off, Windows managing the system. We have a Homegroup and all boxes belong to it. I don't use Public Folders. My entire userid file on the ThinkPad is shared full control with Everyone and with Homegroup.

 

Here are the solutions I found on the Internet which I've tried without success:

  1. Removing Windows credentials for the HP from the T530 credential manager. This worked once. But I notice that every time I shut down and come back up, the Thinkpad recreates credentials for every box on the system (including credentials for the name of my HP that isn't currently in use.)

  2. Some system services were started on Manual not Automatic: Computer Browser, Network Connections, Function Discovery Provider Host, Function Discovery Resource Publication. I found posts suggesting that they should start automatically. I changed them to start automatically.

  3. I found one suggestion (in Windows Help) that my router may need upgrades. But it's only a year or so old, and it worked perfectly with the Dell. I haven't followed this up. I may yet.

  4. Leaving the Homegroup and rejoining it had no effect. Removing all computers from the Homegroup and all joining a new one had no effect.

  5. Setting up the guest account on both computers had no effect. And when I did, I could not log in via the network password prompt as Guest without a password, which I've seen posted as a solution. I saw no way to assign a password to Guest - it was suggested in one Microsoft post, but you can't do it from the control panel, or I can't.

  6. I found a suggestion on BleepingComputer.com that adding a registry key HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa\LmCompatibilityLevel and setting the value to 1 would help. This seemed to work at first – it survived a brief cold boot – but the next morning the password prompt was back. I realize now the problem that solved was with a Win2000 server so it may not be relevant.

  7. I found a suggestion to disable Limit local account use of blank passwords to console login only. This is in Control Panel | Security | Administrative Tools | Local Security Policy | Local Policies | Security Options. Didn't work.

  8. Logging in on the network password prompt with \\Thinkpad\HomeGroupUser$ and the HomeGroup password did not work. Logging in with my userid and password (same on both systems) did not work.

I don't Understand...

Why turning everything off every night should reset the network permissions. It didn't with my old Dell.

 

Why a folder that is shared with Everyone / full control should only be accessible across the network after all these gymnastics.

 

Why Network Discovery doesn't stay turned on. I actually saw it turn itself off one afternoon on the T530 – the Network window blanked and then displayed the message Network discovery and file sharing are turned off – click here to turn on. This may be related to the two Trojans Microsoft Security Essentials found the first time I ran a full scan - my bad, should have run the scan sooner. I haven't had the vanishing Network Discovery problem since then. But yesterday my husband said his monitor went blank for a second and when it came back up, the network permissions he had on my HP were gone; but they came back a few minutes later. What? (He's running a Malwarebytes scan now...)

 

Why instead of the network password prompt I sometimes get Windows cannot access \\<thinkpad>. You do not have permission to access. The folders on the ThinkPad have every permission (for home network) that I know how to give them.

 

Why, when I rename the HP, I only get a UAC prompt every 5-6 attempts. Shouldn't that prompt happen every time I try to change the system, even if I am an administrator?

 

Why, after I rename my HP, it shows on the Network window under both names, and the Thinkpad can access the shared folders under the name it isn't using right now, but when I click on the name it is using, I get the network password prompt. Since I don't synchronize from the Thinkpad to the HP, this is less critical, but it puzzles me.

 

Why it once cleared the network permissions when my husband rebooted and renamed his HP twice. He uses the other HP desktop, and after he did the double reboot-and-rename this time I could connect to the Thinkpad directly without it.

 

Why I once got connectivity to the Thinkpad by a single rename-and-reboot, was able to see the folders; but when I then tried to run Goodsync to synchronize a document I'd updated, it couldn't connect, and I then got the network password prompt. I had to do the double rename-and-reboot to get free access. This has now happened at least twice when I tried to run GoodSync from a GoToMyPC session, is that related? (I may open a question there.)

 

Because I'm not sure if my problem is on my HP desktop or on the Thinkpad laptop, I ran MiniToolBox on both systems.  I've attached the results to this question, since my post is already long.  If no one here can explain this, it may not have an answer.

Attached Files



BC AdBot (Login to Remove)

 


#2 hedera

hedera
  • Topic Starter

  • Members
  • 91 posts
  • OFFLINE
  •  
  • Local time:04:44 PM

Posted 11 December 2013 - 12:19 AM

I never did get a clear reason why all this was happening, but the problem no longer exists.  What happened:  the hard drive on my desktop died.  Dead as a gnat.  The local computer store couldn't even clone the drive.  So they installed a new, faster, bigger drive and built out Win7 Pro 64 bit with all the patches (for a fee, of course).  From that time, with a few exceptions, I've been able to connect across the network without any reboot-and-rename.  My best guess is that the dying hard drive was corrupted in some critical spot.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users