Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

WD USB HD stopped working


  • Please log in to reply
No replies to this topic

#1 Huma22

Huma22

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:05:30 AM

Posted 07 April 2013 - 08:49 AM

Firstly welcome as this is my first post here
 
Secondly sorry for my bad english. I hope it will be clear enough.
 
Thirdly my problem is with WD external USB 500GB drive (My Passport Essenial). Few days ago it was working like a charm. But then the next day it suddenly stopped. After connecting to the computer drive blinks its diod, system shows there is an external drive connected but the hard drive does not start (it's silente). Of course there is no access to data as the drive does not show in Windows (Win 7 Home x64 by the way). After a day of unsuccessfully trying to access the drive I decided that I have nothing to loose at this point and will try to physicly open the drive as it definitely looked like a mechanical failure (when connected for a short period of time drive was making a little noise like there was something stuck inside).
And so I did. I oppened the drive carefully and noticed the actuator arm being locked in weird position. I gave it a gentle push and it returned to the right position. I closed the drive and connected it to the PC. And it started. But here the fun part starts.
I knew that after oppening the drive it's meant to end up in garbage but I just wanted to save as much data as I could. The drive was recognized in the system and there was access to the stored data. So I started copying it. It was going rather slow with many read errors (bad sectors) but part of the data was retrieved. But then while copying system stopped responding. I waited and waited and waited... Nothing happened. System was unresponsive, couldn't do anything but hard restart and so I did.
After restart bigger problem started. The device was connecned, recognised by the usb controller, drive icons shown in My Computer (there are two drives in one, one system showing as CD with WD control software and second as logical drive for the data storage). The first one (WD controll soft) shows correctly, with data on it, but the storage drive is unaccessible. That's when I started to look for a solution. Tried tests with AOMEI Partition Assistant - was working for hours, showing bad sectors, but fixed nothing - still no access to drive. Then I have found the guide on http://html5.litten.com/how-to-fix-external-disk-drive-suddenly-became-raw/ and tried it. Created bootable cd, run the testdisk. It showed the partition on drive, there were files I wanted to access, I wrote the partition table, boot sector was ok. After rebooting there still was no access to the drive. Then I tried mounting the drive on Partmagic but it wasn't working. There was no reaction from the drive for the mount. I also checked other solutions posted on this forum like WD LifeGuard but with no effect (results posted belowe). 
So what I'm asking for is answer for a simple question: is there anything else I could try to access my data and copy it or should I just throw the drive out and start crying.
Will be grateful for any help.
 
Test Option: EXTENDED TEST 
Model Number: WD My Passport 070A 
Unit Serial Number: WX40AC9U5395 
Firmware Number: 1032 
Capacity: 499.40 GB 
SMART Status: PASS 
Test Result: FAIL 
Test Error Code: 08-Error was detected while repairing bad sectors. 
Test Time: 14:17:42, April 07, 2013 
 
Test Option: QUICK TEST 
Model Number: WD My Passport 070A 
Unit Serial Number: WX40AC9U5395 
Firmware Number: 1032 
Capacity: 499.40 GB 
SMART Status: PASS 
Test Result: FAIL 
Test Error Code: 06-Quick Test on drive 2 did not complete! Status code = 07 (Failed read test element), Failure Checkpoint = 97 (Unknown Test) SMART self-test did not complete on drive 2! 
Test Time: 14:22:51, April 07, 2013 


BC AdBot (Login to Remove)

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users