Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Comcast Email won't open on new Windows 8 computer


  • Please log in to reply
4 replies to this topic

#1 SoXfused

SoXfused

  • Members
  • 138 posts
  • OFFLINE
  •  
  • Local time:03:09 PM

Posted 04 April 2013 - 08:59 PM

I've have just received my brand new Windows 8 laptop today, and everything is great except for one thing:  whenever I try to sign into my Comcast email, I get a "Certificate Error" page saying "There is a problem with this website's security certificate (blah blah blah)".  I have no idea why I'm getting this error because I have never gotten this error before until today when I try to sign in on my new computer.  And I'm definitely not on a fake site, so I don't know why I'm getting this error.  Does it have something to do with me using Windows 8 or some type of setting? :scratchhead:



BC AdBot (Login to Remove)

 


#2 Broni

Broni

    The Coolest BC Computer


  • BC Advisor
  • 42,698 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Daly City, CA
  • Local time:01:09 PM

Posted 05 April 2013 - 02:06 PM

First of all make sure your computer date is correct.

 

What browser do you use to access Comcast site?

Did you try different browser?


My Website

p4433470.gif

My help doesn't cost a penny, but if you'd like to consider a donation, click p22001735.gif


 


#3 SoXfused

SoXfused
  • Topic Starter

  • Members
  • 138 posts
  • OFFLINE
  •  
  • Local time:03:09 PM

Posted 11 April 2013 - 02:23 PM

It's IE 10, and this is the first time I've used this browser.

 

Sometimes it will let me into my email, and then other times it gives me a "Certificate Error" page.  It's never happened until I started using IE 10.



#4 Broni

Broni

    The Coolest BC Computer


  • BC Advisor
  • 42,698 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Daly City, CA
  • Local time:01:09 PM

Posted 11 April 2013 - 02:54 PM

First of all make sure your computer date is correct.

Did you try different browser?


My Website

p4433470.gif

My help doesn't cost a penny, but if you'd like to consider a donation, click p22001735.gif


 


#5 Queen-Evie

Queen-Evie

    Official Bleepin' G.R.I.T.S. (and proud of it)


  • Staff Emeritus
  • 16,485 posts
  • OFFLINE
  •  
  • Gender:Female
  • Location:My own little corner of the universe (somewhere in Alabama). It's OK, they know me here
  • Local time:03:09 PM

Posted 13 April 2013 - 10:10 AM

If you have not resolved the issue

I suggest you post in the Comcast Help Forums. If nothing else, your issue can be escalated to the forum administrator who can set the wheels in motion for a resolution.

Those Forums are provided to Comcast customers, and are a great resource for vendor specific issues. There are Forums for computer issues, email issues, security, internet, cable tv, CDV, billing, and customer service.

Many times we, the users there, can provide answers tech support and customer service can't.

Click the link below. The forum landing page will open. Click Sign In. Log in with your Comcast user ID (the part before .net) and your password. You will next see a first time forum users page, asking you to choose a screen name for use in the Forums. Once you set that up, you'll be taken back to the landing page. PLEASE DO NOT USE YOUR COMCAST EMAIL NAME FOR YOUR FORUM USER NAME.

http://forums.comcast.com/

Before posting, take a moment to read the Posting Guidelines.

Then choose the appropriate board to post in. In your case it would be the Email Forum. Please include your OS, browser and version and whether you have tried a different browser. Also confirm that you are using Xfinity Connect (web mail access).

One thing to be aware of: By default you will be notified via email every time someone replies to a topic you have started or replied in. If you do not wish to receive the notifications you can disable them by clicking My Settings/Subscriptions & Bookmarks tab. Uncheck the box next to Automatically subscribe me to topics I participate in. Scroll down and click Save.

(Once you get to the forum, save the page to your favorites/bookmarks. If you want to get to it from the Comcast home page, you have to jump through hoops to reach it)

Edited by Queen-Evie, 13 April 2013 - 10:21 AM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users