Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Program Installation problem


  • Please log in to reply
1 reply to this topic

#1 jmarsh97

jmarsh97

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:05:15 AM

Posted 31 March 2013 - 03:50 PM

I decided I wanted to install an old game I had (SuperPower 2), so I inserted the disks and proceeded to install. The game is from 2004, or somewhere around there. I have a Windows 7 now. The installation went fine, and I attempted to run it. It didn't work, so I tried in compatibility mode for several different versions of Windows (XP sp2, XP sp3, NT 4.0, 98, 2000). None of those worked either, even when run as admin. I did some searching, and learned that there was a patch. I downloaded the patch from two different websites and ran it. It was a Winrar SFX file(sp2upgradev1.4.SFX), so it automatically extracts and runs itself. It seemed like it was going good, and the file (sp2upgradev1.4.EXE) would appear where it was supposed to. However, a few seconds after the extraction finished, an error message appeared and the file would disappear.  ("Windows cannot access the specified device, path, or file. You may not have the appropriate permissions to access the item.") Seeing the last part, I tried running it as admin, and also in compatibility mode for the above OS's. It still disappeared after extracting. 
 
I'm not sure if anybody is familiar with the game, but any general advice/suggestions are welcome. I think the patch is a more pressing issue, since the compatibility problem may sort itself out with the patch. 
 
EDIT: It's almost like WinRar deletes the setup file before it finishes setup. That would explain the error message, because if the file is deleted, setup could not take place.  I tried changing the SFX script commands, but the problem was not fixed. If anyone knows how to stop the SFX from deleting the setup, do tell. I've looked online but found nothing that matches my problem. 
 
EDIT2: I tried to convert the .sfx to a .rar, and see if that might bypass the problem. Instead, I got an error message.
!   C:\Users\Jeffrey\Desktop\1.4patch sp2\SP2V1.4.sfx.rar: Cannot open sp2v1.4.exe
    Access is denied.
 
So I repaired the .sfx, and it was rebuilt as a .rar. After extracting, it seemed fine and did not disappear. However, when I tried to run it, the first error message appeared and the file disappeared. ("Windows cannot access the specified device, path, or file. You may not have the appropriate permissions to access the item.") It seems like I'm running in circles here....

Edited by jmarsh97, 31 March 2013 - 08:21 PM.


BC AdBot (Login to Remove)

 


#2 jmarsh97

jmarsh97
  • Topic Starter

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:05:15 AM

Posted 01 April 2013 - 06:38 PM

I was playing around with the setup file inside the .SFX, and discovered that it only disappears after I try to either run it or open "Properties". This happens even if I manually extract it, so the problem is either in the setup.exe or in my computer. 

 

Am I the only one who has had a problem like this?

 

 

EDIT: Resolved the issue myself, and feel pretty stupid for even letting it puzzle me. Forgot to run the patch installer in XP compatibility mode...


Edited by jmarsh97, 01 April 2013 - 09:14 PM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users