Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Windows 7 Service Pack 1, Boot Camp, and disappearing Bluetooth


  • Please log in to reply
2 replies to this topic

#1 Clay the Turtle

Clay the Turtle

  • Members
  • 31 posts
  • OFFLINE
  •  
  • Local time:06:53 AM

Posted 21 March 2013 - 11:41 PM

I wasn't sure where to post this. I apologize in advance if this should instead go in a Mac section...

I bought an iMac in February of 2012, and using Boot Camp installed Windows 7 on its own partition. It worked great. However, when I tried to update to Service Pack 1, all instances of Bluetooth disappeared from the system. Nothing in the control panel, nothing when you typed "blue" in the start menu. Because the keyboard and magicpad both link to the computer via Bluetooth, the computer becomes nigh-unusable. I managed to use a USB pen tablet and the software keyboard to reinstall Windows. Everything worked fine again, and I simply made it a point to never install Service Pack 1.

Fast forward to today. I turned on my computer to find it installing updates, which wasn't that unusual. However when I got to desktop, I found that neither the keyboard or magicpad worked. Sure enough, Windows had installed SP1 without asking me, and Bluetooth had pulled its systemwide disappearing act.

Unlike the first time, I had far too much software installed and files in use to just reformat and start over again. Instead I attempted to restore my computer. Only one restore point was available, from the night before. I clicked that and restored. This worked for the Bluetooth, it had returned to its old self, but instead a plethora of odd errors appeared. First off, Microsoft Essentials, my chosen virus protector would fail at startup and give this error code: 0x80040154. It cannot be run, and attempts to uninstall it do nothing.

Annoying, but I could just use another solution. I moved on to clicking on my update settings in the task bar, only for it to give an error and not load up the settings. I tried to go through the Control Panel, but any link there would not work when clicked. It would change color, registering the click, but nothing pops up. Trying to run any portion of the Control Panel through the quick-type start menu wouldn't work either. Even right-clicking the desktop and hitting personalize gives no response.

Otherwise, the system seems to work fine, and I can run Firefox, Skype, Photoshop, and all other usual programs without a hitch.

But I seem to be stuck between a rock and a hard place. Obviously no access to anything in my Control Panel will be a problem eventually. But restoring back to SP1 installed will surely erase my Bluetooth again. I'm not sure what to do here (besides the arduous task of a format), so any help anyone could provide for either problem that doesn't involve that would be much appreciated.

P.S. during one of several reboots to attempt to fix the control panel issue on my own, I was once told "my copy of Windows may not be genuine. I assure you it is a full retail copy. However five reboots later, I never could reproduce that message.


Edited by hamluis, 22 March 2013 - 02:34 PM.
Moved from Win 7 to Mac O/S - Hamluis.


BC AdBot (Login to Remove)

 


#2 smax013

smax013

  • BC Advisor
  • 2,329 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Local time:06:53 AM

Posted 23 March 2013 - 02:31 AM

First, if you do get SP1 installed again, you should be able to remove it using the Program & Features function in the Control Panel:

 

http://windows.microsoft.com/en-us/windows7/uninstall-sp1

 

As to Bootcamp, you will need the Windows drivers for use with the built-in Mac hardware.  There are located here:

 

http://support.apple.com/kb/DL1638

 

It is possible that this might cure the Bluetooth problem with SP1 as there might be an upgraded Bluetooth driver.



#3 yebbi

yebbi

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:11:53 AM

Posted 08 November 2014 - 09:25 AM

I have had this problem for the last few years now and its been extremely frustrating to find out how to fix it. The only reason I have managed is that bluetooth devices managed to connect and be usable with my windows 7 bootcamp machine; however, because there was no bluetooth panel to configure devices with, there was no way I could remove devices. And the reason why this is an issue is because I just bought a 2nd mac book pro, but my trackpad and keyboard failed to stay connected to the new mac, whilst the old one running windows was up and running. For some strange reason, when the windows 7 mac is up, any bluetooth device just automatically switches to it, rather than staying connected to the new mac with which I paired with.

 

Anyways, I have found a fix at long last. The issue I had was that there was no driver installed for the Bluetooth USB host controller. To fix this I found the site http://www.driverscape.com. I was a bit wary of this site, because I've never downloaded anything from there before; but it gets a good rating from 'web of trust (mywot.com), so I thought I'd give it a shot. Now, the Mac I have is a 2009 17in Mac Book Pro Core 2 Duo, which has a broadcom bluetooth controller, so I needed the broadcom driver. To get this driver i went to http://www.driverscape.com/download/bluetooth-usb-host-controller, which has a number of downloads available. The latest one mysteriously was one for an acer controller, so I discarded that (there was no way find out up front, needed to download first to see the name of the downloaded zip file), and so I downloaded the next one instead (dated 18th Oct 2013). Actually, if you hover over the link, you can see the name of the download in your browser's status bar (I'm using Firefox).

 

Once downloaded, I extracted the zip file, then open device manager (I like to right click My Computer and select Manage, then select the device manager). The issue I had in there being no bluetooth driver installed was that there was no item called 'Bluetooth Radios'. Instead I had a yellow warning triangle next to 'Bluetooth USB Host Controller'. You need to right click this node, then hit update driver, then opt to search for drivers yourself locally on your machine and then browse to the folder you extracted the zip file to. Once you do this, the driver should be installed and all should be fixed. You should now have 'Bluetooth Radios' in the device manager and also a bluetooth icon in your system tray.

 

I have seen various other supposed fixes for this issue which required extracting the apple bluetooth installer software (which comes with OSX, or downloadable from apple support site), and updating a .inf file with a hardware ID which you have to derive from the device manager. But this type of esoteric solution never worked for me.

 

Anyway, enough waffling, I hope this fixes your issue as it has mine,

 

cheers.

 






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users