Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Huawei 3g modem driver ewusbwwan.sys refuses to install on windows 7


  • Please log in to reply
1 reply to this topic

#1 Eiresans

Eiresans

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:06:10 AM

Posted 15 March 2013 - 07:44 PM

Hi,

I've been having a number of different problems with installing newer huawei 3g modems on windows 7 ultimate 32 bit. Initally the problem surrounded the driver ewusbnet.sys which, when windows 7 attempted to install it, would summon a BSOD. That particular problem was cast out by newer drivers only to reveal a fault with ewusbwwan.sys which shows in device manager as "huawei mobile connect - 3g network card" & gives a Code 10 and another unnamed driver, which is referred to in device manager as simply "Huawei Mobile" handing in a Code 28.

I have the most up to date huawei 3g modem windows drivers I can find anywhere 4.25.11.00 In the case of the ewusbwwan.sys the driver version is 6.0.1.318 with hardware ids:

USB\VID_12D1&PID_1436&REV_0000&MI_01
USB\VID_12D1&PID_1436&MI_01

the other unknown driver has hardware ids of

USB\VID_12D1&PID_1436&REV_0000&MI_04
USB\VID_12D1&PID_1436&MI_04

Since I was getting BSODs with the ewusbnet.sys I've taken to using virtual machines to try and get the device(s) installed. I've tried two different Windows 7 ultimate 32 bit builds. On these there is no virus protection software, I've tried disabling windows defender and windows firewall. I've tried different compatibility settings as these devices have no problem working on either xp or vista. I've tried installing in safe mode. I've ried all these at th same time. I've tried deleting upperfilters and lowerfilters. I've tried all this with the other intel ® pro/1000 network adapter disabled. All to no avail. I can't find any chipset drivers for the acer aspire one 522 I've tried most of this on. I've another laptop a sony vaoi, on which I can't install the devices on windows 7.

I'm knind of at the end of my tether with this at the minute. Huawei 3g models e1752cu, e173, and e353 all display the same symptoms. Other earlier 3g huawei modems such as e172 or e160 don't have these problems as I assume they don;t use the same driver. If there's anybody out there who could offer a few suggestions on how to proceed or on what to try I would be very, very grateful.

Thanks in advance for any help.



BC AdBot (Login to Remove)

 


#2 noknojon

noknojon

  • Banned
  • 10,871 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Local time:04:10 PM

Posted 17 March 2013 - 04:47 AM

Hello and Welcome -
There are quite a few topics on the same subject all around Google - None with good answers -
Most of them have the same problems that you have, and this dates back about 2 years generally.


The general opinion is to refer this back to the retail outlet or in your case, Telstra I would assume.

Vodaphone was very bad for these devices, but they were very bad for most problems -

 

Apart from asking here, you seem to have done about all that I would in the same circumstances. I use an earlier version Huawei (linked to Optus) on my Win7 Toshiba laptop, that I have used for about 3 years, and it gives fairly good reception in "almost" all areas, and none of the problems you list  -

 

Have you contacted anyone else about this problem, and have you been given any other answers, or ideas yet ??


Huawei Support links on this page

 

What Make and Model computer is this ? What Antivirus is installed ?

 

Thank You -






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users