Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

HD is registering as CD drive - & I can't access any data.


  • Please log in to reply
2 replies to this topic

#1 Goblin42

Goblin42

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:07:29 PM

Posted 12 March 2013 - 01:45 PM

hello

 

The other day the plug socket got switched off with my drive attached and i 'think' it 'may' have been in use.

 

the drive now doesnt register  properly - when i plug it in, (sometimes after having to wiggle the lead about)  it began to show up - but it was showing as the CD drive! -

which means all attempts to access it and read it dont work, because it thinks its an empty cd tray.

 

it sometimes shows up in the 'eject software' bit - but wont diconnect, it says its still in use - but its not.

 

it also shows up with its full name in various other places on the machine, so the computer knows its there, and knows its name and size etc. .

 

the light is on and its making a gentle humming and whirring noise - no clicks etc.

 

i am trying various things, lots of recovery software etc to scan it etc, but not having much luck.... i think they are all reading it as a CD drive and saying its empty ...

one wouldnt even try to read it, saying too many bad sectors.

when i click on it it just says the drive is corrupt.

 

i have tried another usb lead but no change.

 

 

i have tried it in a wall socket, and in 2 other laptops but no change.

 

i have changed the drive letter - but no change.

i have uninstalled all my cd software, as someone said a virtual cd maker had caused theirs, but its had no effect.

 

i checked on the drive manager and its showing that is not initialised, so i tried to do that but it wouldnt allow it - it said the drive is write protected.

it is also show as RAW,

 

This is the 3rd WD drive ive had that has gone wrong, with very little use - this one was a replacement and is almost new - i have only actually accessed it about 10 times -  they are terrible terrible drives


i do not want to take it apart really - it is still in warranty.

but i want the data... but if that is the only way, can someone guide me?

I already have the usb/sata device for this.

 

 

but how can this just stop working? it is set to where you do not have to eject the drive to disconnect it - surely there are processes in place to stop loss of data in these circumstances?

 

i had only just installed the software too, about half an hour earlier - could that be the problem?

i have put a password on it too - will this stop me having access to it with recover software?

 

 

I have looked at various other posts with similar problems but nothing has worked yet.

 

any ideas?

 

i am thinking if i can get it to stop thinking its a CD drive, i may be able to access the data.

 

many thanks

 



BC AdBot (Login to Remove)

 


#2 Goblin42

Goblin42
  • Topic Starter

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:07:29 PM

Posted 12 March 2013 - 01:50 PM

Sorry its a WD, MyBook Essentials 2TB

and I am on Win 7

 

thanks



#3 Agglomerate

Agglomerate

  • Members
  • 60 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:England, United Kingdom
  • Local time:07:29 PM

Posted 12 March 2013 - 01:50 PM

The data on the drive is now probably corrupt. I recommend trying to use some kind of bootable CD and then running a chkdsk command on the drive. If this dosen't help, I can't think what will, sorry.

 

- Agglomerate






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users