Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Must Restart Laptop After Sleep to Connect to Wireless


  • Please log in to reply
4 replies to this topic

#1 MountainDewAddict

MountainDewAddict

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:03:02 PM

Posted 05 March 2013 - 02:20 PM

In the last 2 weeks, my laptop has been doing something new and annoying.  I did a search here and found a few users with a similar issue but there were no definitive answers and/or their solutions haven't worked for me.

I am using a Toshiba Satellite L505 laptop with a Realtek RTL8191SE Wireless LAN 802.11n PCI-E NIC wireless adapter that I use to access my home wireless router.  I am using Windows 7.

 

When my laptop goes into sleep or hibernate mode, I must restart my computer in order to get my wireless adapter to connect to the internet again.

 

It was working properly, and no changes were made to the computer.  No updates were applied.

I have checked and verified that drivers are up-to-date.

Power management options have not changed since it was last working, and it is set so that the wireless adapter does NOT turn off when power is low.

Other devices are accessing the router and internet, and they are not experiencing any disturbances in connectivity.

I have uninstalled and reinstalled the wireless adapter.

I have disabled and re-enabled the adapter.

 

I have had the system diagnose the connection issues, and it just tells me to make sure I'm within range of the hidden network even though it shows my home network in the list AND the laptop is always in the same place.  Even when I move it right next to the router, it will not connect without a restart.

 

I can access and use the wireless internet normally, but if the computer sleeps or hibernates...I must restart the computer or the wireless adapter refuses to reconnect to the network without restarting the whole computer.

 

 

Any other ideas?  I'm seriously stumped on this one.


Edited by MountainDewAddict, 05 March 2013 - 02:21 PM.


BC AdBot (Login to Remove)

 


#2 dc3

dc3

    Bleeping Treehugger


  • Members
  • 30,714 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Sierra Foothills of Northern Ca.
  • Local time:02:02 PM

Posted 05 March 2013 - 04:39 PM

If the network adapter is allowed to be disabled to save power on hibernation this may be causing it.

 

Try the following.

 

Go to the Start Orb> right click on Computer> click on Manage> click on Device Manager.

 

Scroll down to Network Adapters and and expand it.

 

Click on the Network adapter and click on Properties.

 

On the Power Management tab uncheck all the boxes and then click on OK.

 

Restart the computer and see if this resolves the problem.


Family and loved ones will always be a priority in my daily life.  You never know when one will leave you.

 

 

 

 


#3 MountainDewAddict

MountainDewAddict
  • Topic Starter

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:03:02 PM

Posted 05 March 2013 - 11:04 PM

Thank you for the suggestion, but both boxes have been unchecked for a while now.  I've even checked them, restarted, unchecked, restarted...just to see if it would "reset" the option somehow.  I've tried everything :(



#4 dc3

dc3

    Bleeping Treehugger


  • Members
  • 30,714 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Sierra Foothills of Northern Ca.
  • Local time:02:02 PM

Posted 06 March 2013 - 08:14 AM

Let's go back to the Device Manager and reopen the Network Adapters.  This time click on the wireless adapter> Power Management and place a check in the Allow this device to wake the computer box.


Family and loved ones will always be a priority in my daily life.  You never know when one will leave you.

 

 

 

 


#5 MountainDewAddict

MountainDewAddict
  • Topic Starter

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:03:02 PM

Posted 06 March 2013 - 08:17 PM

I tried that, but I still have the issue.

 

I have just set the power management options to not let the computer sleep/hibernate but still turn off the hard drive and other extras when the lid is closed.  I'm not crazy about keeping the laptop from sleeping though.

 

Is there any harm in this?  I'll just shut it down at night, but it seems okay since the hard drive and everything turns off after 20 minutes of inactivity.  I just don't want to damage the laptop by keeping it "on" all the time...but I assume if it NEEDED to sleep, it wouldn't be "optional" right?  I mean, as far as wear and tear on my computer?






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users