Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Vista slave drive Access Denied


  • Please log in to reply
6 replies to this topic

#1 KeMo_Sabi

KeMo_Sabi

  • Members
  • 9 posts
  • OFFLINE
  •  
  • Local time:06:58 PM

Posted 20 February 2013 - 01:46 PM

Ok. Since I've gotten no replies to my earlier post, I decided to just slave the old drive and pull the files off it and put them on a temp Vista drive.

So, first problem was setting permissions in order to access the files I need to save. That failed. I went in and tried to set permissions and I kept getting "access deinied" when trying to set those permissions.

After this last round of trying to get to the files I need to save, I got another "access denied" message, so like an idiot I got pissed and clicked cancel.

Now, I am completely locked out of that drive. When I open My Computer I see the drive as a slave, but instead of having a volume label it says E: Access Denied.

 

Nothing I've done seems to be helping. I've even downloaded and tried to boot to Ubuntu Live CD, but it won't boot in my system. My old Linix Knoppix disks won't boot either. They used to, but for some reason they won't anymore.

 

I have a lot of music and personal files I need to save from this hard drive. Anybody have a way I can fix this "Access Denied" thing??

 

 



BC AdBot (Login to Remove)

 


#2 AngryRaisin

AngryRaisin

  • Members
  • 234 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Orange County, CA, US
  • Local time:04:58 PM

Posted 20 February 2013 - 05:23 PM

First you have to take ownership of all the files... right click on your drive - goto properties - then the security tab - then advanced button - goto Owner tab - then edit button - then 'other users or groups' button - type 'everyone' then ok - now select everyone and check the 'replace owner on subcontainers and objects box' click ok and wait for it to finish. If this was the operating drive out of another computer you may get some/many/50-100 'access is denied' prompts keep pressing the 'continue/skip file' until finished. click ok on all the open windows.

Now right click on the drive again - goto properties - then the security tab - then advanced button - goto Permissions tab - then 'change permissions' button - remove all entries with the remove button - click add button - type 'everyone' - select 'full control' and make sure 'apply to' is set to 'this folder, subfolders, and files' - click ok once - check 'replace all child object permissions...' then click ok on all the rest of the boxes

you should be able to get to everything.


Edited by AngryRaisin, 20 February 2013 - 05:34 PM.


#3 KeMo_Sabi

KeMo_Sabi
  • Topic Starter

  • Members
  • 9 posts
  • OFFLINE
  •  
  • Local time:06:58 PM

Posted 21 February 2013 - 09:49 AM

Thank you for responding. I fixed it yesterday evening by changing the security settings in Vista in the Users section. I turned off the  Account Control and rebooted. When I got back on, the drive was unlocked.

 

I'm still having problems accessing certain files on the drive. I keep setting the permissions, but it still won't show the Documents & Settings folder. 



#4 hamluis

hamluis

    Moderator


  • Moderator
  • 55,406 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:07:58 PM

Posted 21 February 2013 - 11:10 AM

The Docs/Settings folder in Vista is useless...it doesn't contain/reflect the same files that would be reflected in XP's Docs/Settings group...those fall under the User files in Vista.

 

Access will be denied to all Vista users attempting to open the Docs/Settings group in Vista, IME.

 

Louis



#5 KeMo_Sabi

KeMo_Sabi
  • Topic Starter

  • Members
  • 9 posts
  • OFFLINE
  •  
  • Local time:06:58 PM

Posted 21 February 2013 - 11:17 AM

You're right. My bad. I was speaking of the Users folder.



#6 KeMo_Sabi

KeMo_Sabi
  • Topic Starter

  • Members
  • 9 posts
  • OFFLINE
  •  
  • Local time:06:58 PM

Posted 21 February 2013 - 04:03 PM

I fixed this problem.

I had ownership of files, but the User folder wasn't showing in Explorer. So, I went to Run and typed E:\Users
The files that were hidden popped up, but when I opened them, they were "empty". I right clicked the individual files and selected the Security tab, and set the new Ownership rights. After I clicked OK, I opened the file folders I needed to save and all my files were there.
The file folder "User" wasn't setting the security permissions from Explorer.

Close thread if you need to...

Edited by KeMo_Sabi, 21 February 2013 - 04:04 PM.


#7 hamluis

hamluis

    Moderator


  • Moderator
  • 55,406 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:07:58 PM

Posted 21 February 2013 - 04:34 PM

Glad you resolved it, happy computing :).

 

Louis






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users