Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

napinsp.dll error too


  • Please log in to reply
27 replies to this topic

#1 David Mc

David Mc

  • Members
  • 18 posts
  • OFFLINE
  •  
  • Local time:04:49 PM

Posted 17 February 2013 - 03:24 PM

I also have this napinsp.dll error popping up with everything I click in steam.  It just started yesterday and I had it go away but it's back and constantly popping up now.

 

I did this...sfc /scanfile=c:\windows\system32\napinsp.dll

 

and got the response....Windows Resource Protection did not find any integrity violations.

 

Since I'm following the other post I used the system look tool and here is the log....

 

SystemLook 30.07.11 by jpshortstuff
Log created at 14:12 on 17/02/2013 by Dave
Administrator - Elevation successful
WARNING: SystemLook running under WOW64. Use SystemLook_x64 for accurate results.

========== filefind ==========

Searching for "napinsp.dll"
C:\Windows\System32\NapiNSP.dll    --a---- 52224 bytes    [23:54 13/07/2009]    [01:16 14/07/2009] D41D8CD98F00B204E9800998ECF8427E
C:\Windows\SysWOW64\NapiNSP.dll    --a---- 52224 bytes    [23:54 13/07/2009]    [01:16 14/07/2009] D41D8CD98F00B204E9800998ECF8427E
C:\Windows\winsxs\amd64_microsoft-windows-n..ider-infrastructure_31bf3856ad364e35_6.1.7600.16385_none_0812326fa8e1ed67\NapiNSP.dll    --a---- 68096 bytes    [00:10 14/07/2009]    [01:41 14/07/2009] 58A0CDABEA255616827B1C22C9994466
C:\Windows\winsxs\x86_microsoft-windows-n..ider-infrastructure_31bf3856ad364e35_6.1.7600.16385_none_abf396ebf0847c31\NapiNSP.dll    --a---- 52224 bytes    [23:54 13/07/2009]    [01:16 14/07/2009] D41D8CD98F00B204E9800998ECF8427E

-= EOF =-



BC AdBot (Login to Remove)

 


#2 narenxp

narenxp

  • BC Advisor
  • 16,371 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:India
  • Local time:04:49 PM

Posted 17 February 2013 - 03:48 PM

Click on startmenu and type

 

cmd

 

Right click on it and select run as administrator and run these commands

 

takeown /a /f  napinsp.dll

cacls napinsp.dll /g everyone:f

ren napinsp.dll napinsp..old

 

Browse to

 

C:\Windows\winsxs\amd64_microsoft-windows-n..ider-infrastructure_31bf3856ad364e35_6.1.7600.16385_none_0812326fa8e1ed67

 

and click ok

 

Copy napinsp.dll  and paste in c:\windowsystem32 folder

 

Reboot the PC and let me know if that helps


Edited by narenxp, 17 February 2013 - 06:46 PM.


#3 David Mc

David Mc
  • Topic Starter

  • Members
  • 18 posts
  • OFFLINE
  •  
  • Local time:04:49 PM

Posted 17 February 2013 - 03:58 PM

Thank you!  and just to be sure what I'm doing...

I am overwriting the napinsp.dll that is currently in my system32 folder with the one that is in winsxs folder.

Is that correct?



#4 narenxp

narenxp

  • BC Advisor
  • 16,371 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:India
  • Local time:04:49 PM

Posted 17 February 2013 - 04:13 PM

Yep :)



#5 David Mc

David Mc
  • Topic Starter

  • Members
  • 18 posts
  • OFFLINE
  •  
  • Local time:04:49 PM

Posted 17 February 2013 - 04:37 PM

I am still getting the error when I start steam and

now the file seems to be missing.  not sure why, it looked like it was there before I rebooted.

I see a file called NapiNSP.dll

Here's the systemlook log

 

SystemLook 30.07.11 by jpshortstuff
Log created at 15:33 on 17/02/2013 by Dave
Administrator - Elevation successful
WARNING: SystemLook running under WOW64. Use SystemLook_x64 for accurate results.

========== filefind ==========

Searching for " napinsp.dll"
No files found.

-= EOF =-


Edited by David Mc, 17 February 2013 - 04:38 PM.


#6 narenxp

narenxp

  • BC Advisor
  • 16,371 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:India
  • Local time:04:49 PM

Posted 17 February 2013 - 04:44 PM

Click on startmenu and type


cmd


Right click on it and select run as administrator and run this command

 

regsvr32 napinsp.dll

 

Any errors?


Edited by narenxp, 17 February 2013 - 04:44 PM.


#7 David Mc

David Mc
  • Topic Starter

  • Members
  • 18 posts
  • OFFLINE
  •  
  • Local time:04:49 PM

Posted 17 February 2013 - 05:12 PM

looks like I have an error, I got a pop up that says

The module "napinsp.dll" was loaded but the entry-point DllRegisterServer was not found.

Make sure the "napinsp.dll" is a valid DLL or OCX file then try again.



#8 narenxp

narenxp

  • BC Advisor
  • 16,371 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:India
  • Local time:04:49 PM

Posted 17 February 2013 - 05:15 PM

Please do this again


Copy this script and paste it in the system look BOX

 

:filefind
napinsp.dll
 

 

Click on LOOK,post the generated log



#9 David Mc

David Mc
  • Topic Starter

  • Members
  • 18 posts
  • OFFLINE
  •  
  • Local time:04:49 PM

Posted 17 February 2013 - 05:17 PM

Here is what I got...

SystemLook 30.07.11 by jpshortstuff
Log created at 16:16 on 17/02/2013 by Dave
Administrator - Elevation successful
WARNING: SystemLook running under WOW64. Use SystemLook_x64 for accurate results.

========== filefind ==========

Searching for "napinsp.dll"
C:\Windows\System32\NapiNSP.dll    --a---- 52224 bytes    [23:54 13/07/2009]    [01:16 14/07/2009] D41D8CD98F00B204E9800998ECF8427E
C:\Windows\SysWOW64\NapiNSP.dll    --a---- 52224 bytes    [23:54 13/07/2009]    [01:16 14/07/2009] D41D8CD98F00B204E9800998ECF8427E
C:\Windows\winsxs\amd64_microsoft-windows-n..ider-infrastructure_31bf3856ad364e35_6.1.7600.16385_none_0812326fa8e1ed67\NapiNSP.dll    --a---- 68096 bytes    [00:10 14/07/2009]    [01:41 14/07/2009] 58A0CDABEA255616827B1C22C9994466
C:\Windows\winsxs\x86_microsoft-windows-n..ider-infrastructure_31bf3856ad364e35_6.1.7600.16385_none_abf396ebf0847c31\NapiNSP.dll    --a---- 52224 bytes    [23:54 13/07/2009]    [01:16 14/07/2009] D41D8CD98F00B204E9800998ECF8427E

-= EOF =-



#10 narenxp

narenxp

  • BC Advisor
  • 16,371 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:India
  • Local time:04:49 PM

Posted 17 February 2013 - 05:31 PM

Corrupted was not replaced.What happened when you tried to replace the file?



#11 David Mc

David Mc
  • Topic Starter

  • Members
  • 18 posts
  • OFFLINE
  •  
  • Local time:04:49 PM

Posted 17 February 2013 - 05:48 PM

I had teracopy on my machine and it wouldn't allow me to overwrite.  I uninstalled teracopy and it copied immediately when I allowed it as admin.

I have the file called napinsp..old in the system 32 folder and I copied the new one from winsxs, but it seems odd because the one I was trying to copy from winsxs was 67KB and the old one in system32 was something like 55KB. Now in my system32 folder the old file and current are both 67KB.

I really appreciate your time and help!



#12 narenxp

narenxp

  • BC Advisor
  • 16,371 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:India
  • Local time:04:49 PM

Posted 17 February 2013 - 06:05 PM

Do you still have the error? If yes please post the new system look log



#13 David Mc

David Mc
  • Topic Starter

  • Members
  • 18 posts
  • OFFLINE
  •  
  • Local time:04:49 PM

Posted 17 February 2013 - 06:20 PM

I did the file replacement again and still get the error on reboot.

It seems like it is replacing the file, but the log seems to say it is not.

Here is the log...

SystemLook 30.07.11 by jpshortstuff
Log created at 17:18 on 17/02/2013 by Dave
Administrator - Elevation successful
WARNING: SystemLook running under WOW64. Use SystemLook_x64 for accurate results.

========== filefind ==========

Searching for "napinsp.dll"
C:\Windows\NapiNSP.dll    --a---- 68096 bytes    [23:16 17/02/2013]    [01:41 14/07/2009] 58A0CDABEA255616827B1C22C9994466
C:\Windows\System32\NapiNSP.dll    --a---- 52224 bytes    [23:54 13/07/2009]    [01:16 14/07/2009] D41D8CD98F00B204E9800998ECF8427E
C:\Windows\SysWOW64\NapiNSP.dll    --a---- 52224 bytes    [23:54 13/07/2009]    [01:16 14/07/2009] D41D8CD98F00B204E9800998ECF8427E
C:\Windows\winsxs\amd64_microsoft-windows-n..ider-infrastructure_31bf3856ad364e35_6.1.7600.16385_none_0812326fa8e1ed67\NapiNSP.dll    --a---- 68096 bytes    [00:10 14/07/2009]    [01:41 14/07/2009] 58A0CDABEA255616827B1C22C9994466
C:\Windows\winsxs\x86_microsoft-windows-n..ider-infrastructure_31bf3856ad364e35_6.1.7600.16385_none_abf396ebf0847c31\NapiNSP.dll    --a---- 52224 bytes    [23:54 13/07/2009]    [01:16 14/07/2009] D41D8CD98F00B204E9800998ECF8427E

-= EOF =-


Edited by David Mc, 17 February 2013 - 06:22 PM.


#14 narenxp

narenxp

  • BC Advisor
  • 16,371 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:India
  • Local time:04:49 PM

Posted 17 February 2013 - 06:30 PM

You copied to wrong folder

 

C:\Windows\NapiNSP.dll    --a---- 68096 bytes    [23:16 17/02/2013]    [01:41 14/07/2009] 58A0CDABEA255616827B1C22C9994466

 

You should copy it to

 

C:\windows\system32 folder



#15 David Mc

David Mc
  • Topic Starter

  • Members
  • 18 posts
  • OFFLINE
  •  
  • Local time:04:49 PM

Posted 17 February 2013 - 06:45 PM

oopsaxesmiley.png

 

I tried again but I can't seem to get the larger file to copy into that folder.

It acts like it is copying (I have to agree to admin) but the log shows the file as the smaller version.

Not sure why.

Here's the latest log.  I deleted the file in the wrong spot did the whole thing from post #2 and still get the errors.

 

SystemLook 30.07.11 by jpshortstuff
Log created at 17:40 on 17/02/2013 by Dave
Administrator - Elevation successful
WARNING: SystemLook running under WOW64. Use SystemLook_x64 for accurate results.

========== filefind ==========

Searching for "napinsp.dll"
C:\Windows\System32\NapiNSP.dll    --a---- 52224 bytes    [23:54 13/07/2009]    [01:16 14/07/2009] D41D8CD98F00B204E9800998ECF8427E
C:\Windows\SysWOW64\NapiNSP.dll    --a---- 52224 bytes    [23:54 13/07/2009]    [01:16 14/07/2009] D41D8CD98F00B204E9800998ECF8427E
C:\Windows\winsxs\amd64_microsoft-windows-n..ider-infrastructure_31bf3856ad364e35_6.1.7600.16385_none_0812326fa8e1ed67\NapiNSP.dll    --a---- 68096 bytes    [00:10 14/07/2009]    [01:41 14/07/2009] 58A0CDABEA255616827B1C22C9994466
C:\Windows\winsxs\x86_microsoft-windows-n..ider-infrastructure_31bf3856ad364e35_6.1.7600.16385_none_abf396ebf0847c31\NapiNSP.dll    --a---- 52224 bytes    [23:54 13/07/2009]    [01:16 14/07/2009] D41D8CD98F00B204E9800998ECF8427E

-= EOF =-






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users