Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

napinsp.dll error


  • Please log in to reply
44 replies to this topic

#1 J.Smith

J.Smith

  • Members
  • 22 posts
  • OFFLINE
  •  
  • Local time:01:05 AM

Posted 17 February 2013 - 02:36 PM

I keep getting a pop-up message which says that the napinsp.dll has an error and i sometimes cant even start some programms cause it keeps spamming the error.I tried to research about the problem but couldnt find a trustfull way to fix it.The error mostly occurs when i start games or programms like steam,uplay and origin and often times crashes games.If anyone knows a way to fix this problem i would be really thankful!



BC AdBot (Login to Remove)

 


#2 narenxp

narenxp

  • BC Advisor
  • 16,371 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:India
  • Local time:07:05 PM

Posted 17 February 2013 - 02:40 PM

Click on startmenu and type

 

cmd

 

Right click on it and select run as administrator and run this command

 

sfc /scanfile=c:\windows\system32\napinsp.dll

 

Let me know the output of this command.



#3 J.Smith

J.Smith
  • Topic Starter

  • Members
  • 22 posts
  • OFFLINE
  •  
  • Local time:01:05 AM

Posted 17 February 2013 - 02:43 PM

It says it found no errors.Sorry for not copying the text but its german so i tried to translate it.



#4 narenxp

narenxp

  • BC Advisor
  • 16,371 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:India
  • Local time:07:05 PM

Posted 17 February 2013 - 03:05 PM

Download

system look

Copy this script and paste it in the BOX
 

:filefind
napinsp.dll


Click on LOOK,post the generated log


Edited by narenxp, 17 February 2013 - 05:06 PM.


#5 J.Smith

J.Smith
  • Topic Starter

  • Members
  • 22 posts
  • OFFLINE
  •  
  • Local time:01:05 AM

Posted 17 February 2013 - 03:11 PM

Administrator - Elevation successful
WARNING: SystemLook running under WOW64. Use SystemLook_x64 for accurate results.
 
========== filefind ==========
 
Searching for " napinsp.dll"
No files found.
 
-= EOF =-


#6 narenxp

narenxp

  • BC Advisor
  • 16,371 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:India
  • Local time:07:05 PM

Posted 17 February 2013 - 03:21 PM

Please download system look again and run the script,post the new log



#7 J.Smith

J.Smith
  • Topic Starter

  • Members
  • 22 posts
  • OFFLINE
  •  
  • Local time:01:05 AM

Posted 17 February 2013 - 03:24 PM

Administrator - Elevation successful
 
========== filefind ==========
 
Searching for " napinsp.dll"
No files found.
 
-= EOF =-


#8 narenxp

narenxp

  • BC Advisor
  • 16,371 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:India
  • Local time:07:05 PM

Posted 17 February 2013 - 03:29 PM

Give me some time.It seems you are missing the file.I need to get a clean copy of it



#9 J.Smith

J.Smith
  • Topic Starter

  • Members
  • 22 posts
  • OFFLINE
  •  
  • Local time:01:05 AM

Posted 17 February 2013 - 03:31 PM

I just want to say ty for being so kind and helping other people in your free time!I really appreciate that!



#10 narenxp

narenxp

  • BC Advisor
  • 16,371 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:India
  • Local time:07:05 PM

Posted 17 February 2013 - 05:08 PM

Hi

 

Can you re run the script again and post the log? I have edited the script.I'm sure vista and windows 7 should have a backup



#11 J.Smith

J.Smith
  • Topic Starter

  • Members
  • 22 posts
  • OFFLINE
  •  
  • Local time:01:05 AM

Posted 17 February 2013 - 05:17 PM

Administrator - Elevation successful
 
========== filefind ==========
 
Searching for "napinsp.dll"
C:\Users\Schmidt\Downloads\NapiNSP.dll    --a---- 50176 bytes    [13:42 17/02/2013]    [13:42 17/02/2013] 5E72DCFF9FB2374642043899A1C2E446
C:\Windows\System32\NapiNSP.dll    --a---- 68096 bytes    [00:10 14/07/2009]    [01:41 14/07/2009] 58A0CDABEA255616827B1C22C9994466
C:\Windows\SysWOW64\NapiNSP.dll    --a---- 0 bytes    [23:54 13/07/2009]    [01:16 14/07/2009] D41D8CD98F00B204E9800998ECF8427E
C:\Windows\winsxs\amd64_microsoft-windows-n..ider-infrastructure_31bf3856ad364e35_6.1.7600.16385_none_0812326fa8e1ed67\NapiNSP.dll    --a---- 68096 bytes    [00:10 14/07/2009]    [01:41 14/07/2009] 58A0CDABEA255616827B1C22C9994466
C:\Windows\winsxs\x86_microsoft-windows-n..ider-infrastructure_31bf3856ad364e35_6.1.7600.16385_none_abf396ebf0847c31\NapiNSP.dll    --a---- 0 bytes    [23:54 13/07/2009]    [01:16 14/07/2009] D41D8CD98F00B204E9800998ECF8427E
C:\Windows.old\Windows\System32\NapiNSP.dll    --a---- 68096 bytes    [00:10 14/07/2009]    [01:41 14/07/2009] 58A0CDABEA255616827B1C22C9994466
C:\Windows.old\Windows\SysWOW64\NapiNSP.dll    --a---- 52224 bytes    [23:54 13/07/2009]    [01:16 14/07/2009] 0B7E85364CB878E2AD531DB7B601A9E5
C:\Windows.old\Windows\winsxs\amd64_microsoft-windows-n..ider-infrastructure_31bf3856ad364e35_6.1.7600.16385_none_0812326fa8e1ed67\NapiNSP.dll    --a---- 68096 bytes    [00:10 14/07/2009]    [01:41 14/07/2009] 58A0CDABEA255616827B1C22C9994466
C:\Windows.old\Windows\winsxs\x86_microsoft-windows-n..ider-infrastructure_31bf3856ad364e35_6.1.7600.16385_none_abf396ebf0847c31\NapiNSP.dll    --a---- 52224 bytes    [23:54 13/07/2009]    [01:16 14/07/2009] 0B7E85364CB878E2AD531DB7B601A9E5
 
-= EOF =-


#12 narenxp

narenxp

  • BC Advisor
  • 16,371 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:India
  • Local time:07:05 PM

Posted 17 February 2013 - 05:34 PM

Click on startmenu and type

 

cmd

 

Right click on it and select run as administrator and run these commands

 

takeown /a /f  napinsp.dll

cacls napinsp.dll /g everyone:f

ren napinsp.dll napinsp.old

 

Now press Windows+R  key and type

 

C:\Windows\SysWOW64

 

and click ok

 

Copy napinsp.dll  and paste in c:\windowsystem32 folder

 

Reboot the PC and let me know if that helps


Edited by narenxp, 17 February 2013 - 06:44 PM.


#13 J.Smith

J.Smith
  • Topic Starter

  • Members
  • 22 posts
  • OFFLINE
  •  
  • Local time:01:05 AM

Posted 17 February 2013 - 05:44 PM

What is supposed to happen if i press windows+r key?If i try it nothing is really happening.



#14 David Mc

David Mc

  • Members
  • 18 posts
  • OFFLINE
  •  
  • Local time:07:05 PM

Posted 17 February 2013 - 05:51 PM

I get a pop-up to "run"  same thing happens when you type run and click on it same as you do with cmd.

Odd that we both are having the same problem at the same timesmile.png



#15 narenxp

narenxp

  • BC Advisor
  • 16,371 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:India
  • Local time:07:05 PM

Posted 17 February 2013 - 06:06 PM

Just browse to C:\Windows\SysWOW64 folder :)






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users