Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

New ATI HD7870 graphics card causing freeze on boot


  • Please log in to reply
2 replies to this topic

#1 ragnin

ragnin

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:09:35 PM

Posted 15 February 2013 - 09:11 PM

So I decided I needed a new graphics card since my old HD5850 just
doesn't give me enough power for games. I decided to go with a gigabyte
HD 7870 since it seemed like a good card. The problem is after swapping
it out my computer freezes on boot. The first time I try booting it
nothing happens the monitor and computer turn on but it just black
screens and stays there. After powering it down and restarting it then
it will display the first screen and freeze there (the screen that tells
me what buttons to push to get bios or boot menu and such). At this
screen it just freezes and I can't do anything, can't get into bios or
boot menu. I sent it back for a replacement and the same thing happens
with the new card so it has to be something else or very bad luck. If I
put my old card in the computer starts fine. I placed the card in my
roommates computer and his computer booted up fine so I'm not sure what
the problem is.


windows 7-64bit OS

i7-860 cpu with a coolmaster evo cpu cooler

intel DP55wg motherboard

coolmax NW-650B powersupply

CORSAIR Vengeance 8GB (2 x 4GB) 240-Pin DDR3 SDRAM DDR3 1600 (PC3 12800) Desktop Memory

Old graphics card is ATI HD 5850

New one that is not working gigabyte ATI HD 7870: -GV-R7870C-GD


My bios and drivers are up to date.



BC AdBot (Login to Remove)

 


#2 jhayz

jhayz

  • BC Advisor
  • 6,922 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:12:35 PM

Posted 16 February 2013 - 04:42 AM

Possibly a power supply problem. Have you tried swapping PSU of same or greater wattage just in case?


Tekken
 


#3 ragnin

ragnin
  • Topic Starter

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:09:35 PM

Posted 17 February 2013 - 12:39 AM

Did all the driver removing stuff and I have all the power connecters hooked up.  Still no go.  I even reset my CMOS.  I'm truly stumped.  My roommate has a Sapphire HD 7870 card so I took it and put it in and my comp booted up with no problem.  So for some reason the Gigabyte version of the card won't work on my comp and I have no clue why.  I'm just giving up and sending it back.  Going to try getting a Sapphire one since that seemed to work.  Thanks for your help.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users