Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Internal error: failed to expand shell folder constant "userappdata"


  • Please log in to reply
2 replies to this topic

#1 bahii

bahii

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:09:02 PM

Posted 11 February 2013 - 01:03 AM

Hello, I just had this pesky error and spent three hours researching and trying to fix it. I wanted to have this searchable in case others have come across the same problem. This problem occurs when you try to install certain programs. I tried all of these fixes, but I'll label the one that worked for me. (I will only show the fixes I tried which have been confirmed to work for others). My operating system is a Windows 7 64 bit. Enjoy thumbup2.gif

 

1. Create a new administrator account, log on to that account, then run the installer from that account. (this is what worked for me. )

 

(Simply running the installer as an administrator account from my normal account did not work)

 

 

 

2. Go to the command prompt (by clicking the windows logo/start and typing cmd ),

then type regedit inside the command prompt and press enter. Browse to the location: HKEY_CURRENT_USER --> Software --> Microsoft --> Windows -->Current Version --> Explorer --> User Shell Folders. Click to highlight the Recent key, then click File, export. Save the file (but remember where you saved it to). Go back to the registry editer, right click Recent and click delete. Restart your computer and try the installation again. (please take care when you're in the registry editer, deleting the wrong thing could lead to: rip_1.gif )

 

(If this one did not work, go back to User Shell Folders inside the registry editor, click a blank area inside the right pane, click File, import, and choose the Recent key you exported earlier. This will put the key back in your registry.)

 

 

3. Boot up in safe mode with networking ( to do this, start up your computer and press F8 like a

madman before the windows logo appears on the screen.) and try to run the installer as an administrator.

 

 

 

I hope this helps someone in the future. Cheers!


Edited by hamluis, 13 February 2013 - 02:51 PM.
Moved from All Other Apps to Win 7 - Hamluis.


BC AdBot (Login to Remove)

 


#2 narenxp

narenxp

  • BC Advisor
  • 16,371 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:India
  • Local time:09:02 PM

Posted 11 February 2013 - 03:06 AM

Thanks for sharing your fix but there is a fixit already available for same error.

 

Download this fixit

 

http://go.microsoft.com/?linkid=9708107

 

Run it and restart the PC.You will not receive the error.


Edited by narenxp, 11 February 2013 - 03:07 AM.


#3 dave032218

dave032218

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:10:02 PM

Posted 22 March 2018 - 10:19 PM

Thank you, bahii. I saw your fix first and it worked perfectly after hours of trying to install a much needed program. I appreciate very much your post!






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users