Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Network printing with a Canon Pixma MP600


  • Please log in to reply
3 replies to this topic

#1 byteguy

byteguy

  • Members
  • 47 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Washington state
  • Local time:08:09 AM

Posted 10 February 2013 - 02:14 PM

I have a client with a Canon Pixma MP 600 printer.  It's attached to a Win 7 machine via USB cable and works fine.  He wants to print to it over the network with a Win XP machine.  Unfortunately, we cannot make that happen.  No matter what we try, we come up against incompatible drivers.

Interesting thing is that the printer works just fine when attached to the XP machine.Once it is attached to the network, though, all bets are off.

I'm almost thinking it's a network problem, but sitting at the XP machine, I can see the files on the Win 7 machine as well as the printer.  Even went so far as to try to install the XP drivers on the Win 7 machine, as you are supposed to be able to do this in order to support other operating systems.  Win 7 machine says there are no compatible drivers on either the install disk or downloaded software.

Anyone have any ideas on this?

 


I have the power to channel my imagination into ever-soaring levels of suspicion and paranoia.

BC AdBot (Login to Remove)

 


#2 smax013

smax013

  • BC Advisor
  • 2,329 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Local time:11:09 AM

Posted 21 February 2013 - 08:38 AM

Interesting thing is that the printer works just fine when attached to the XP machine.Once it is attached to the network, though, all bets are off.

 

When you say the printer works fine when attached to the XP machine, do you mean that the printer works fine JUST from the XP machine?  Or can you also "share" it with the Win 7 machine and print to it across the network?



#3 dc3

dc3

    Bleeping Treehugger


  • Members
  • 30,714 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Sierra Foothills of Northern Ca.
  • Local time:09:09 AM

Posted 21 February 2013 - 11:09 AM

Have you downloaded the driver for Windows 7?

 

Canon U.S.A. : Support & Drivers : PIXMA MP600


Family and loved ones will always be a priority in my daily life.  You never know when one will leave you.

 

 

 

 


#4 byteguy

byteguy
  • Topic Starter

  • Members
  • 47 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Washington state
  • Local time:08:09 AM

Posted 21 February 2013 - 02:43 PM

The printer works just fine when hooked directly to the Windows XP machine.  It also works fine when hooked directly to the Win 7 machine.

When I try to network them, it "can't find the correct driver."

Curious.  After installing the XP driver on the SP machine and printing with USB, I put the printer back on the WIN 7 machine by USB, checked the printing, and then told the XP machine to locate the network printer.  No joy--said it did not have the correct drivers.  It's using the WIn 7 machine as a passthrough and shouldn't need any more drivers. 

Even if it did need drivers, it should have used the ones on the Win 7 machine.


I have the power to channel my imagination into ever-soaring levels of suspicion and paranoia.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users