Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

AHCI port 0 device error


  • Please log in to reply
No replies to this topic

#1 shqipo

shqipo

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:12:11 PM

Posted 05 February 2013 - 06:48 PM

I have a Dell XPS Studio. Not sure what brand HD (I think WD) cause I haven't taken it out yet. I only have one 1TB HD in my computer, yet, factory default, it was set in BIOS as RAID. A couple of days ago, I kept getting a message from Intel Rapid Storage Technology "Disk on port 0: At Risk". I had the option to set it to normal. Which I did. Whenever I tried to restart the PC, it gives me a black screen with this Error code: AHCI Port0 Device Error. Press f2 to resume Which I did, and it would go back to normal windows login screen and computer would operate.

I tried a sfc scan and it didn't show any errors. I tried chkdsk. First time it didn't start when I restarted my computer. Second time it did. I let it run overnight last night and this morning I woke up to the "AHCI Port0 Device Error. Press f2 to resume" screen so I don't even know if it found and fixed any errors. As I continued to use the PC normally this morning, a window popped up saying hard drive was going to fail so I should back up. I have never seen it before. I turned the PC off immediately cause I want to get a new HD and clone this one, if I can.

1. There's a good chance the HD is failing, but why am I getting the AHCI error when I'm not using AHCI? In BIOS I only have two options for the HD: RAID or ATA. Is this error related to the actual HD failing or the computer is trying to look for another RAID drive and is not finding it?

2. I'm buying a new HD today. I already use CrashPlan cloud backup so most of my files are already backed up with them. I do shoot and edit photos. Do you recommend I get: A. a new larger (e.g. 2TB) HD for future expansion B. a 1TB (I was thinking about WD Caviar Black - unless you recommend something else) and clone the current one, plus get another HD (e.g. Green - or is Seagate fine?) to store all photos and use it as a scratch disk for Photoshop, considering I also back them up with CrashPlan or C. Two 2TB drives and set them up as RAID?

BC AdBot (Login to Remove)

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users