Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Failed to connect to a windows service


  • Please log in to reply
1 reply to this topic

#1 solobaggins

solobaggins

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:02:41 AM

Posted 04 February 2013 - 12:38 PM

Hi guys.

Yesterday when I logged into my PC I got the error message "Failed to connect to a windows service". After spending most of the rest of the day trying to find some solutions I am no further forward. I found two temporary solutions: one is to go on safe mode, open command prompt and type netsh winsock reset , but that stopped working after I reset a few more times. Another possible fix was to press F8 and then start with "last best configuration settings" but that only works sometimes.

What I did then was to completely reinstall windows vista last night thinking that a complete overwrite may resolve the issue. After the boring task of reinstalling and updating all my drivers and windows updates, everything was ok until I got the dreaded message again! Only this time start up is extremely slow and twice I've had the blue screen crash. The first time I didn't see what the error message was as the screen went away too quickly. I'm currently working in safe mode with networking still trying to find a solution. I have read on this site and others about potential fixes but nothing has worked so far for me.

Please help!

PS

I did try the below advice to provide you with some information but I can do everything listed apart from the bit in bold. I'm not sure why I can't save what I've done....sorry in advance.

Boot in safe mode and login under a local adminstrator account.

Right click My Computer and click manage, up will pop up a computer management window, in that window double click Services and Applications and then click Services.

In the list of services scroll down to "System Event notification" and double click it. The properties for this Service will then display.

Make sure the start up type is set to Automatic and make sure the Service status is set to Started.

After you have done this click "Event Viewer" in the far top left of the screen and click "System". This will bring up the logging of events in which have happened on your machine. This can help us determine whats causing the error.

So click "Action" on the top toolbar and click "Save log files as," save it somewhere and then upload it in your next post. Do not copy and paste it.

Incidently I found a potential fix on your site. URL below.
http://www.bleepingcomputer.com/forums/topic473923.html/page__st__30

I tried to delete the HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\gpsvc as the potential fix but couldn't. I followed these instructions:
gpscv folder in registry tree -> hit Permissions -> hit Advanced -> go to Owner tab, choose and hit your account name, click OK -> get back to Permissions, hit Administrators, choose full control, click OK -> now you're able to delete your gpsvc folder..........I still can't delete the entry.

I would be grateful if anyone can help further. It should be noted that at the moment my system has loaded normally at this time, but this was after about 25 startups. Sometimes it crashes and I lose internet ability and the system is extremely slow and unstable. Other times I need to load up in safe mode to do basic things like go on the internet to find advice.

Thanks in advance

Mr Baggins

BC AdBot (Login to Remove)

 


#2 narenxp

narenxp

  • BC Advisor
  • 16,371 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:India
  • Local time:09:41 PM

Posted 04 February 2013 - 09:40 PM

Right click on this key

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\gpsvc

Select PERMISSIONS

Click on ADVANCED

Click on OWNER and select your user account name under CHANGE OWNER options and click APPLY

Now go to SECURITY tab and click on ADD and type

Everyone in Dialog box

click ok and select Everyone and give full control permissions to it

If you still have issues try to delete the key in SAFEMODE.

IMPORTANT:Import the clean registry key and then reboot the PC




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users