Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Master Boot Record Error


  • Please log in to reply
11 replies to this topic

#1 stevealmighty

stevealmighty

    Bleepin' WormBreath


  • Members
  • 2,629 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Upstate NY
  • Local time:09:31 AM

Posted 30 March 2006 - 09:12 PM

Ok, this has been going on for a short while now (well, about a month) and it's bugging the crap out of me. When I restart my computer, I get the following error.


verifying DMI Pool Data.............

Master Boot Record Error

Press a key

**I press ENTER**

Master Boot Record Error

Press a key

**I press ENTER**

Boot from CD:

DISK BOOT FAILURE, INSERT SYSTEM DISK AND PRESS ENTER

**I press ENTER**

From here, it boots normally, and runs without any glitches. No freezing, no crashing, nothing out of the normal, and as far as operating (running) goes, it's completely fine. It only does this at startup. It doesn't matter if I have a disk in the dvd drive or not. I didn't install anything new when this happened, and I don't remember doing anything odd or "out of the norm" to the system. I've never been into the registry, and am good about keeping my AV updated (it updates and scans nightly) and run adaware, ewido and CWShredder frequently.

I do have a 200 gb Western Digital drive that I've partitioned with W2Kpro on a 9.77 gb partition (C:){Healthy, system}, and WIN XP pro on a 118.22 gb partition (F:) {Healthy, Boot} and then another partition for "other stuff" that's 58.32 gb (G:)......WTF? That only adds up to 186.31 gb total...so where's my other 13.69 gb? And windows disk manager says it's only 186.31 gb! OMG! And my 160 gb external drive only shows up as 153.38 gb! Grrrr :thumbsup: Probably the way it's measured, being 1000 mb=1gb instead of 1024mb=1gb. Anyways, in the BIOS it's set to boot from hard drive first, cd second and thrid (I don't have a floppy), and it's always been this way and have never had any problems with it before.

I've also run Nortons utilities from the CD and ran windows repair on it. It found a few things and fixed them, but I still get the boot error at startup.

Any ideas as to what's wrong with it or how I can (attempt) to fix it? Would it be easier to just reinstall the OS?

Thanks in advance for the help! :flowers: :trumpet:
War produces veterans, wounded both physically and mentally. They have sacrificed for us.....and it is now our job to help these veterans, as they have already helped us in ways we will never know, in ways that we cannot fathom, and in ways that we take granted every day.
Posted Image

BC AdBot (Login to Remove)

 


m

#2 dc3

dc3

    Bleeping Treehugger


  • Members
  • 30,040 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:Sierra Foothills of Northern Ca.
  • Local time:06:31 AM

Posted 31 March 2006 - 01:47 AM

Is this after the POST, if not clear the CMOS. If it is after the POST you may want to go to WD and download their diagnostic tool to a floppy and run it.

Family and loved ones will always be a priority in my daily life.  You never know when one will leave you.

 

 

 

 


#3 Albert Frankenstein

Albert Frankenstein

  • Members
  • 2,707 posts
  • OFFLINE
  •  
  • Gender:Female
  • Location:Michigan, USA
  • Local time:10:31 AM

Posted 31 March 2006 - 07:35 AM

Well, as I am thinking about this, let me say a couple of things:

Probably the way it's measured, being 1000 mb=1gb instead of 1024mb=1gb

Yes, that is correct. Windows counts differently than manufacturers do and you can get discrepencies like this fairly commonly.

When your computer finally boots, do you get a menu so that you can choose what operating system to boot to, or does it just boot up? If it just boots up, what operating system is it booting to?

Are all partitions primary partitions? You can check by using Disk Management, they should show up as blue. Start > right click on My Computer > Manage > Disk Management

Another idea is to post a copy of the contents your boot.ini file here for us to take a look at.
ALBERT FRANKENSTEIN
I'M SO SMART IT'S SCARY!


Currently home chillin' with the fam and my two dogs!


#4 stevealmighty

stevealmighty

    Bleepin' WormBreath

  • Topic Starter

  • Members
  • 2,629 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Upstate NY
  • Local time:09:31 AM

Posted 31 March 2006 - 08:20 AM

Is this after the POST, if not clear the CMOS. If it is after the POST you may want to go to WD and download their diagnostic tool to a floppy and run it.


dc3, I'm not sure exactly what "post" is :thumbsup: It gets the boot error just before I get to the screen that allows me to choose which OS to run. My BIOS is updated to the latest and greatest that Abit has to offer for this board though, if that's any help!


Albert Frankenstein, to answer your questions.....

When your computer finally boots, do you get a menu so that you can choose what operating system to boot to, or does it just boot up? If it just boots up, what operating system is it booting to?


Yes, I get the screen asking which system I'd like to start. If I don't choose XP pro, it automatically picks it in 30 seconds.

Are all partitions primary partitions? You can check by using Disk Management, they should show up as blue


No, only drive (C:) and (G:) are listed as primary partitions, while (F:) is listed as a logical drive.

I forgot to mention that Win2K pro is installed on the C: drive, while XP pro is installed on the F: drive. It's always been this way though, so I'm still confused as to why this just started. Maybe 2 months ago, I changed around my drive (deleted an unused partition, and gave that space to either F: or G:, and I think it was G:. I believe that everything was fine after that though (meaning that I don't remember this boot error starting after I did that change to the partition).

I did a search for *boot.ini and came up empty handed. How do I find that info so I can post it for you? Sorry, but I've never done that before, so I don't know where that info is :flowers:

Thanks for your help both of you! :trumpet:

Edited by stevealmighty, 31 March 2006 - 08:25 AM.

War produces veterans, wounded both physically and mentally. They have sacrificed for us.....and it is now our job to help these veterans, as they have already helped us in ways we will never know, in ways that we cannot fathom, and in ways that we take granted every day.
Posted Image

#5 Albert Frankenstein

Albert Frankenstein

  • Members
  • 2,707 posts
  • OFFLINE
  •  
  • Gender:Female
  • Location:Michigan, USA
  • Local time:10:31 AM

Posted 31 March 2006 - 08:32 AM

I did a search for *boot.ini and came up empty handed. How do I find that info so I can post it for you?

Start > My Computer > C: then Tools > Folder Options > View tab

Select "Show hidden files and folders" and UNcheck the next two selections: "Hide Extensions for Known File Types" and "Hide Protected Operating System Files (recommended)". Now you will receive a warning dialog box, just click "Yes", and then Apply and OK. Now your boot.ini file should be visible to you. Open it up, copy and paste it back in here.
ALBERT FRANKENSTEIN
I'M SO SMART IT'S SCARY!


Currently home chillin' with the fam and my two dogs!


#6 stevealmighty

stevealmighty

    Bleepin' WormBreath

  • Topic Starter

  • Members
  • 2,629 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Upstate NY
  • Local time:09:31 AM

Posted 31 March 2006 - 10:20 AM

Here it is!




[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(3)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(3)\WINDOWS="Microsoft Windows XP Professional" /fastdetect /NoExecute=OptIn
multi(0)disk(0)rdisk(0)partition(1)\WINNT="Microsoft Windows 2000 Professional" /fastdetect


Thanks again :thumbsup:
War produces veterans, wounded both physically and mentally. They have sacrificed for us.....and it is now our job to help these veterans, as they have already helped us in ways we will never know, in ways that we cannot fathom, and in ways that we take granted every day.
Posted Image

#7 Enthusiast

Enthusiast

  • Members
  • 5,898 posts
  • OFFLINE
  •  
  • Location:Florida, USA
  • Local time:09:31 AM

Posted 31 March 2006 - 10:33 AM

The following may help you as well:

Multibooting with Windows XP:
http://www.microsoft.com/windowsxp/using/s.../multiboot.mspx

As far as the discrepancy existing on how large your hard drive/s are, Western Digital just settled a class action lawsuit for overstating the size of their hard drives. It seems there are two methods of measurement.

Here is the notice I got for that:
http://archives.subscribermail.com/msg/NOTI5BB159DD.htm

and

http://www.wdc.com/settlement/

Edited by Enthusiast, 31 March 2006 - 10:36 AM.


#8 Albert Frankenstein

Albert Frankenstein

  • Members
  • 2,707 posts
  • OFFLINE
  •  
  • Gender:Female
  • Location:Michigan, USA
  • Local time:10:31 AM

Posted 31 March 2006 - 02:33 PM

Here is another idea as far as troubleshooting this issue goes:

Change your boot up sequence in the BIOS, so that the hard drive is #1. Let see what happens to those error messages now! Let us know.
ALBERT FRANKENSTEIN
I'M SO SMART IT'S SCARY!


Currently home chillin' with the fam and my two dogs!


#9 stevealmighty

stevealmighty

    Bleepin' WormBreath

  • Topic Starter

  • Members
  • 2,629 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Upstate NY
  • Local time:09:31 AM

Posted 31 March 2006 - 08:16 PM

Here is another idea as far as troubleshooting this issue goes:

Change your boot up sequence in the BIOS, so that the hard drive is #1. Let see what happens to those error messages now! Let us know.



I checked my BIOS and it is set to boot to the hdd first, hdd second and cdrom third. I don't have a floppy, so I just changed the first boot to the hdd. Like I said though, I haven't had an issue before, and am not sure why it's started to act up :thumbsup:
War produces veterans, wounded both physically and mentally. They have sacrificed for us.....and it is now our job to help these veterans, as they have already helped us in ways we will never know, in ways that we cannot fathom, and in ways that we take granted every day.
Posted Image

#10 Albert Frankenstein

Albert Frankenstein

  • Members
  • 2,707 posts
  • OFFLINE
  •  
  • Gender:Female
  • Location:Michigan, USA
  • Local time:10:31 AM

Posted 31 March 2006 - 08:17 PM

Well, what you say makes sense in that the first error message you get:

Master Boot Record Error

Press a key

happens when your computer tries to boot from the HD. Then you get a second message:


Master Boot Record Error

Press a key

When the computer tries to boot from the HD the second time. Then you get a third message:

Boot from CD:

DISK BOOT FAILURE, INSERT SYSTEM DISK AND PRESS ENTER

When the computer tries to boot from the CD. You have no disk in, so it can't boot from it.

Change the boot order to CD first, then your HD.

I think it may help you to boot from your XP cd and start up the recovery console, then run 'fixboot C:' or 'fixmbr'. More info on this can be found HERE. Of course I am assuming you have good data backups at this point?

Edited by Albert Frankenstein, 31 March 2006 - 08:31 PM.

ALBERT FRANKENSTEIN
I'M SO SMART IT'S SCARY!


Currently home chillin' with the fam and my two dogs!


#11 Albert Frankenstein

Albert Frankenstein

  • Members
  • 2,707 posts
  • OFFLINE
  •  
  • Gender:Female
  • Location:Michigan, USA
  • Local time:10:31 AM

Posted 31 March 2006 - 08:51 PM

FYI you can edit your boot.ini file quite easily to make your computer boot faster. Waiting 30 seconds is kind of boring!

Start > right click My Computer > Properties > Advanced tab > Startup and Recovery Settings

Change the setting next to: 'Time to display list of operating systems". I like 3 seconds. This is long enough for you to be able to hit the up or down arrows on your keyboard to stop the countdown if you don't want the default selection, but not too long to wait.

Just a suggestion for more pleasant computing. :thumbsup:
ALBERT FRANKENSTEIN
I'M SO SMART IT'S SCARY!


Currently home chillin' with the fam and my two dogs!


#12 stevealmighty

stevealmighty

    Bleepin' WormBreath

  • Topic Starter

  • Members
  • 2,629 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Upstate NY
  • Local time:09:31 AM

Posted 04 April 2006 - 03:03 PM

Sorry for the delay in getting back to you.....I was out of the loop for a bit!

I'll try those things this weekend. That way if I screw something up, I'll just throw in the towel and reinstall windows completely!

Thanks for the help and I'll let you know how I fare with this!
War produces veterans, wounded both physically and mentally. They have sacrificed for us.....and it is now our job to help these veterans, as they have already helped us in ways we will never know, in ways that we cannot fathom, and in ways that we take granted every day.
Posted Image




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users