Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

WD Drive Won't Mount on MacbookPro


  • Please log in to reply
3 replies to this topic

#1 rdallas

rdallas

  • Members
  • 11 posts
  • OFFLINE
  •  
  • Local time:03:43 AM

Posted 30 January 2013 - 11:34 PM

I just bought a WD My Passport 2TB Portable External USB 3.0 Hard Drive (WDBY8L0020BBK-NESN) I used it for my PC until I completed setting up my Macbook. I transferred all the data to my Seagte 3TB HardDrive and formatted it to exFat to read/write on both my PC and MacbookPro

It was working fine, I used it last yesterday. But now I'm trying to mount it won't work. It will let me enter the WD Security Password, but won't mount.

Disk Utility will read it, but won't mount. Like I can see its there, but it says "not mounted"

I've plugged it into my PC and it mounted right away and works on my PC.

On the MBP all its doing is the back white light is flashing.

[UPDATE: After about 20 minutes it decided to mount]

Should I be worried? I've read else this is a sign that the drive is dying - but I just bought it about a month ago.

Thanks in advance!

Edited by rdallas, 30 January 2013 - 11:34 PM.


BC AdBot (Login to Remove)

 


#2 rdallas

rdallas
  • Topic Starter

  • Members
  • 11 posts
  • OFFLINE
  •  
  • Local time:03:43 AM

Posted 10 February 2013 - 03:34 PM

this problem is getting worse, it takes approx. 30 minutes for my macbook to read the drive after I unlock it. this is getting ridiculous.

 

please advise?



#3 computerxpds

computerxpds

    Bleepin' Comp


  • Moderator
  • 4,489 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:USA
  • Local time:04:43 AM

Posted 10 February 2013 - 04:06 PM

Have you tried turning off drive lock to see if it still takes forever to mount? If its mounting quickly on windows but not on mac then I wouldn't worry *That* much about issues with the drive itself. 


sigcomp.png 
If I have replied to a topic and you reply and I haven't gotten back to you within 48 hours (2 days) then send me a P.M.
Some important links: BC Forum Rules | Misplaced Malware Logs | BC Tutorials | BC Downloads |
Follow BleepingComputer on: Facebook! | Twitter! | Google+| Come join us on the BleepingComputer Live Chat on Discord too! |

#4 rdallas

rdallas
  • Topic Starter

  • Members
  • 11 posts
  • OFFLINE
  •  
  • Local time:03:43 AM

Posted 13 February 2013 - 02:26 PM

to remove the password lock i have to format it. and that's too much work. it was working fine before, quick mount and unmount, now it takes forever.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users