Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

checking file system in C


  • This topic is locked This topic is locked
14 replies to this topic

#1 Stuffed

Stuffed

  • Members
  • 55 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:01:07 AM

Posted 25 January 2013 - 09:39 PM

Hi,

Every time I start my computer I get this message;

Checking file system on C: The type of the file system is NTFS. One of your disk needs to be checked for consistency. You can cancel the disk check, but it is strongly recommended that you continue. To skip disk checking, press any key within(10)seconds.

I have allowed it to continue numerous times, but it makes no difference, this same error comes up every time I start my computer, now I just press a key within 10 seconds and that gets rid of it. Any ideas of how I can permanently get rid of it?

Yours, Stuffed.

BC AdBot (Login to Remove)

 


#2 Broni

Broni

    The Coolest BC Computer


  • BC Advisor
  • 42,697 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Daly City, CA
  • Local time:08:07 AM

Posted 25 January 2013 - 10:04 PM

Click Start and in "Start search" type cmd.
Hold SHIFT and CTRL keys, press Enter.
At the prompt in the command window that opens, type:
fsutil dirty query C:
and press "Enter".
Does the result of this indicate the drive is "Dirty"?

My Website

p4433470.gif

My help doesn't cost a penny, but if you'd like to consider a donation, click p22001735.gif


 


#3 Stuffed

Stuffed
  • Topic Starter

  • Members
  • 55 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:01:07 AM

Posted 26 January 2013 - 01:43 AM

When I do the following;

fsutil dirty query C:
and press "Enter".

I get this;

The FSUTIL utility requires that you have administrative privileges.

I am the only person to use this computer so how do I get around that?

#4 Broni

Broni

    The Coolest BC Computer


  • BC Advisor
  • 42,697 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Daly City, CA
  • Local time:08:07 AM

Posted 26 January 2013 - 08:10 PM

You didn't follow my instructions and you didn't run "cmd" as Administrator....

Click Start and in "Start search" type cmd
Hold SHIFT and CTRL keys, press Enter.


My Website

p4433470.gif

My help doesn't cost a penny, but if you'd like to consider a donation, click p22001735.gif


 


#5 Stuffed

Stuffed
  • Topic Starter

  • Members
  • 55 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:01:07 AM

Posted 27 January 2013 - 06:28 PM

Yes, you were right, sorry about that.

OK what I get is this;

Volume - C: is dirty

#6 Allan

Allan

  • BC Advisor
  • 8,589 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:New Jersey
  • Local time:11:07 AM

Posted 27 January 2013 - 06:33 PM

right-click on a command prompt icon and open as administrator. In the command prompt window type: chkdsk /r (then press ENTER). You'll be told the disk is in use and asked if you want to run checkdisk on the next boot. Say yes, exit the command prompt window, and reboot.

#7 Broni

Broni

    The Coolest BC Computer


  • BC Advisor
  • 42,697 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Daly City, CA
  • Local time:08:07 AM

Posted 27 January 2013 - 07:39 PM

* If you have Spyware Doctor installed, uninstall it.
* If you have ZoneAlarm installed, open it, click the "Overview" tab, then select "Preferences", and UNcheck the "Protect ZA Client" check box.


Click Start and in "Start search" type
cmd
Hold SHIFT and CTR key, press Enter.
At the prompt in the Command window, type the following commands, pressing "Enter" after each one:
Please, note the spaces.

* chkntfs /d <--- (This will reset autocheck options to default...will come back invalid on some installations)
* chkntfs /c C: <--- (This will allow checking the specified drive )
* chkntfs /x C: <--- (The x switch tells Windows to NOT check the specified drive on the next boot)


At this point, restart your computer, it will not do a chkdsk and will boot directly to Windows.


This next step is important as this is where the Dirty Bit will be unset.

Click Start, then Run, type cmd in the Open box and click "OK".
At the command prompt, type the following, pressing "Enter" after each one:
Again, note the spaces.

* chkdsk /f /r C: <--- (To manually run a full chkdsk operation on the specified drive)
* Y <--- (To accept having it run on the next boot)


This should take you through 5 stages of the scan and will unset the Dirty Bit.
Be patient...this is a very thorough check and will take quite a while.

Finally, when the chkdsk operation has completed, type:
fsutil dirty query C:
press "Enter", and Windows will confirm that the Dirty Bit is not set on that drive.

Reboot again and see if chkdsk still runs on startup.

Edited by Broni, 27 January 2013 - 07:41 PM.

My Website

p4433470.gif

My help doesn't cost a penny, but if you'd like to consider a donation, click p22001735.gif


 


#8 Stuffed

Stuffed
  • Topic Starter

  • Members
  • 55 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:01:07 AM

Posted 28 January 2013 - 12:04 AM

OK done all that,and what I get is;

Volume - C: is NOT Dirty

#9 Broni

Broni

    The Coolest BC Computer


  • BC Advisor
  • 42,697 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Daly City, CA
  • Local time:08:07 AM

Posted 28 January 2013 - 07:51 PM

Very well.
Does "chkdsk" still bother you at startup?

Edited by Broni, 28 January 2013 - 07:51 PM.

My Website

p4433470.gif

My help doesn't cost a penny, but if you'd like to consider a donation, click p22001735.gif


 


#10 Stuffed

Stuffed
  • Topic Starter

  • Members
  • 55 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:01:07 AM

Posted 31 January 2013 - 01:55 AM

I have been monitoring the computer over the last few days and it appears that the problem has gone, so thank you very much for your help, it is much appreciated.

#11 Broni

Broni

    The Coolest BC Computer


  • BC Advisor
  • 42,697 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Daly City, CA
  • Local time:08:07 AM

Posted 31 January 2013 - 06:30 PM

You're very welcome Posted Image

My Website

p4433470.gif

My help doesn't cost a penny, but if you'd like to consider a donation, click p22001735.gif


 


#12 folkdrop

folkdrop

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:08:07 AM

Posted 24 July 2014 - 01:50 PM

hi Broni I have got the same problem.I have donme everything but when type chkdsk /f /r C: 

 

I got the following message

 

Access Denied as you do not have sufficient privileges.
You have to invoke this utility running in elevated mode.

 

Pls let me know what to do from here!

 

Thanks in advance for your help



#13 hamluis

hamluis

    Moderator


  • Moderator
  • 55,730 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:10:07 AM

Posted 24 July 2014 - 03:12 PM

Elevated Command Prompt

 

The command that you want to type in is:  chkdsk /r , forget all those other letters :).

 

Louis



#14 folkdrop

folkdrop

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:08:07 AM

Posted 24 July 2014 - 03:29 PM

Hi hamluis,Thanks for your reply.Anyways,I think I have sorted the problem.I did it from the properties of C and then check errors and restart.It took nearly 1.5 hrs to finish 5 stages of update and its now showing C is not dirty and C is clean.



#15 hamluis

hamluis

    Moderator


  • Moderator
  • 55,730 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:10:07 AM

Posted 24 July 2014 - 05:03 PM

If you use system properties...then putting checks in both the "scan for" and "automatically fix" boxes is the equivalent of the chkdsk /r command.

 

If it's working, all's well :), no need to run the chkdsk /r command.

 

Happy computing :).

 

Louis.






3 user(s) are reading this topic

0 members, 3 guests, 0 anonymous users