Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Catalyst Driver won't install: "cannot be downloaded due to incompatible hardware"


  • Please log in to reply
No replies to this topic

#1 FatLord

FatLord

  • Members
  • 11 posts
  • OFFLINE
  •  
  • Local time:02:00 PM

Posted 25 January 2013 - 01:25 PM

Hi!

I bought a brand new Dell Inspiron 15r SE 7520 for christmas paired with an AMD Radeon HD7730m gaming GPU. This week, I tried to install the latest catalyst drivers from the AMD website (13.1) and I got this error message: http://imageshack.us/photo/my-images/829/screenshot5qk.png/ --> "AMD Catalyst Mobility cannot be downloaded due to insompatible hardware/software on your computer. The version of you graphic adapter is not supported. Please contact your notebook manifacturer for a graphics driver update."

I tried to reinstall the same drivers many times, and still got the same error message. Freak, because the AMD 7730m is working properly in Device Manager and I am 100% sure I am using the right drivers. So here are the things I tried:

-Uninstalling CCC completely in control panel + regedit and complete reinstall. Nothing changed.
-Deleting the AMD GPU in Device Manager and removing all of its drivers in order to reset it. Nothing changed.
-Installing the AMD beta drivers. They successfully worked for about 5 hours, and then after they automatically uninstalled (???) and I am back at the starting point.
-Installing modded drivers. No luck, it just automatically uninstalled just as the beta drivers. Really, this is awkward.

So now I'm stuck. What should I do? Any advices? Need some help over here!

Thank you very much.

EDIT: I went to Dell Canada's website to update the drivers and it seemed to work. However, those are the OLD graphic drivers from november 2012 (not 13.1) and it's 25% weaker than the new ones. I still can't download the ones from AMD.com D: I think it's Dell who's blocking the AMD drivers so they want us to go by their crappy website. HOW TO BYPASS THIS??

Edited by FatLord, 25 January 2013 - 01:31 PM.


BC AdBot (Login to Remove)

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users