Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Wireless capability is turned off on a Toshiba L40-10U with an ATheros AR5007EG


  • Please log in to reply
1 reply to this topic

#1 andrewcezar

andrewcezar

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:03:32 AM

Posted 25 January 2013 - 12:49 PM

Hello all. I don't even know from where to start. If someone's able to help me, I'll be grateful.

The problem is like this: I own a Toshiba Equium L40-10U :

-Processor : Intel® Celeron® M CPU 520 @1.6 GHZ
-Memory : 1GB of RAM
-Qualcomm Atheros AR5007EG Wireless.


It came with a 32 bit Windows Vista Home Premium, and I recently updated it to a 32 bit Windows 7 Ultimate.

When I was running on Vista, the wireless kept turning on and off, without me disabling it. I thought it was a driver issue, so I updated the drivers, again, it was working fine, but the problem appeared again.
I then upgraded my operating system to 7 Ultimate, Windows Update updated my wireless driver, and it worked for a couple of hours, and while I was on the internet reading something, I saw this pop-up on my screen: "Wireless Lan OFF". Since then I cannot seem to "activate " my wireless.

Should I mention that there is no actual switch to turn the wireless on or off, is just a hotkey combination: Fn and number 8.
And now when I press that, it just gives me a popup: "Wireless Lan OFF". It doesn't matter how many times I press it , it still says that is off.

I'll attach a print screen to see exactly the pop-up message(see first attachment)
Posted Image

In the device manager, the wireless adapter is there and functioning properly (see second attachment)

Posted Image

Things that I already tried:

-Uninstall wireless adapter, download & install latest wireless driver
-uninstall wireless adapter, manually install the driver
-disable "Allow the computer to turn off this device to save power"
-Verify that all your Network Services are Started from Control Panel
-Disable IPV6
-I also tried this thing that I saw on another forum :

Most laptops have a hardware switch which disables the wireless card. More than once, I've come across a laptop which has had that switch either broken or broken off. The obvious solution would be to fix the switch, but that involves opening every freaking screw on the laptop to get access to the motherboard just to solder two small points. There is a huge potential of breaking something important in the process, but that is what I've done in the past. Last week the old *** laptop that I use as file server fell ill to the same issue. As I'm using my neighbors wireless signal, I couldn't really ask him if I could hook up an ethernet cable to his router instead (although I thought about it). But honestly, it wasn't worth the effort to open it up. So I started looking up how the wireless card is actually turned off and on using the switch. Here is what I found:

This applies to MiniPCI wireless cards only. Pin # 13 controls the "silent RF" mode. That is what most hardware switch activate in order to turn off your wireless. You'll notice that while you lose your internet connection when the switch is turned off, your hardware is still visible in device manager. The solution is to take your wireless card out, and apply a small amount of tape over just pin #13, and put it back in. That's it. Your wireless card will always see the hardware switch as being turned on. You can still disable the wireless using Fn+f2 or whatever the hotkey is for your laptop.

The pin numbering alternates from side to side so that all odd pins are on one side and even pins are on the other. So if this is your MiniPCI card, tape this pin:

Update: For mini pci express, it is pin #20, which is responsible for the same function (also active low). It is located on the underside of the board, second pin from the notch toward the side with more pins.


Unfortunately that didn't work.

I ran out of ideas. Please help.

Edited by andrewcezar, 25 January 2013 - 12:49 PM.


BC AdBot (Login to Remove)

 


#2 Sneakycyber

Sneakycyber

    Network Engineer


  • BC Advisor
  • 6,111 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Ohio
  • Local time:04:32 AM

Posted 26 January 2013 - 04:17 AM

I would try removing all of the TOSHIBA connection utilities as well as any that are provided by Atheros.NOTE:I do not mean uninstall the device or the drivers. Give windows full rights to manage the hardware.it appears even though the device is working a program is stating the device is off. you could also try a different wifi card.


Edit thanks for the link i have isssues with my modified Intel card that goes to sleep

Edited by Sneakycyber, 26 January 2013 - 04:19 AM.

Chad Mockensturm 

Systems and Network Engineer

Certified CompTia Network +, A +





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users