Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Run main account as standard user, with admin account hidden


  • Please log in to reply
No replies to this topic

#1 aod_

aod_

  • Members
  • 41 posts
  • OFFLINE
  •  
  • Local time:02:12 AM

Posted 20 January 2013 - 04:08 PM

I've just installed a new copy of Windows 7 Ultimate. By default the 'first' user account (as declared in windows setup), is set at administrator level.
I want to run this 'main' account as a standard user, but when I went to change this in account settings, the option to change the account to standard was greyed out.

I decided to enable the administrator account to change this (computer management/local users and groups, un-ticked 'account is disabled'). I logged on as administrator, then changed the main account to standard.

As the Administrator account is now 'enabled', it shows on the welcome screen. I don't want this.
I went back and disabled it (running computer management as admin, in the now standard account, and re-ticked 'account is disabled').
technically, this should be how it was before I touched it, except, the 'main' account is now at standard user level, rather than administrator level.

The problem i have now, is when trying to run anything on the standard account, that needs admin rights, i get the UAC box, asking to enter admin password (which is blank), but there is no 'administrator' icon or password field, and the 'yes' button is greyed out.

How can I have my main account as standard user, the administrator account not showing on welcome screen, but allowing it (admin) to authorise actions on the standard account that required admin rights via UAC? i.e when UAC comes up, I can click 'yes' to run as administrator. At the moment, the correct process happens, but 'yes' is greyed out, when the admin account is disabled. When the admin account is enabled, this works (yes button not greyed out), but the administrator account shows on the welcome screen, which i don't want.

Edited by aod_, 20 January 2013 - 04:10 PM.


BC AdBot (Login to Remove)

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users