Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Windows XP SP 3 is not functioning properly after virus removal


  • Please log in to reply
3 replies to this topic

#1 CapnDrake

CapnDrake

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:04:13 AM

Posted 19 January 2013 - 10:37 PM

Hello and thanks for taking the time to heed my issue!

I am running Windows XP Home edition version 2002 Service Pack 3

My Laptop was infected with the malicious ransomware uKash where it locked me out of my OS. Even in safe mode I couldn't do anything so i had to create a bootable flash drive with hitman pro on it then removed it. However, after virus removal my OS is doing strange things. For example. I cannot access my Windows Firewall in control panel. I might still be infected with something but malwarebytes doesn't detect anything else.

when i try and open Windows Firewall in control panel i get the following prompt.. "Windows Firewall settings cannot be displayed because the service is not running. Do you want to start the windows firewall/Internet connection sharing (ICS) service?" i go yes then i get the prompt "Windows cannot start the windows firewall/internet connection (ICS) sharing service"

When i go to admin tools and access the services list and try to start ICS i get the following "Error code 1075: the dependancy service does not exist or has been marked for deletion"

Also Mozilla Firefox seems to not be working. everytime i try and open it i get the Mozilla Crash reporter "We're sorry Firefox had a problem and crashed" when i click restart the crash reporter just keeps popping up so i have to quit. I've tried removing it, re-installing it. Still no avail. I've tried the newest version and older version and still crash reporter comes up. other browsers liek IE and Chrome work just fine.

That's why i think I might still be infected with something because I can't even play any games online on my laptop. When I try playing PlanetSide 2 it doesn't start up the mozilla crash reporter pops up when i try and load the game <- this is bizarre because firefox has nothing to do with the game.

Also I can't play games online when I try and connect to battle.net in WC3 when i boot it up and click battle.net it disconnects me from the internet and my connection dies for a good 5 minutes


seems to be internet/registry or firewall issue i got no clue could you please help my OS return to normal?

Edited by CapnDrake, 19 January 2013 - 10:42 PM.


BC AdBot (Login to Remove)

 


#2 Nunos

Nunos

  • Members
  • 83 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:04:13 AM

Posted 19 January 2013 - 11:16 PM

There may be some damage to some of the WIndows System Files maybe we can start by running System File Checker.

http://www.northernaurora.com/page/articles.html/_/articles/system-file-checker-r38

You may be prompted for your XP CD so you may want to insure you have it first.

#3 noknojon

noknojon

  • Banned
  • 10,871 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Local time:07:13 PM

Posted 20 January 2013 - 07:33 PM

Hello -
Re: Error 1075: The dependency service does not exist or has been marked for deletion

The following is from M/Soft advice area. Please create a Restore point first so that you can go back if this will not work for you -
answers.microsoft.com
Just delete the registry entry and then Reboot the system. It should work just fine. It has worked for many people, so it is worth a try.

1.Click Start, click Run, type regedit in the Open box, and then click OK.

2.In Registry Editor, locate and then click the following registry subkey:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Dhcp

3.Right-click the DependOnService entry, and then click delete instead of modify

Thank You -

#4 CapnDrake

CapnDrake
  • Topic Starter

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:04:13 AM

Posted 20 January 2013 - 08:39 PM

After the SFC scan nothing happened. it just went back to the C: prompt

I deleted the dhcp registry then rebooted and nothing changed




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users