Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

New Installation of Ubuntu Oneiric 11.10


  • Please log in to reply
27 replies to this topic

#1 BLewellyn

BLewellyn

  • Members
  • 13 posts
  • OFFLINE
  •  
  • Gender:Female
  • Location:Upper Great Lakes Region AKA the Frozen North
  • Local time:08:14 PM

Posted 19 January 2013 - 11:03 AM

Hi,

I'm not sure exactly where this goes or what the problem is but since I am using Linux and that's what I suspect the problem is I will start here.

I have been experiencing this problem ever since I installed Ubuntu 11.10. I first noticed that when I boot up my monitor cycles off after a few seconds. I can turn it on again using the monitor power button but in less than 30 seconds it goes off again. At first I could just reboot and then it would be OK but eventually even that didn't work so I went into system set-up and noticed that the clock wasn't set correctly. hmmm... I set it and took a look at the monitor settings but couldn't figure out what to change if anything so I rebooted and googled some more. I can't find anything that addresses this exact problem but I did use the terminal to get some graphic interfaces and shut off the suspend and hibernate modes. That didn't work either.

Of course the clock needing reset indicated that it might be a problem w/the CMOS battery so I canniblized one from another computer that I know had a good one and changed that. (Ordered a couple of new ones too) But that didn't fix the problem and the clock needs to be reset everytime I boot.

Booting has become a 20 minute process. Here's how it goes: Boot-go into system and reset the clock. It then reboots and I go back into the system and make sure the clock is correct. Sometimes it isn't. If it isn't I reset it. Then boot all the way into Ubuntu and futz around w/ the monitor blinking out every 20-30 seconds while I log out and restart. Reset the clock again. Rinse repeat. The FIFTH time I reboot I can usually get the clock to stay set correctly and the monitor to stay on.

This is a Dell Dimension 3000 circa 2004 (I know, I know--it's ancient). It has 2 gigs of memory. The monitor is a flat screen generic Dell monitor that came w/the PC. These got medium use for a couple of years then they just sat in my daughter's hall until I took it in 2010 and it's gotten heavy daily use since then. I was hoping to get another 6-9 months out of it.

Before I installed Ubuntu 11.10 I had upgraded from 10.04 to Lubuntu (12.04 ?) but really hated that and this machine cannot deal with the newest version of Ubuntu so I went back to 11.04. The problems started when I upgraded to 11.10.

Sooo, what do you think? Should I try going back to 11.04 and see what happens or is it just a coincidence that this started after the upgrade. I don't think it happened right away but I'm not absolutely sure about that. It happened within a few days of the upgrade though--after some software updates I think. I should keep a diary when I do this stuff.

Maybe I should just go back to 10.04. Everything worked swell with that version but no more flash updates and I watch videos at Hulu and DramaFever online a LOT. I could watch them via ROKU so it isn't completely unfeasible but it wouldn't be as convenient.

OK, I'm starting to ramble so I'll quit.

BLewellyn

BC AdBot (Login to Remove)

 


#2 Zen Seeker

Zen Seeker

  • Members
  • 695 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Local time:08:14 PM

Posted 20 January 2013 - 01:56 PM

Hello,

Not sure what I can do to help but we can at least look at the basic stuff which you seem to know pretty well.

Ubuntu is a spin-off of Debain Linux, which is a good thing as both are well supported and documented. (Most packages that work for the one will work for either.)

When I had issues after upgrading once, months back, it was because DPMS was suddenly supported and turned on without my knowedge. I didn't even know it was there until I started searching for answers myself. (I found out that everything is fine until I watch a video, pause, resume and then DPMS will screen blank every 30 minutes.)

Lets see if DPMS is installed and enabled. (Energy saving, Display Power Management Signaling.)

Shouldn't need to be root or sudo; type "xset q", no quotes, and see if DPMS is enabled.

If it is there and enabled you can type "xset -dpms" to disable it. (This only works for the current session and will return to normal after a reboot.)

Let me know what you find out up to this point. We'll look at the clock issue after this. (You seem to know how to work around clock issues well enough for now.)


Regards,
Zen

#3 Zen Seeker

Zen Seeker

  • Members
  • 695 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Local time:08:14 PM

Posted 20 January 2013 - 01:59 PM

BTW - Do you dual boot into another OS or just Linux?

#4 BLewellyn

BLewellyn
  • Topic Starter

  • Members
  • 13 posts
  • OFFLINE
  •  
  • Gender:Female
  • Location:Upper Great Lakes Region AKA the Frozen North
  • Local time:08:14 PM

Posted 20 January 2013 - 03:25 PM

Hi Zen,

Thanks for your reply. Just FYI I realized I could go back to the 11.04 through that window that comes up when you cut the power to the machine without doing an Ubuntu shutdown. I'm pretty sure that solved the problem and I didn't lose anything that I can see but let's see what happens from here.

DPMS is disabled.

No I do not have a dual boot.

Good thing I like doing this kind of stuff or I'd be pulling my hair out. <grin>

Barbara

#5 Zen Seeker

Zen Seeker

  • Members
  • 695 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Local time:08:14 PM

Posted 21 January 2013 - 10:48 AM

Hi Barbara,

Do you mean the boot loader? It's the ascii or text window that comes up for a few seconds that allows you to choose which OS or tool to load. I don't recall what Ubuntu uses but it might be "Grub".

When I do upgrades/updates I tend to leave the last kernel that worked so that I can boot back into it if needed.

Does this mean your using the old kernel again, 11.04? (Everything else would still be updated.)

The config file that controls your video and monitor settings is "/etc/X11/xorg.conf" you can use "vi" or "vim" to view it. It will let you know what your settings are now and what video card driver your using. (nvidia, ati, etc.) As a normal user see if you can look inside this file and see what your settings are. If you do try to change things be aware that you can lose your GUI interface and be left at the command line on your next boot. Always backup a file before you make changes so you can just copy it back.

My setup has issues between using non-free drivers and Debian free video drivers. Some kernel updates also break my video as the new kernel doesn't yet support my settings. (Which happened last month or so.)

Hope things are working well for you under 11.04 but let me know.


Zen

#6 Zen Seeker

Zen Seeker

  • Members
  • 695 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Local time:08:14 PM

Posted 21 January 2013 - 11:33 AM

Further to my above post...

Read the following post on another board that has the same issue as you; http://askubuntu.com/questions/97475/monitor-shuts-off-after-installing-ubuntu-11-10-64-bit

It worked for the original poster there.


Regards,
Zen

#7 BLewellyn

BLewellyn
  • Topic Starter

  • Members
  • 13 posts
  • OFFLINE
  •  
  • Gender:Female
  • Location:Upper Great Lakes Region AKA the Frozen North
  • Local time:08:14 PM

Posted 21 January 2013 - 09:19 PM

Good evening Zen,

Once again, thanks for your reply. The screen I am talking about comes up when I do a hard reboot (ie shut the power off before logging out of Ubuntu). When I turn the power back on it reboots into a screen that gives me the option of booting into Ubuntu normally, booting into a safe mode, doing some memory tests, or using previous versions of Ubuntu. Oh, writing this out it just occurred to me that maybe it doesn't take me into 11.04. Maybe it is like Windows restore. hmmm...I will have to try it and let you know exactly what it says the next time I reply. Whatever, it works and I don't have to dick around for 20 minutes to get the monitor to stay on.

Ok, I may sort of understand the basic basics and I know how to use command lines but only if the commands are spoon fed to me. I need you to tell me exactly what to type into the terminal. Preferably in a form I can copy and paste. <grin> I do not have a clue otherwise. It all looks like a foreign language and I'm lost. The good news is that I am going to be getting some tutoring on using command lines from a Grad Student in exchange for cooking meals for him. We'll see if he can teach this old Gramma some new tricks.

In the meanwhile how do I view the settings for the monitor? What do you mean by backing thigs up. I have the Ubuntu cloud so everything that I want to save backs up automatically. Besides I don't do anything really important that I'm all that worried about losing anything. I keep my photos, my journal, and my recipes on a memory stick in addition to the Ubuntu cloud. It's a PITA for me to reinstall the OS but not a catastrophe.

On a related note I was able to figure out what graphics card I have. It is not ATI. It is VGA.

Thanks for your help.

Barbara

#8 Zen Seeker

Zen Seeker

  • Members
  • 695 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Local time:08:14 PM

Posted 21 January 2013 - 09:42 PM

No problem Barbara, I get stuck at times and need a second set of eyes myself from time to time.

Okay, first...that screen you see with the choices to select to boot from...that's your bootloader...and probably "Grub". After an update that provides a new kernel it should add a new option to load using the new kernel that you can select. So version 11.04 and 11.10 can possibly both be there. (My Linux branch goes by kernel versions rather than OS versions so I see 3.4-2 and 3.4-4, etc.)

Second, VGA stands for video graphics array and isn't your model of graphics card but can be a type of display.

vi and vim are simple editors, like notepad in Windows. They have their own set of rules on how to add, delete, append a document/file but can be found on most versions of Linux, just like notepad.

Did you go to the link I supplied above and read the posts there? Does it sound like your issue? We'll see if "sudo apt-get install fglrx" is needed or not either way.

I'll post steps on backing up a file and looking inside it tomorrow. (I'm in windows now and don't want to post the wrong thing when I couldn't double check it first.)

L8r,
Zen

#9 Zen Seeker

Zen Seeker

  • Members
  • 695 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Local time:08:14 PM

Posted 22 January 2013 - 10:05 AM

Lets copy your file first today.

From your Terminal window type the following followed by your password if asked; sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf.mybak

Now you can open this backup file and look around; vim /etc/X11/xorg.conf.mybak

Somewhere you should see a Section "Device" with a Driver "name". We want that "name". (That will be your graphics card.)

Look around in here for other options or settings like Option "DPMS" or Option "DPMS" "1" or Option "DPMS" "True".

Let me know what you see and what graphics card you have.

#10 Zen Seeker

Zen Seeker

  • Members
  • 695 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Local time:08:14 PM

Posted 22 January 2013 - 12:27 PM

Before I forget again; Here is a site with a list of commands that you can use in "vi" ir "vim". http://www.yolinux.com/TUTORIALS/LinuxTutorialAdvanced_vi.html

To close the open file = :q
To close and save file = :wq
To force closed without saving = :q!

Have a look at the guide like I attached first just so you are okay. (Its a backup file and you shouldn't be able to change anything unless you use "sudo" to open it.)


Regards,
Zen

#11 BLewellyn

BLewellyn
  • Topic Starter

  • Members
  • 13 posts
  • OFFLINE
  •  
  • Gender:Female
  • Location:Upper Great Lakes Region AKA the Frozen North
  • Local time:08:14 PM

Posted 24 January 2013 - 01:49 PM

Hi Zen,

New developments. The problem got so bad that I could not get the monitor to stay on so I reinstalled 10.10. Still having the same problem so I wondered if it was the monitor gone bad. I stuck an old CRT on there and that worked OK but it is in the process of dying and I can barely read it. My neighbor brought a small falt screen TV that I could use as a monitor but I couldn't get it to stay on either. Soooo he brought me a different computer to use (and maybe buy) and told me I could install Ubuntu on it. That's the first thing I did and upgraded right away to 11.10. I now have a dual boot w/windows set up.


Everything worked fine w/the TV last night after I got everything installed and updated but this morning I have the same problem.


I have a headache. That is all.

Here is what lspci says my graphics card is


barbara@bjgl-T5224:~$ lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation 82945G/GZ Integrated Graphics Controller (rev 02)
barbara@bjgl-T5224:~$

I will go through the rest of the stuff one by one.

Thanks for your help with this. I at least feel as if I am not sitting here all alone with this headache.

B

#12 BLewellyn

BLewellyn
  • Topic Starter

  • Members
  • 13 posts
  • OFFLINE
  •  
  • Gender:Female
  • Location:Upper Great Lakes Region AKA the Frozen North
  • Local time:08:14 PM

Posted 24 January 2013 - 03:51 PM

Hi Zen,

I installed the grapic card drivers recommended on the page you referred to. I think it may have solved the problems with the monitor. I have rebooted twice and was able to get into Windows too. I will say YAY with a qualifier--I'll believe it after I have shut it down and been away from the computer for awhile. I haven't turned my back on it yet. Ha!

B

#13 Zen Seeker

Zen Seeker

  • Members
  • 695 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Local time:08:14 PM

Posted 24 January 2013 - 06:33 PM

Excellent, hope it works out for you!

#14 BLewellyn

BLewellyn
  • Topic Starter

  • Members
  • 13 posts
  • OFFLINE
  •  
  • Gender:Female
  • Location:Upper Great Lakes Region AKA the Frozen North
  • Local time:08:14 PM

Posted 24 January 2013 - 07:12 PM

Hi Zen,

Thanks for your reply. It's still working although at one point I put the wrong password in to bring it up after it went into suspend while I took the dog out and then I had to do the startr/restart again until it came back but didn't have to do it too many times and I could not get it to repeat when I put the wrong password in. Weird.

I have a question. Do I need two different accounts. One for admin and one to play with? I have both but I have been told that is not necessary.


The system clock isn't telling the right time on this machine either.

Lets copy your file first today.

From your Terminal window type the following followed by your password if asked; sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf.mybak

Now you can open this backup file and look around; vim /etc/X11/xorg.conf.mybak

Somewhere you should see a Section "Device" with a Driver "name". We want that "name". (That will be your graphics card.)

Look around in here for other options or settings like Option "DPMS" or Option "DPMS" "1" or Option "DPMS" "True".

Let me know what you see and what graphics card you have.


could not get this to work. It said there was no such file after the first command.

Barbara

#15 Zen Seeker

Zen Seeker

  • Members
  • 695 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Local time:08:14 PM

Posted 25 January 2013 - 12:16 PM

Hello,

1. By default in Linux, like windows, you have at least two accounts. The administrator, called root in Linux/Unix, and the installers user account called whatever you selected when installing.
The user account in Linux can act like the root account at any time by using "sudo".(I've read a bunch of things over the years for what "sudo" stands for but I like the one "SuperUserDO".)
When you need to do something that requires the SuperUser account root you can do it with your own account by typing; sudo command any-other-extra-requirements
Have a look here; https://help.ubuntu.com/community/RootSudo

You can use "your" account to play with or create a second account just for testing things. Up to you but I usually stick with one account unless it's for work testing.

Note: In order for sudo to work you need to be part of the sudoers group which I have found doesn't always happen automatically like it did in the past.


2. If the video seems resolved we don't need to worry about xorg.conf or vi/vim. But just out of curiosity did you leave a space between; sudo cp /etc/X11/xorg.conf<SPACE>/etc/X11/xorg.conf.mybak Although you might not have an xorg.conf file created I would expect one. The above string/command needs to be copied exactly as case matters in Linux and "x" is NOT the same as "X". What the above string means is use the SuperUser to copy a file found at /etc/X11/ called xorg.conf to a second new file named xorg.conf.mybak.

But as I said, if things are working as-is lets just back away slowly and leave it be. ;c)


3. Clock issues in Linux are usually simple enough once you set it once it's done. However using dual boot it can make things a pain as both Windows and Linux will change the time when you login to match what it believes is the correct time. Usually advancing one of the OSes hours ahead or behind.

In a terminal window in Linux type "date" without the quotes. If the date and time look alright you might need to right click on the clock on your screen so you can adjust the date and time through the GUI, Graphical User Interface. If that's the case its usually the time zone.

If the date/time is off in the terminal window you can correct it by typing; sudo date YYMMDDhhmm.ss -u Which would look like; sudo date 1301252212.23 -u
The date command uses 24hr format and you can drop the year or seconds if you wish. -u stands for setting Coordinated Universal Time.

date --help will show you all the command line switches and some explanations.

It will take a few minutes for any changes you make in the terminal window to show up in the GUI clock on your desktop so don't expect it to happen at the same time.


Let me know if this helps you at all.


Regards,
Zen




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users