Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

website virus


  • Please log in to reply
1 reply to this topic

#1 ladynic

ladynic

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:10:05 PM

Posted 17 January 2013 - 10:02 AM

Hello
I have a virus on my website that deleted my theme. Now I only see a white page with writing and pictures. The page will only come on the screen for a few seconds then it shows a blank page and it says its loading but nothing ever happens.
I've contact my web host and they did a security sweep. Stated that I have to contact the site that my website was created through which is word press. They gave me stuff on what to do but I have no clue where to start and what the terms are. So I contacted badwarebusters.org. They said Malicious Code detected on Line 111, 113, 115, 117, 119, 121

Starts with <!—>;_1Ol=’7kSKlBXYjNXZfhSZwF2YzVmb1hSZ0lmc35 ..var 0×84de=[“ABCDEFGHIJK.. charAt”,“indexOf”,“fromCharCode” .. ;} ;eval(O00(01O(→

Now I went in my view page source and found it. My problem is how do I remove it?
This is my first time building and maintaining a website. I learn from asking search engines info that I need.
I don't know any technical terms at all.That is also a problem cause when I do get help its from computer techs that know what they are talking about only problem it I don't.
Can anyone out there help me out? Im using mac os x 10.4. If that helps.
Thanks lots
Nikki

Moderator edit:
Moved to a more appropriate forum, From Mac OS
Roger

Edited by rotor123, 17 January 2013 - 11:00 AM.


BC AdBot (Login to Remove)

 


#2 KamakaZ

KamakaZ

  • Members
  • 739 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Victoria
  • Local time:02:05 PM

Posted 17 January 2013 - 04:11 PM

To remove the malware it is as simple as going to those lines in code and deleting the infected parts (may not be the whole line).

The harder part is finding why it got there in the first place, I would suggest changing you cPanel ( or other control panel), FTP, mySQL( or other database) and any other passwords relating to your hosting. Also have a look for any unknown files that may have been uploaded to your server. Always try to keep Wordpress and plugins up to date (reduces the vulnerability).

There's no place like 127.0.0.1
There are 10 types of people in the world, those that can read binary, and those who can't.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users