Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

DVD/CD-ROM Is There But Not Reading Discs


  • Please log in to reply
3 replies to this topic

#1 KramerTM

KramerTM

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:05:02 AM

Posted 15 January 2013 - 11:04 AM

On a scale of 1-10 in computer literacy, I give myself between a 5 and 6, so please go easy.

Cliff's Notes: DVD/CD-ROM drive appears as a drive in Windows Explorer but it does not seem to read any CD or DVD that I put in. It worked fine yesterday and only stopped working after two new programs were installed (Daemon Tools Lite and Astroburner Lite).

A Little History on How We Arrived Here
1. Got a nasty virus about a year ago that blue screened me.
2. Cleaned it up as best I could following lots of guidance online. It "seems" to be contained and the remnants really only do two things which are noticeable to me: a> redirect google link clicks to third-party sites, and b> all shortcuts to programs in the start menu have disappeared
3. Have been running both malwarebytes and BitDefender since I have cleaned up the virus, which seem to be keeping it contained.
4. PC has been running very slowly since virus attacked and now running both these programs, so decided I wanted to just save my data on an external HD and format the drive to start from scratch
5. DVD/CD-ROM confirmed working just fine as of yesterday when I successfully installed TurboTax from a CD
6. Incorrectly thinking I needed to run a data destroyer/wipe program to format the drive and kill the virus, I stumbled upon the program DBAN (Darik's Boot & Nuke) - a program in ISO format that you just burn to a CD and boot to it in order to wipe a hard drive
7. Being computer illiterate, I was not sure how to burn, so tried to drag and drop the ISO file to the CD drive (note: blank DVD booted up normally when I inserted it). Got a generic error message that it did work. Assume I was missing CD burning software so went to search for free software.
8. Saw good reviews for Daemon Tools Lite, so I downloaded it and ran it.
9. Followed instructions and clicked "Burn to CD" and it prompted me to install Astroburner Lite in order to burn. I accepted, and it installed through the program. This time it allowed me to click "Burn to CD."
10. After 37 seconds, it told me that the process had failed, without much explanation why.
11. Assumed something was wrong with DVD, so put in a new blank one. This time it did not boot up like it did last time. Tried running burn process again and it failed.
12. Suspicious, I inserted a data CD and nothing showed up when I clicked on the DVD-RW Drive (D:) in Windows Explorer. Same for when I insert my Windows XP CD.

Actions Already Attempted
1. I have uninstalled both Daemon Tools Lite and Astroburner Lite through Add/Remove Programs in Control Panel.
2. I have uninstalled my DVD/CD-ROM from Device Manager and restarted the computer. The device seems to have re-installed successfully.
3. Pressed F2 during bootup and went into BIOS. Went to boot sequence and saw the following:
......1. Onboard or USB CD-ROM Drive
......2. Onboard or USB Floppy Drive (not present)
......3. Onboard or SATA Hard Drive (not present)
......4. ExcelStor Techbology
......5. Onboard Network Controller (not present)
......6. USB Device (not present)
4. Downloaded CDGone registry patch and merge with registry and rebooted.
5. Did a system restore to the date of the TurboTax installation when the CD-ROM was working fine.

System Info
Dell Dimension 9200 running Windows XP Home Edition Service Pack 3
Intel Core2 CPU 6300 @ 1.86Ghz
1.00 GB of RAM
DVD Drive: TSSTcorp DVD+-RW TS-H553A

Additional Info that May Not be Relevant
In Device Manager, there is a yellow exclamation point next to SM Bus Controller and when I click into Properties, it indicates that "The drivers for this device are not installed. (Code 28)." This has been this way for about 3 years since I put a new hard drive into the computer and does not seem to be in any way related to this recent issue.

What I'm ultimately looking to do is just format the hard drive and re-install Windows XP so I can get this thing back to clean, factory settings again. If there is some way to do that without necessarily solving this whole big issue, then I am open to that as well.

Edited by KramerTM, 15 January 2013 - 11:10 AM.


BC AdBot (Login to Remove)

 


#2 dc3

dc3

    Bleeping Treehugger


  • Members
  • 30,809 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Sierra Foothills of Northern Ca.
  • Local time:02:02 AM

Posted 15 January 2013 - 12:32 PM

Have you tried this drive in another computer?

The SM Bus Controller is the chipset drivers. You can download it from Dell.

Scroll down to Chipset, there is only 1 download.

Edited by dc3, 15 January 2013 - 12:34 PM.

Family and loved ones will always be a priority in my daily life.  You never know when one will leave you.

 

 

 

 


#3 KramerTM

KramerTM
  • Topic Starter

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:05:02 AM

Posted 15 January 2013 - 01:32 PM

Have you tried this drive in another computer?

The SM Bus Controller is the chipset drivers. You can download it from Dell.

Scroll down to Chipset, there is only 1 download.


Unfortunately not, as I only have one desktop at home. The only other computer is my work laptop. Is there any way I can test if the drive is working but just something is blocking it?

Thanks for the tip on the SM Bus Controller. Will install and see if it works.

#4 KramerTM

KramerTM
  • Topic Starter

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:05:02 AM

Posted 15 January 2013 - 04:39 PM

Just did the following in the registry but it did not affect the issue:

1. Locate and then click the following registry subkey:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E965-E325-11CE-BFC1-08002BE10318}

(Warning There can be many instances of the registry subkey that is mentioned in step 1. You must make sure that you are in the appropriate registry subkey before you change the UpperFilters and the LowerFilters values. To verify that you are in the appropriate registry subkey, make sure that the Default value is DVD/CD-ROM and the Class value is CDROM.)

2. If you see UpperFilters in the pane on the right side, right-click UpperFilters, and then click Delete.

3. Click Yes to confirm the removal of the UpperFilters registry entry.

4. If you see LowerFilters in the pane on the right side, right-click LowerFilters, and then click Delete.

5. Click Yes to confirm the removal of the LowerFilters registry entry.


Does it mean anything that when I right-click on the DVD/CD drive in Windows Explorer and click Eject, that the drive corresponds and opens?




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users