Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

S3 Aspire and USB hubs dont work


  • Please log in to reply
1 reply to this topic

#1 FraidyMan

FraidyMan

  • Members
  • 8 posts
  • OFFLINE
  •  
  • Local time:01:53 AM

Posted 12 January 2013 - 01:17 PM

Our firm recently acquired 2 Acer Aspire S3 Ultrabooks , 1 Win7 the other Win8. These machines are sleek, fast, light- very nice, but for one oddity. Both machines have 2 USB 3 ports on the back - which work well with peripherals plugged straight in, but when a hub is introduced, no USB peripherals work. I have tried passive 1.0 hobs, powered and unpowered 2.0 and 3.0 hubs - none work, but work fine on other machines. Any thoughts?

BC AdBot (Login to Remove)

 


#2 Nanobyte

Nanobyte

  • Members
  • 431 posts
  • OFFLINE
  •  
  • Local time:11:53 PM

Posted 15 January 2013 - 07:38 AM

My thoughts are mostly that USB stands for Universal Sons of .......... Why this standard is so fraught with problems escapes me. You have tried all the possible solutions. I cannot find anything in the USB spec that would explain this type of behaviour. There is quite a good overview of USB here. The only external factors I could find relevant are incorrect grounding; pull-up resistors of load are not driving voltage of data line high enough to be detected at the PC/voltage losses through cables too high; USB hardware in PC not to spec. If you have tried many hub configurations, one has to point to the PC.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users