Jump to content


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.

Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.


One Part Of Network Unable To Connect To One Server

  • Please log in to reply
2 replies to this topic

#1 alsit


  • Members
  • 2 posts
  • Local time:10:47 AM

Posted 09 January 2013 - 09:41 AM

Hi everyone. We have 5 servers here, linked to 5 buildings across the site. Each building has a network switch which uplinks back to the main network switch in the server room. All of a sudden, all PCs in one of the buildings cannot access our file server, which also runs MS Exchange. These PCs can however access the resources on the other 5 servers. The strange thing is there is only one uplink cable (fibre) between this building and the server room, so the cable uplink IS working because if it wasn't, the PCs wouldn't be able to access the resources on the other 4 servers. I have made no changes that could have made this happen, so I really do not know why this is occurring. The server they can't connect to is a Windows Server 2003 R2 server. We have another 2 servers with the same OS on which are fine, and the other 2 servers run Windows Server 2008. The PCs are running Windows XP. This was all working a week ago, so I do not know why this has suddenly happened. This is what I have tried so far, none of which has changed the situation.

1. Changed the switch in the problem building for another.
2. Tried a different port on the new and old switch for the fibre patch cables.
3. Changed the port the server uses on the main network switch.
4. Re-started all switches by turning the power off and back on.
5. Re-started all the servers.
6. Took a machine from a part of the site that is fine, plugged it into the switch in the problem building. But then this machine has the same problem. Back in it's normal "home" it is fine again.
7. On one of the problem machines I released the IP settings using ipconfig, deleted it's DHCP lease in DHCP and then restarted the machine. Same problem again.

For all the world it appears to be a configuration or software issue on the "problem" server, because the uplink cable back to the main network switch is clearing working. But what the problem is I don't know.

Here is a link to a "crude" network diagram showing the setup - http://www.ldbsa.co.uk/images/net_setup.png

The computers in the building on the left in the picture are able to access 4 of the 5 servers in the server room, but not the fifth. The other 4 buildings on the site are able to connect to everything without any problems at all.

Does anybody have any suggestions?

Edited by alsit, 09 January 2013 - 09:42 AM.

BC AdBot (Login to Remove)


#2 Baltboy


    Bleepin' Flame Head

  • Members
  • 1,432 posts
  • Gender:Male
  • Location:Pennsylvania
  • Local time:11:47 AM

Posted 09 January 2013 - 07:16 PM

First thing that popped in to my head was a permissions issue. If that building is its own security group I would check that first. Second thought would be some kind of corruption in the remote switch. Is a managed switch where you can upload the settings from a saved image ala Cisco? Since you tried a known working computer and it failed in that building I doubt it is the server or I would think it would fail everywhere. To me it has to be related to the building since you seemed to have isolated that the problem originates from there. I am assuming all ofthe machines share the same subnet??
Get your facts first, then you can distort them as you please.
Mark Twain

#3 alsit

  • Topic Starter

  • Members
  • 2 posts
  • Local time:10:47 AM

Posted 10 January 2013 - 03:21 AM

This is now resolved. After uninstalling and replacing the network card it still didn't work. Eventually it got resolved by changing the ports for each end of the fibre cable in the server room and suddenly it started working. I'd done this the other end as well and it didn't help. So I think I may have to ultimately replace the server room switch but for now the trial and error swapping around of ports seems to have fixed the issue.

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users