Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Ubuntu 12.10 Hangs on Shutdown


  • Please log in to reply
1 reply to this topic

#1 R0D3R1CK

R0D3R1CK

  • Members
  • 623 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:08:12 AM

Posted 26 December 2012 - 12:30 AM

Hi everyone!
I recently made a bootable flashdrive of Ubuntu 12.10. Unfortunately, I have a problem shutting down the "computer"

I've done some research and it seems that ACPI (Advanced Configuration and Power Interface) is the cause of the problem. This research led me to a way to boot the machine with ACPI disabled (hit Shift when the computer is first booting...choose your language...f6>ACPI). This seemed to work. I was able to shut the computer down successfully.

However, disabling ACPI also has rather unpleasant effects. I'm using this on a quad-core laptop (Windows 7 on the HDD)...but disabling ACPI only allows one core to be used, making my computer quite slow. Additionally, disabling ACPI causes the brightness/volume keys to become remapped; and I no longer see a battery status indicator on the top right of the screen.

From my research, I also found this:

The first thing you will want to look at when experiencing shutdown problems is ACPI (Advanced Configuration and Power Interface). This, in my experience, is the most common culprit when it comes to Linux shutdown problems. When troubleshooting ACPI, please follow the steps below:

  • Try booting with the "acpi=off" kernel parameter: This will disable ACPI support. If the error is the same with acpi enabled and disabled, you are probably not having an ACPI issue. If that is the case, please see the section of this article titled "Other Possible Solutions".
  • If "acpi=off" allows the system to boot, you will need to isolate the ACPI issue by trying each of the following boot parameters.
  • Try booting with "acpi=ht": This disables all of ACPI except just enough to enable Hyper Threading. If acpi=off works and acpi=ht fails, then the issue is in the ACPI table parsing code itself, or perhaps the SMP code.
  • Try booting with "pci=noacpi": This disables ACPI for IRQ routing and PCI scanning.
  • Try booting with "acpi=noirq": This disables ACPI for IRQ routing.
  • Try booting with "pnpacpi=off": This disables the ACPI component of the Linux Plug and Play code.
  • Try booting with "noapic": This disables the IO-APIC for IRQ routing or PCI scanning.
  • Try booting with "nolapic": This disables the local APIC.

Disabling ACPI at startup seems to work...so I was hoping someone here could guide me through how to try the other parameters.
And once we reach a solution, I would like to make the change permanent. My research also gave instructions for this, but I find them rather confusing.

Thanks in advance!
-r0d3r1ck


UPDATE: After another attempt, it seems that ACPI might not be the culprit.
This is truly bizarre.

Edited by R0D3R1CK, 26 December 2012 - 01:25 AM.


BC AdBot (Login to Remove)

 


#2 R0D3R1CK

R0D3R1CK
  • Topic Starter

  • Members
  • 623 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:08:12 AM

Posted 27 December 2012 - 12:57 PM

Solution (Workaround): Use 12.04LTS instead.
All is well.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users