Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Adapter is failing to connect to wireless network


  • Please log in to reply
10 replies to this topic

#1 Shicke

Shicke

  • Members
  • 15 posts
  • OFFLINE
  •  
  • Local time:04:14 AM

Posted 22 December 2012 - 08:20 AM

Hi all, earlier on today, I've had some problems with pop-ups on my computer (http://www.bleepingcomputer.com/forums/topic479274.html) and after following gringo_pr's advice, the pop-up issue has more or less been settled. However, after restarting my computer, I've been having issues with my network.

First things first, I can connect to my router just fine using a wired connection for this computer and wireless on my iPod Touch works fine as well. However, on another computer in which I'm using a TPLINK TL-WN822N adapter, the connection cannot be established. This only occured after the whole pop-up incident. When I ran 'diagnose' initially, there was a message similar to 'this adapter cannot automatically detect proxy settings', but now, the usual system 'diagnose' just doesn't detect anything. I have tried using the "netsh winsock reset", "netsh int ipv4 reset" and a similar ipv6 on cmd, and even reinstalling the adapter drivers have done no good. I have been at this for an hour now and am still not getting any significant results. The wireless icon at the bottom of the taskbar (Windows 7) shows a yellow warning sign, and the network displays 'Identifying.. No Internet access".

Below is the log from MiniToolBox. Help will be appreciated.



MiniToolBox by Farbar Version: 25-11-2012
Ran by image 17 junjie (administrator) on 22-12-2012 at 21:19:04
Running from "C:\Users\image 17 junjie\Desktop"
Windows 7 Ultimate Service Pack 1 (X64)
Boot Mode: Normal
***************************************************************************

========================= IE Proxy Settings: ==============================

Proxy is not enabled.
No Proxy Server is set.
========================= Hosts content: =================================

127.0.0.1 localhost

========================= IP Configuration: ================================

Atheros AR8151 PCI-E Gigabit Ethernet Controller (NDIS 6.20) = Local Area Connection (Disconnected)
TP-LINK Wireless N Adapter = Wireless Network Connection (Connected)


# ----------------------------------
# IPv4 Configuration
# ----------------------------------
pushd interface ipv4

reset


popd
# End of IPv4 configuration



Windows IP Configuration

Host Name . . . . . . . . . . . . : image17junjie
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Hybrid
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Local Area Connection:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Atheros AR8151 PCI-E Gigabit Ethernet Controller (NDIS 6.20)
Physical Address. . . . . . . . . : 90-2B-34-10-BD-0B
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes

Wireless LAN adapter Wireless Network Connection:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : TP-LINK Wireless N Adapter
Physical Address. . . . . . . . . : 90-F6-52-0F-7C-5F
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
Link-local IPv6 Address . . . . . : fe80::1936:a850:b8e3:afd%11(Preferred)
Autoconfiguration IPv4 Address. . : 169.254.10.253(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.0.0
Default Gateway . . . . . . . . . :
DNS Servers . . . . . . . . . . . : 218.186.2.16
218.186.2.6
202.156.1.6
NetBIOS over Tcpip. . . . . . . . : Enabled

Tunnel adapter isatap.{FED9230C-21D1-47DA-AEFF-EBB541A64B2D}:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Microsoft ISATAP Adapter
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes

Tunnel adapter Teredo Tunneling Pseudo-Interface:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes

Tunnel adapter isatap.{3D647CAB-844D-4EA0-9F63-797B680F869B}:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Microsoft ISATAP Adapter #2
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes
Server: UnKnown
Address: 218.186.2.16

Ping request could not find host google.com. Please check the name and try again.
Server: UnKnown
Address: 218.186.2.16

Ping request could not find host yahoo.com. Please check the name and try again.

Pinging 127.0.0.1 with 32 bytes of data:
Reply from 127.0.0.1: bytes=32 time<1ms TTL=128
Reply from 127.0.0.1: bytes=32 time<1ms TTL=128

Ping statistics for 127.0.0.1:
Packets: Sent = 2, Received = 2, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 0ms, Maximum = 0ms, Average = 0ms
===========================================================================
Interface List
13...90 2b 34 10 bd 0b ......Atheros AR8151 PCI-E Gigabit Ethernet Controller (NDIS 6.20)
11...90 f6 52 0f 7c 5f ......TP-LINK Wireless N Adapter
1...........................Software Loopback Interface 1
14...00 00 00 00 00 00 00 e0 Microsoft ISATAP Adapter
12...00 00 00 00 00 00 00 e0 Teredo Tunneling Pseudo-Interface
15...00 00 00 00 00 00 00 e0 Microsoft ISATAP Adapter #2
===========================================================================

IPv4 Route Table
===========================================================================
Active Routes:
Network Destination Netmask Gateway Interface Metric
127.0.0.0 255.0.0.0 On-link 127.0.0.1 306
127.0.0.1 255.255.255.255 On-link 127.0.0.1 306
127.255.255.255 255.255.255.255 On-link 127.0.0.1 306
169.254.0.0 255.255.0.0 On-link 169.254.10.253 281
169.254.10.253 255.255.255.255 On-link 169.254.10.253 281
169.254.255.255 255.255.255.255 On-link 169.254.10.253 281
224.0.0.0 240.0.0.0 On-link 127.0.0.1 306
224.0.0.0 240.0.0.0 On-link 169.254.10.253 281
255.255.255.255 255.255.255.255 On-link 127.0.0.1 306
255.255.255.255 255.255.255.255 On-link 169.254.10.253 281
===========================================================================
Persistent Routes:
None

IPv6 Route Table
===========================================================================
Active Routes:
If Metric Network Destination Gateway
1 306 ::1/128 On-link
11 281 fe80::/64 On-link
11 281 fe80::1936:a850:b8e3:afd/128
On-link
1 306 ff00::/8 On-link
11 281 ff00::/8 On-link
===========================================================================
Persistent Routes:
None

========================= Event log errors: ===============================

Application errors:
==================
Error: (12/22/2012 08:45:25 PM) (Source: WinMgmt) (User: )
Description: //./root/CIMV2SELECT * FROM __InstanceModificationEvent WITHIN 60 WHERE TargetInstance ISA "Win32_Processor" AND TargetInstance.LoadPercentage > 990x80041003

Error: (12/22/2012 08:44:05 PM) (Source: Winlogon) (User: )
Description: Windows license activation failed. Error 0x80070005.

Error: (12/22/2012 08:43:52 PM) (Source: Schedule) (User: )
Description: Schedule error: 10050Initialize call failed, bailing out

Error: (12/22/2012 08:35:18 PM) (Source: WinMgmt) (User: )
Description: //./root/CIMV2SELECT * FROM __InstanceModificationEvent WITHIN 60 WHERE TargetInstance ISA "Win32_Processor" AND TargetInstance.LoadPercentage > 990x80041003

Error: (12/22/2012 08:33:56 PM) (Source: Winlogon) (User: )
Description: Windows license activation failed. Error 0x80070005.

Error: (12/22/2012 08:33:44 PM) (Source: Schedule) (User: )
Description: Schedule error: 10050Initialize call failed, bailing out

Error: (12/22/2012 08:31:55 PM) (Source: WinMgmt) (User: )
Description: //./root/CIMV2SELECT * FROM __InstanceModificationEvent WITHIN 60 WHERE TargetInstance ISA "Win32_Processor" AND TargetInstance.LoadPercentage > 990x80041003

Error: (12/22/2012 08:30:32 PM) (Source: Winlogon) (User: )
Description: Windows license activation failed. Error 0x80070005.

Error: (12/22/2012 08:30:20 PM) (Source: Schedule) (User: )
Description: Schedule error: 10050Initialize call failed, bailing out

Error: (12/22/2012 08:27:57 PM) (Source: WinMgmt) (User: )
Description: //./root/CIMV2SELECT * FROM __InstanceModificationEvent WITHIN 60 WHERE TargetInstance ISA "Win32_Processor" AND TargetInstance.LoadPercentage > 990x80041003


System errors:
=============
Error: (12/22/2012 09:19:08 PM) (Source: Service Control Manager) (User: )
Description: The HTTP service failed to start due to the following error:
%%22

Error: (12/22/2012 09:19:08 PM) (Source: Service Control Manager) (User: )
Description: The HTTP service failed to start due to the following error:
%%22

Error: (12/22/2012 08:57:16 PM) (Source: Service Control Manager) (User: )
Description: The WinHTTP Web Proxy Auto-Discovery Service service depends on the DHCP Client service which failed to start because of the following error:
%%1075

Error: (12/22/2012 08:57:16 PM) (Source: Service Control Manager) (User: )
Description: The DHCP Client service depends the following service: Afd. This service might not be installed.

Error: (12/22/2012 08:46:00 PM) (Source: Service Control Manager) (User: )
Description: The Windows Update service terminated with the following error:
%%-2147014846

Error: (12/22/2012 08:45:41 PM) (Source: Service Control Manager) (User: )
Description: The WinHTTP Web Proxy Auto-Discovery Service service depends on the DHCP Client service which failed to start because of the following error:
%%1075

Error: (12/22/2012 08:45:41 PM) (Source: Service Control Manager) (User: )
Description: The DHCP Client service depends the following service: Afd. This service might not be installed.

Error: (12/22/2012 08:44:07 PM) (Source: Service Control Manager) (User: )
Description: The IPsec Policy Agent service terminated with the following error:
%%10050

Error: (12/22/2012 08:44:06 PM) (Source: Service Control Manager) (User: )
Description: The IPsec Policy Agent service terminated with the following error:
%%10050

Error: (12/22/2012 08:44:06 PM) (Source: Service Control Manager) (User: )
Description: The IPsec Policy Agent service terminated with the following error:
%%10050


Microsoft Office Sessions:
=========================
Error: (12/22/2012 08:45:25 PM) (Source: WinMgmt)(User: )
Description: //./root/CIMV2SELECT * FROM __InstanceModificationEvent WITHIN 60 WHERE TargetInstance ISA "Win32_Processor" AND TargetInstance.LoadPercentage > 990x80041003

Error: (12/22/2012 08:44:05 PM) (Source: Winlogon)(User: )
Description: 0x800700050x00000000

Error: (12/22/2012 08:43:52 PM) (Source: Schedule)(User: )
Description: Schedule error: 10050Initialize call failed, bailing out

Error: (12/22/2012 08:35:18 PM) (Source: WinMgmt)(User: )
Description: //./root/CIMV2SELECT * FROM __InstanceModificationEvent WITHIN 60 WHERE TargetInstance ISA "Win32_Processor" AND TargetInstance.LoadPercentage > 990x80041003

Error: (12/22/2012 08:33:56 PM) (Source: Winlogon)(User: )
Description: 0x800700050x00000000

Error: (12/22/2012 08:33:44 PM) (Source: Schedule)(User: )
Description: Schedule error: 10050Initialize call failed, bailing out

Error: (12/22/2012 08:31:55 PM) (Source: WinMgmt)(User: )
Description: //./root/CIMV2SELECT * FROM __InstanceModificationEvent WITHIN 60 WHERE TargetInstance ISA "Win32_Processor" AND TargetInstance.LoadPercentage > 990x80041003

Error: (12/22/2012 08:30:32 PM) (Source: Winlogon)(User: )
Description: 0x800700050x00000000

Error: (12/22/2012 08:30:20 PM) (Source: Schedule)(User: )
Description: Schedule error: 10050Initialize call failed, bailing out

Error: (12/22/2012 08:27:57 PM) (Source: WinMgmt)(User: )
Description: //./root/CIMV2SELECT * FROM __InstanceModificationEvent WITHIN 60 WHERE TargetInstance ISA "Win32_Processor" AND TargetInstance.LoadPercentage > 990x80041003


CodeIntegrity Errors:
===================================
Date: 2012-12-22 12:39:11.919
Description: Windows is unable to verify the image integrity of the file \Device\HarddiskVolume2\ComboFix\catchme.sys because file hash could not be found on the system. A recent hardware or software change might have installed a file that is signed incorrectly or damaged, or that might be malicious software from an unknown source.

Date: 2012-12-22 12:39:11.904
Description: Windows is unable to verify the image integrity of the file \Device\HarddiskVolume2\ComboFix\catchme.sys because file hash could not be found on the system. A recent hardware or software change might have installed a file that is signed incorrectly or damaged, or that might be malicious software from an unknown source.


========================= Memory info: ===================================

Percentage of memory in use: 18%
Total physical RAM: 8139.58 MB
Available physical RAM: 6638.74 MB
Total Pagefile: 16277.36 MB
Available Pagefile: 14556.55 MB
Total Virtual: 4095.88 MB
Available Virtual: 3978.59 MB

========================= Partitions: =====================================

1 Drive c: () (Fixed) (Total:1862.92 GB) (Free:1254.67 GB) NTFS
2 Drive d: (CD061A14) (CDROM) (Total:0.2 GB) (Free:0 GB) CDFS
3 Drive e: () (Removable) (Total:0.24 GB) (Free:0.24 GB) FAT

========================= Users: ========================================

User accounts for \\

Administrator Guest image 17 junjie


**** End of log ****

BC AdBot (Login to Remove)

 


#2 InadequateInfirmity

InadequateInfirmity

    I Gots Me A Certified Edumication


  • Banned
  • 5,180 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:03:14 PM

Posted 22 December 2012 - 11:41 AM

Run the services repair tool reboot and check the issue.
http://kb.eset.com/library/ESET/KB%20Team%20Only/Malware/ServicesRepair.exe


If no dice then please post a Fss Log.

Please download FarbarServiceScanner and run it on the computer with the issue.
http://download.bleepingcomputer.com/farbar/FSS.exe


Make sure the following options are checked:
Internet Services
Windows Firewall
System Restore
Security Center/Action Center
Windows Update

Press "Scan".
It will create a log (FSS.txt) in the same directory the tool is run.
Please copy and paste the log to your reply.

#3 Shicke

Shicke
  • Topic Starter

  • Members
  • 15 posts
  • OFFLINE
  •  
  • Local time:04:14 AM

Posted 22 December 2012 - 08:37 PM

I ran the services repair tool reboot but it didn't help. Anyway, here's the FSS log.

Farbar Service Scanner Version: 10-12-2012
Ran by image 17 junjie (administrator) on 23-12-2012 at 09:34:33
Running from "C:\Users\image 17 junjie\Desktop"
Windows 7 Ultimate Service Pack 1 (X64)
Boot Mode: Normal
****************************************************************

Internet Services:
============
Dhcp Service is not running. Checking service configuration:
The start type of Dhcp service is OK.
The ImagePath of Dhcp service is OK.
The ServiceDll of Dhcp service is OK.

afd Service is not running. Checking service configuration:
Checking Start type: ATTENTION!=====> Unable to open afd registry key. The service key does not exist.
Checking ImagePath: ATTENTION!=====> Unable to open afd registry key. The service key does not exist.
Checking LEGACY_afd: ATTENTION!=====> Unable to open LEGACY_afd\0000 registry key. The key does not exist.


Connection Status:
==============
Localhost is accessible.
There is no connection to network.
Attempt to access Google IP returned error.
Attempt to access Google.com returned error: Other errors
Attempt to access Yahoo IP returned error.
Attempt to access Yahoo.com returned error: Other errors


Windows Firewall:
=============

Firewall Disabled Policy:
==================


System Restore:
============

System Restore Disabled Policy:
========================


Action Center:
============

Windows Update:
============
wuauserv Service is not running. Checking service configuration:
The start type of wuauserv service is OK.
The ImagePath of wuauserv service is OK.
The ServiceDll of wuauserv service is OK.

BITS Service is not running. Checking service configuration:
The start type of BITS service is set to Demand. The default start type is Auto.
The ImagePath of BITS service is OK.
The ServiceDll of BITS service is OK.


Windows Autoupdate Disabled Policy:
============================


Other Services:
==============


File Check:
========
C:\Windows\System32\nsisvc.dll => MD5 is legit
C:\Windows\System32\drivers\nsiproxy.sys => MD5 is legit
C:\Windows\System32\dhcpcore.dll => MD5 is legit
C:\Windows\System32\drivers\afd.sys
[2012-05-14 19:25] - [2012-12-22 22:01] - 0022368 ____A (AVG Technologies CZ, s.r.o. ) 42B7E1AA0C7EC54652A50585793F1885

ATTENTION!=====> C:\Windows\System32\drivers\afd.sys IS INFECTED AND SHOULD BE REPLACED.

C:\Windows\System32\drivers\tdx.sys => MD5 is legit
C:\Windows\System32\Drivers\tcpip.sys => MD5 is legit
C:\Windows\System32\dnsrslvr.dll => MD5 is legit
C:\Windows\System32\mpssvc.dll => MD5 is legit
C:\Windows\System32\bfe.dll => MD5 is legit
C:\Windows\System32\drivers\mpsdrv.sys => MD5 is legit
C:\Windows\System32\SDRSVC.dll => MD5 is legit
C:\Windows\System32\vssvc.exe => MD5 is legit
C:\Windows\System32\wscsvc.dll => MD5 is legit
C:\Windows\System32\wbem\WMIsvc.dll => MD5 is legit
C:\Windows\System32\wuaueng.dll => MD5 is legit
C:\Windows\System32\qmgr.dll => MD5 is legit
C:\Windows\System32\es.dll => MD5 is legit
C:\Windows\System32\cryptsvc.dll => MD5 is legit
C:\Windows\System32\svchost.exe => MD5 is legit
C:\Windows\System32\rpcss.dll => MD5 is legit


**** End of log ****

#4 InadequateInfirmity

InadequateInfirmity

    I Gots Me A Certified Edumication


  • Banned
  • 5,180 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:03:14 PM

Posted 23 December 2012 - 10:35 PM

Re-run Fss and type afd.sys hit the search files button post the log.


Go to the site below and download the windows 7 file.

http://www.smartestcomputing.us.com/files/file/9-registry-network-keys/

Save it to your desktop we will use these later.

#5 Shicke

Shicke
  • Topic Starter

  • Members
  • 15 posts
  • OFFLINE
  •  
  • Local time:04:14 AM

Posted 24 December 2012 - 01:42 AM

I've downloaded the Windows 7 file. Below is the log.

Farbar Service Scanner Version: 10-12-2012
Ran by image 17 junjie (administrator) on 24-12-2012 at 14:38:53
Windows 7 Ultimate Service Pack 1 (X64)

************************************************
======== Search: "afd.sys" =========

C:\Windows\System32\drivers\AFD.SYS
[2012-05-14 19:25] - [2012-12-22 22:01] - 0022368 ____A (AVG Technologies CZ, s.r.o. ) 42B7E1AA0C7EC54652A50585793F1885

C:\Windows\winsxs\amd64_microsoft-windows-winsock-core_31bf3856ad364e35_6.1.7601.21887_none_364f3a028e605345\afd.sys
[2012-05-14 19:25] - [2011-12-28 12:01] - 0498176 ____A (Microsoft Corporation) 36A14FD1A23F57046361733B792CA8DB

C:\Windows\winsxs\amd64_microsoft-windows-winsock-core_31bf3856ad364e35_6.1.7601.17752_none_35e10b89752ee0f5\afd.sys
[2012-05-14 19:25] - [2011-12-28 11:59] - 0498688 ____A (Microsoft Corporation) 1C7857B62DE5994A75B054A9FD4C3825

C:\Windows\winsxs\amd64_microsoft-windows-winsock-core_31bf3856ad364e35_6.1.7601.17514_none_360e4801750ca991\afd.sys
[2010-11-21 11:24] - [2010-11-21 11:24] - 0499712 ____A (Microsoft Corporation) D31DC7A16DEA4A9BAF179F3D6FBDB38C

====== End Of Search ======

#6 InadequateInfirmity

InadequateInfirmity

    I Gots Me A Certified Edumication


  • Banned
  • 5,180 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:03:14 PM

Posted 24 December 2012 - 12:47 PM

Hit the start button then copy and paste the file path below into start search box.


C:\Windows\winsxs\amd64_microsoft-windows-winsock-core_31bf3856ad364e35_6.1.7601.21887_none_364f3a028e605345\afd.sys

Drag the afd.sys file to your desktop.

Now hit the start button and paste.

C:\Windows\System32\drivers

Find the afd.sys file located here and name it afd.old now drag the afd.sys file from your desktop into the C:\Windows\System32\drivers folder and close it.


Now from the windows 7 file I had you download earlier please right click and select merge on the afd.reg file and the legacy afd.reg file.
Reboot and then re-run the services repair tool.

Reboot the machine and post a new Fss log so that I can see what progress has been made.

#7 Shicke

Shicke
  • Topic Starter

  • Members
  • 15 posts
  • OFFLINE
  •  
  • Local time:04:14 AM

Posted 24 December 2012 - 07:51 PM

Hi there, I am stuck at this step; "Now from the windows 7 file I had you download earlier please right click and select merge on the afd.reg file and the legacy afd.reg file."

Even after granting permission to my user account (Properties --> Changed owner to administrator --> Granted Full Control) on regedit.exe and running it as an administrator, I still get an error stating "Cannot run legacy afd.reg; Error in accessing registry". From the advice you gave me, I only had to change permissions on afd.sys when I dragged it to the desktop.

The afd.reg and legacy afd.reg files are both on my desktop, and I have had no problems merging the afd.reg file. It's only the legacy afd.reg file that's not cooperating.

I guess I'll be stuck on this step until someone sees this post. Anyway, I'll be overseas in slightly more than half a day's time, so please do not close this thread for a lack of response.

By the way, MERRY X'MAS! Enjoy your holidays :)

#8 Shicke

Shicke
  • Topic Starter

  • Members
  • 15 posts
  • OFFLINE
  •  
  • Local time:04:14 AM

Posted 25 December 2012 - 02:13 AM

In between my last post and this, I uninstalled my wireless adapter via Device Manager, and reinstalled utilities and drivers via the accompanying CD. Progress made as of now: afd.reg file successfully ran once, legacy afd.reg file failed to run on multiple instances, owing to 'Error in accessing registry'. Ran the services repair tool reboot again, as well as FSS twice (once for Internet Services, Windows Firewall, System Restore, Security Center/Action Center, Windows Update and another for afd.sys). Here are the logs.


FSS Log 1

Farbar Service Scanner Version: 10-12-2012
Ran by image 17 junjie (administrator) on 25-12-2012 at 15:00:00
Running from "C:\Users\image 17 junjie\Desktop\Computer Security"
Windows 7 Ultimate Service Pack 1 (X64)
Boot Mode: Normal
****************************************************************

Internet Services:
============
Dhcp Service is not running. Checking service configuration:
The start type of Dhcp service is OK.
The ImagePath of Dhcp service is OK.
The ServiceDll of Dhcp service is OK.

afd Service is not running. Checking service configuration:
The start type of afd service is OK.
The ImagePath of afd service is OK.
Checking LEGACY_afd: ATTENTION!=====> Unable to open LEGACY_afd\0000 registry key. The key does not exist.


Connection Status:
==============
Localhost is accessible.
There is no connection to network.
Attempt to access Google IP returned error.
Attempt to access Google.com returned error: Other errors
Attempt to access Yahoo IP returned error.
Attempt to access Yahoo.com returned error: Other errors


Windows Firewall:
=============

Firewall Disabled Policy:
==================


System Restore:
============

System Restore Disabled Policy:
========================


Action Center:
============

Windows Update:
============
wuauserv Service is not running. Checking service configuration:
The start type of wuauserv service is OK.
The ImagePath of wuauserv service is OK.
The ServiceDll of wuauserv service is OK.

BITS Service is not running. Checking service configuration:
The start type of BITS service is set to Demand. The default start type is Auto.
The ImagePath of BITS service is OK.
The ServiceDll of BITS service is OK.


Windows Autoupdate Disabled Policy:
============================


Other Services:
==============


File Check:
========
C:\Windows\System32\nsisvc.dll => MD5 is legit
C:\Windows\System32\drivers\nsiproxy.sys => MD5 is legit
C:\Windows\System32\dhcpcore.dll => MD5 is legit
C:\Windows\System32\drivers\afd.sys
[2012-05-14 19:25] - [2011-12-28 12:01] - 0498176 ____A (Microsoft Corporation) 36A14FD1A23F57046361733B792CA8DB

C:\Windows\System32\drivers\tdx.sys => MD5 is legit
C:\Windows\System32\Drivers\tcpip.sys => MD5 is legit
C:\Windows\System32\dnsrslvr.dll => MD5 is legit
C:\Windows\System32\mpssvc.dll => MD5 is legit
C:\Windows\System32\bfe.dll => MD5 is legit
C:\Windows\System32\drivers\mpsdrv.sys => MD5 is legit
C:\Windows\System32\SDRSVC.dll => MD5 is legit
C:\Windows\System32\vssvc.exe => MD5 is legit
C:\Windows\System32\wscsvc.dll => MD5 is legit
C:\Windows\System32\wbem\WMIsvc.dll => MD5 is legit
C:\Windows\System32\wuaueng.dll => MD5 is legit
C:\Windows\System32\qmgr.dll => MD5 is legit
C:\Windows\System32\es.dll => MD5 is legit
C:\Windows\System32\cryptsvc.dll => MD5 is legit
C:\Windows\System32\svchost.exe => MD5 is legit
C:\Windows\System32\rpcss.dll => MD5 is legit


**** End of log ****



FSS Log 2(afd.sys)


Farbar Service Scanner Version: 10-12-2012
Ran by image 17 junjie (administrator) on 25-12-2012 at 15:10:46
Windows 7 Ultimate Service Pack 1 (X64)

************************************************
======== Search: "afd.sys" =========

C:\Windows\System32\drivers\afd.sys
[2012-05-14 19:25] - [2011-12-28 12:01] - 0498176 ____A (Microsoft Corporation) 36A14FD1A23F57046361733B792CA8DB

C:\Windows\winsxs\amd64_microsoft-windows-winsock-core_31bf3856ad364e35_6.1.7601.17752_none_35e10b89752ee0f5\afd.sys
[2012-05-14 19:25] - [2011-12-28 11:59] - 0498688 ____A (Microsoft Corporation) 1C7857B62DE5994A75B054A9FD4C3825

C:\Windows\winsxs\amd64_microsoft-windows-winsock-core_31bf3856ad364e35_6.1.7601.17514_none_360e4801750ca991\afd.sys
[2010-11-21 11:24] - [2010-11-21 11:24] - 0499712 ____A (Microsoft Corporation) D31DC7A16DEA4A9BAF179F3D6FBDB38C

====== End Of Search ======

#9 Shicke

Shicke
  • Topic Starter

  • Members
  • 15 posts
  • OFFLINE
  •  
  • Local time:04:14 AM

Posted 25 December 2012 - 02:48 AM

Hi there, I have successfully managed to merge legacy afd.reg using instructions from these 2 pages.

http://www.raymond.cc/blog/full-control-permission-to-delete-or-edit-restricted-windows-registry/
http://www.bleepingcomputer.com/forums/topic430676.html/page__view__findpost__p__2499523.

I am currently rebooting my computer. Will be updating this with a new FSS log.



FSS Log

Farbar Service Scanner Version: 10-12-2012
Ran by image 17 junjie (administrator) on 25-12-2012 at 15:58:12
Running from "C:\Users\image 17 junjie\Desktop\Computer Security"
Windows 7 Ultimate Service Pack 1 (X64)
Boot Mode: Normal
****************************************************************

Internet Services:
============

Connection Status:
==============
Localhost is accessible.
LAN connected.
Google IP is accessible.
Google.com is accessible.
Yahoo IP is accessible.
Yahoo.com is accessible.


Windows Firewall:
=============

Firewall Disabled Policy:
==================


System Restore:
============

System Restore Disabled Policy:
========================


Action Center:
============

Windows Update:
============

Windows Autoupdate Disabled Policy:
============================


Other Services:
==============


File Check:
========
C:\Windows\System32\nsisvc.dll => MD5 is legit
C:\Windows\System32\drivers\nsiproxy.sys => MD5 is legit
C:\Windows\System32\dhcpcore.dll => MD5 is legit
C:\Windows\System32\drivers\afd.sys
[2012-05-14 19:25] - [2011-12-28 12:01] - 0498176 ____A (Microsoft Corporation) 36A14FD1A23F57046361733B792CA8DB

C:\Windows\System32\drivers\tdx.sys => MD5 is legit
C:\Windows\System32\Drivers\tcpip.sys => MD5 is legit
C:\Windows\System32\dnsrslvr.dll => MD5 is legit
C:\Windows\System32\mpssvc.dll => MD5 is legit
C:\Windows\System32\bfe.dll => MD5 is legit
C:\Windows\System32\drivers\mpsdrv.sys => MD5 is legit
C:\Windows\System32\SDRSVC.dll => MD5 is legit
C:\Windows\System32\vssvc.exe => MD5 is legit
C:\Windows\System32\wscsvc.dll => MD5 is legit
C:\Windows\System32\wbem\WMIsvc.dll => MD5 is legit
C:\Windows\System32\wuaueng.dll => MD5 is legit
C:\Windows\System32\qmgr.dll => MD5 is legit
C:\Windows\System32\es.dll => MD5 is legit
C:\Windows\System32\cryptsvc.dll => MD5 is legit
C:\Windows\System32\svchost.exe => MD5 is legit
C:\Windows\System32\rpcss.dll => MD5 is legit


**** End of log ****

Edited by Shicke, 25 December 2012 - 03:00 AM.


#10 Shicke

Shicke
  • Topic Starter

  • Members
  • 15 posts
  • OFFLINE
  •  
  • Local time:04:14 AM

Posted 25 December 2012 - 03:00 AM

Posting on my computer now! The wireless connection is back up! InadequateInfirmity, thank you for having been patient with me and helping me along! Merry X'mas!

Edited by Shicke, 25 December 2012 - 03:00 AM.


#11 InadequateInfirmity

InadequateInfirmity

    I Gots Me A Certified Edumication


  • Banned
  • 5,180 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:03:14 PM

Posted 25 December 2012 - 03:38 AM

glad u got it sorted. :thumbsup:




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users