Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

USB port doesn't recognize camera


  • Please log in to reply
2 replies to this topic

#1 Yepytzme

Yepytzme

  • Members
  • 90 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:11:24 AM

Posted 20 December 2012 - 03:56 PM

Hi folk,
I just purchased a new camera, came with USB compatible cable but when I went to upload the pictures from the camera to the PC, nothing happened. A mini window popped up saying "P510" then "Camera connected" but there's nothing on the screen to show the pictures or anything else (screenshot attached). I have 8 USB ports, I was told not to use the 'hubs' but to use the USB at the back of the CPU. Doesn't work either. All the USB ports read my flash drive, a USB cable to charge and connect my Garmin GPS and my card reader. Why will it not recognize my camera. If it says "P510" and "Camera Connected" then why does it not recognize anything else to do with the camera? I ran a Dell Diagnostics and it said everything is working and no problems were detected. I took my camera and cable back to Henry's and they also could not get it to work. They tried their own camera and cable...no luck. Then they downloaded Nikon's "ViewNX 2" program for movie editing and to download/upload etc., etc., and it did recognize the camera and did show the pictures for uploading. I tried the same thing at home......DID NOT WORK! I am really really frustrated with this! Anyone have any idea what it is about my USB port that will not allow Nikon to be recognized?
Help!!!
Thanks,
Just call me Yep.

Edit: Moved topic from XP to the more appropriate forum. ~ Animal

BC AdBot (Login to Remove)

 


#2 hamluis

hamluis

    Moderator


  • Moderator
  • 56,111 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:10:24 AM

Posted 21 December 2012 - 06:37 PM

Did you install the software which commonly comes on CD with cameras?

Louis

#3 Yepytzme

Yepytzme
  • Topic Starter

  • Members
  • 90 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:11:24 AM

Posted 21 December 2012 - 07:23 PM

Hi Hamluis, as I stated in my original post (quote):" Then they downloaded Nikon's "ViewNX 2" program for movie editing and to download/upload etc., etc., and it did recognize the camera and did show the pictures for uploading. I tried the same thing at home......DID NOT WORK!
The only other software that came with the camera was the PDF instruction manual. I have to add, apparently there is something wrong with my USB port or some program running it. I checked the Device Manager and ALL 8 USB ports are "working properly". The thing that baffles me is that I had, and still have, a Canon camera and had the same problem uploading pictures from it as well. I gave that camera and USB cable to my friend and he tried it on his and said it worked properly. I just don't get it!




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users