Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

USB3 ports cannot recognize USB2 Kindle


  • Please log in to reply
1 reply to this topic

#1 MWM-4444

MWM-4444

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:05:52 PM

Posted 13 December 2012 - 01:52 PM

I bought a Kindle a few months ago. (The "medium" kind, with a keyboard -- NOT the Fire.) It works perfectly with my 2003 XP (USB-1 ports) and with my 2008 Windows 7 (USB-2 ports).

With my one-week-old 2012 Windows 7 beta (USB-3 ports), the Kindle is invisible. I have three USB ports, all of which work perfectly with other devices, and all of which tell me the Kindle is invisible.

The new computer makes the "clank" that signals that it recognizes something is connected to the USB port. After that, nothing.

No Autoplay window. No "removeable disk F:\" when I look at New Computer's root directories.

I right-clicked on Computer, then Manage - Disk Management - Storage. The new computer said there was no data storage device connected to any USB port.

I did Device Manager - Scan for new hardware, nothing.

I tried restarting both New Computer and Kindle. Nothing. I turned off the Kindle altogether, plugged it into the USB port, then restarted the computer. I turned the Kindle on. The computer made the "clank" indicating its recognition that the Kindle had been turned on and was connected to the port. I repeated all the above attempts to locate the Kindle. Nothing.

I restarted the Kindle while it was plugged into the computer. Nothing. Except, after about an hour of being plugged into the USB port unrecognized, the Kindle notified me that its battery was almost drained & I'd better plug it into a power source right away. (This notification appears to have been untrue. The Kindle's battery was full when I plugged it into New Computer, and it was full again five minutes after I unplugged the Kindle from New Computer and plugged it into the wall.)

I did a search on "how to update your new computer's USB 3 drivers to recognize your old USB 2 device," but the search terms came up with crappy results.

I contacted my expert brother, who told me HE had the identical problem with an external electric signature pad. He "solved" HIS problem by plugging the pad into HIS computer's one USB 2 port.

While I can work around my problem by using an older computer, I don't want to. If I can't make New Computer recognize Old Device, is there a "USB2 emulator" driver I can download for New Computer, or a USB2 emulator gizmo I can obtain somewhere? I wouldn't mind plugging a gizmo into my USB3 port and then plugging my Kindle into the gizmo, if it meant that New Computer could recognize the existence of the darn thing.

BC AdBot (Login to Remove)

 


#2 MWM-4444

MWM-4444
  • Topic Starter

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:05:52 PM

Posted 15 December 2012 - 03:26 PM

Never mind, everyone, I solved my own problem. My Kindle now works just fine with my new USB3 ports.

Here's what I did: I connected my Kindle to one of my USB3 ports. As usual, nothing happened except that "clank" where the computer acknowledged the existence of the Kindle.

I went into Device Manager. Suddenly a new subdirectory appeared: Portable Devices. Clicked on that & saw "Kindle." Clicked on Kindle, and then right-clicked on Kindle and chose "Update driver software."

A minute or so later, the computer told me, "Could not complete update because could not turn Kindle on." Well, duh, it was already on! BUT, my Kindle had magically appeared in Computer and I could do everything except recharge from the new computer.

I turned my Kindle off. Then I repeated the whole "Update device driver" routine. THIS time, the computer turned the Kindle on AND restarted it. And problem solved. My Kindle has returned to working perfectly with my new computer.

Incidentally, if anyone is interested, I have more than 200 screensaver images in my Kindle, each of which identifies the Kindle as mine (in case I lose it somewhere). Here's how I did it: http://witwisdom.wordpress.com/2012/08/06/customize-your-kindle-screensaver/.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users