Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

can only use computer in safe mode and cant install anything


  • Please log in to reply
2 replies to this topic

#1 kgerred83

kgerred83

  • Members
  • 6 posts
  • OFFLINE
  •  
  • Local time:06:32 AM

Posted 09 December 2012 - 11:35 PM

my computer will freeze as soon as it turns on, so i have to put it in safe mode. it works in safe mode except when i try and run either microsoft security essentials or malwarebytes it freezes. if i try and install something like a reg cleaner or another virus scanner it tells me i cant do that in safe mode.. also as soon as i turn on comp. (in safe mode) a box comes up that says my help and support is missing... anyone got any advice on what is wrong and how to fix it myself without having to pay an arm and a leg..lol..thanks in advance.

i tried to download hijackthis but once again says installer does not work in safe mode

Edited by kgerred83, 09 December 2012 - 11:53 PM.


BC AdBot (Login to Remove)

 


#2 aswinvijayakumar

aswinvijayakumar

  • Members
  • 7 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:India
  • Local time:05:02 PM

Posted 10 December 2012 - 01:51 AM

Hi,

It is correct that you will not be able to install any apps in safe mode. It is because the safe mode is the mode where only the minimal features are loaded up or activated. For any apps to install you need to activate the installer service. To do that I will give you the steps in the end.

Method 1 to increase the performance:
Step 1. In run window type "msconfig" and hit enter without quotes.
2. go to services tab
3. check the "hide all microsoft services"(Compulsory step to be done or else it is going to be more problem)
4. uncheck all the services which you think is not necessary. Keep in mind that the antivirus services should be running.

Method 2 to enable installer service
1. In run window type "cmd" and hit enter without quotes.
2.
Safe Mode.
Type this in a command prompt:
REG ADD "HKLM\SYSTEM\CurrentControlSet\Control\SafeBoot\Minimal\MSIServer" /VE /T REG_SZ /F /D "Service"

and then

net start msiserver

This will start the Windows Installer Service.
3. try installing the apps now.

Thanks and Regards
Aswin

NB: This is my first post, I apologize if you find any mistake in my explanation.

Please let me know if you found this post useful.

Edited by aswinvijayakumar, 10 December 2012 - 01:52 AM.


#3 dc3

dc3

    Bleeping Treehugger


  • Members
  • 30,489 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Sierra Foothills of Northern Ca.
  • Local time:04:32 AM

Posted 10 December 2012 - 09:24 AM

Try doing a System Restore in Safe Mode, choose a date prior to the start of this problem.

When the Advanced Boot Options page opens choose Safe mode with a Command propmpt.

Go to Start> Run and type in cmd and press Enter.

A similar to the picture below will open, there will be a blinking white cursor, type in %systemroot%\system32\restore\rstrui.exe and press Enter.

Follow the instructions which will appear on your screen

Posted Image

If this works you should have a functional normal mode, but you may still have other problems which we can pursue once you can boot normally.

Edited by dc3, 10 December 2012 - 09:28 AM.

Family and loved ones will always be a priority in my daily life.  You never know when one will leave you.

 

 

 

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users