Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

BSOD NTOSKRNL.EXE USBPORT.SYS


  • Please log in to reply
3 replies to this topic

#1 Meat5000

Meat5000

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:07:19 AM

Posted 03 December 2012 - 12:05 PM

Hello there, the problem I am experiencing is truly frustrating as it throws a giant glue covered spanner in my works.

To outline; BlueScreenView says the BSOD IRQL_NOT_LESS_OR_EQUAL is due to USBPORT.SYS crashing my ntoskrnl.exe. I recall it didn't crash in safe mode. I don't think its an infection.

I am developing a USB device using MICROCHIP PIC 18f2550 to communicate to the PC via USB. The above BSOD occurs when I plug my device in. Custom drivers written by MICROCHIP were successfully installed and the device is a very basic barebones circuit. Essentially this part of the project is handed to us on a plate by Microchip and the meat needs to be added to the bones by the user to develope it further. Essentially what I am getting at here is that this nonsense I have in front of me should work off the bat.

After some googling there is a suggestion that the new AVG 2013 is causing similar BSOD but their problems are not related to PIC development. I can not say that it is to blame here as I, rather foolishly, installed AVG2013 (updated 2012) right in the middle of jiggling my circuit.

I had installed a custom driver and the device would begin enumeration but not be functional, appearing in device manager as "USB Device", "Unknown Device" or "Microchip Custom USB Device" all of which still caused BSOD. I have tried different drivers and have even cleaned up over 25 old USB drivers dormant on the system. Still, the drivers install ok and the PC BSODs.

There are numerous problems on my PC due to hardware migration. Moving from AMDx2-ASUS to Intelx1-HP in the same XP Pro x86 installation. It worked out ok after I swapped all the drivers but still shows stuttering when anything goes through the network.

Also, I get some entries in the Eventlog:

The server could not bind to the transport \Device\NetBT_Tcpip_{8F5A3D67-C17B-409E-9560-A645A63B9063}.

The ScRegSetValueExW call failed for FailureActions with the following error: Access is denied. (x2)

The Windows Driver Foundation - User-mode Driver Framework service terminated with the following error:
A device attached to the system is not functioning.

I'm on XPProSp3. Intel pentium4 Northwood, 1.5GB of random RAM all lovingly jammed onto a HP board made from string, sticky tape, pencil lead and wishes; wedged and wangled half heartedly into the ol' coolermaster tower on a shard of hacked up metal. Yes I had to MAKE it fit. My old x2 died after 6 years of glory; making do with what I could find. The XP install came from 4400x2 on A8N32sli, with a 7800GTX512 sitting in the case and swallowing whole passing-by people.

Anyway, I've attached some minidumps, RENAMED AS .TXT (ofc should be .dmp). Sorry for the essay; I can provide more info if you need it.

Hope you can help me pinpoint this problem!
Kind Regards!
Meat5000

BC AdBot (Login to Remove)

 


#2 Meat5000

Meat5000
  • Topic Starter

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:07:19 AM

Posted 03 December 2012 - 12:08 PM

Hmmm ok, I had clicked preview, then back and it said I'd used 460k of my uploads, but they never posted. Little forum bug there. I can't post my minidumps -_- Bleepin' Computers!!!!!!!!

#3 Meat5000

Meat5000
  • Topic Starter

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:07:19 AM

Posted 04 December 2012 - 06:48 PM

ok Here is the debug info. Hope it helps.

BugCheck 1000000A, {e1edb5b0, 2, 1, 8067337a}

IRQL_NOT_LESS_OR_EQUAL (a)
An attempt was made to access a pageable (or completely invalid) address at an
interrupt request level (IRQL) that is too high. This is usually
caused by drivers using improper addresses.
If a kernel debugger is available get the stack backtrace.
Arguments:
Arg1: e1edb5b0, memory referenced
Arg2: 00000002, IRQL
Arg3: 00000001, bitfield :
bit 0 : value 0 = read operation, 1 = write operation
bit 3 : value 0 = not an execute operation, 1 = execute operation (only on chips which support this level of status)
Arg4: 8067337a, address which referenced memory

Debugging Details:
------------------
WRITE_ADDRESS: e1edb5b0
CURRENT_IRQL: 2
FAULTING_IP:
nt!ViFlushDoubleBuffer+182
8067337a f3a5 rep movs dword ptr es:[edi],dword ptr [esi]
CUSTOMER_CRASH_COUNT: 5
DEFAULT_BUCKET_ID: COMMON_SYSTEM_FAULT
BUGCHECK_STR: 0xA
PROCESS_NAME: svchost.exe
LAST_CONTROL_TRANSFER: from 80673951 to 8067337a
STACK_TEXT:
f78a2e30 80673951 8948bd90 00000000 e1edb5b0 nt!ViFlushDoubleBuffer+0x182
f78a2e64 b7891f8d 89ea7610 891e9d20 00000000 nt!VfFlushAdapterBuffers+0x147
f78a2ee4 b7892d47 f78d68dc 00000000 8a0467d8 USBPORT!USBPORT_CompleteTransfer+0x22b
f78a2f14 b7893944 026e6f44 8a0460e0 8a0460e0 USBPORT!USBPORT_DoneTransfer+0x137
f78a2f4c b789513a 8a046028 804e2ec4 8a046230 USBPORT!USBPORT_FlushDoneTransferList+0x16c
f78a2f78 b78a324b 8a046028 804e2ec4 8a046028 USBPORT!USBPORT_DpcWorker+0x224
f78a2fb4 b78a33c2 8a046028 00000001 8a04a590 USBPORT!USBPORT_IsrDpcWorker+0x38f
f78a2fd0 804dbbd4 8a04664c 6b755044 00000000 USBPORT!USBPORT_IsrDpc+0x166
f78a2ff4 804db89e aea5095c 00000000 00000000 nt!KiRetireDpcList+0x46
f78a2ff8 aea5095c 00000000 00000000 00000000 nt!KiDispatchInterrupt+0x2a
WARNING: Frame IP not in any known module. Following frames may be wrong.
804db89e 00000000 00000009 bb835675 00000128 0xaea5095c

STACK_COMMAND: kb
FOLLOWUP_IP:
USBPORT!USBPORT_CompleteTransfer+22b
b7891f8d 56 push esi
SYMBOL_STACK_INDEX: 2
SYMBOL_NAME: USBPORT!USBPORT_CompleteTransfer+22b
FOLLOWUP_NAME: MachineOwner
MODULE_NAME: USBPORT
IMAGE_NAME: USBPORT.SYS
DEBUG_FLR_IMAGE_TIMESTAMP: 480254ce
FAILURE_BUCKET_ID: 0xA_USBPORT!USBPORT_CompleteTransfer+22b
BUCKET_ID: 0xA_USBPORT!USBPORT_CompleteTransfer+22b
Followup: MachineOwner

#4 Meat5000

Meat5000
  • Topic Starter

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:07:19 AM

Posted 05 December 2012 - 06:05 AM

Well, I disabled DRIVER VERIFIER and that stopped the BSOD. Now PC sees my circuit properly and is fully functional. I have circumvented the problem, not fixed it, but this is good enough for now.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users