Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Network Win7 and XP


  • Please log in to reply
33 replies to this topic

#1 Menessis

Menessis

  • Members
  • 127 posts
  • OFFLINE
  •  
  • Local time:07:53 PM

Posted 01 December 2012 - 08:43 PM

Well I have this set up though my router. Turned off both firewalls as a test but still can't get the XP to access the Win7 machine.

Both machines have a workgroup named "MYNETWORKTEST"
The Win7 shows network 4 in the taskbar.
XP shows MYNETWORKTEST in the task bar.

I can see all the shared folders on the XP machine.
I can ping the Win7 but cant see the shared folder.

ipconfig shows:

IPv4 Address.............192.168.0.150
Subnet Mask..............255.255.255.0
Default Gateway..........192.168.0.1

DNS Server...............192.168.0.1

Any ideas?

Thanks

Menessis

BC AdBot (Login to Remove)

 


#2 Sneakycyber

Sneakycyber

    Network Engineer


  • BC Advisor
  • 6,130 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Ohio
  • Local time:08:53 PM

Posted 01 December 2012 - 08:51 PM

On the windows 7 computer Right click on the folder or the library you want to share with the xp machine select the security tab, then edit. Add the user name Anonymous. If that doesn't work you can change it in local policy (not a good Idea since ANYONE with a network connection to your computer can see those files

Edited by Sneakycyber, 01 December 2012 - 08:52 PM.

Chad Mockensturm 
Network Engineer
Certified CompTia Network +, A +

#3 Menessis

Menessis
  • Topic Starter

  • Members
  • 127 posts
  • OFFLINE
  •  
  • Local time:07:53 PM

Posted 01 December 2012 - 09:16 PM

Hi SneakyCyber. I tried to do what you said. When I add in Anonymous it puts it in as "Anonymous Logon". I tried it anyways. When I go into My Network Places all I see is my router.


Menessis

#4 Sneakycyber

Sneakycyber

    Network Engineer


  • BC Advisor
  • 6,130 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Ohio
  • Local time:08:53 PM

Posted 01 December 2012 - 09:34 PM

You may not be able to "See" the computer in Windows Explorer but are you able to access the folder? Go to the address bar in Explorer and type \\Computername\Folder Where computer name is the name of the windows 7 XP Machine pc and the folder name is the one you should have access to. If you can access the folder add LLTD (link layer topology) to XP. If you have XP SP3 use the Microsoft HotFix

Edit: Adding LLTD to XP SP3 allows the XP computer to be readily detected by Windows 7

Edited by Sneakycyber, 01 December 2012 - 09:35 PM.

Chad Mockensturm 
Network Engineer
Certified CompTia Network +, A +

#5 Menessis

Menessis
  • Topic Starter

  • Members
  • 127 posts
  • OFFLINE
  •  
  • Local time:07:53 PM

Posted 01 December 2012 - 10:03 PM

I can get into the XP machine from Win7, but not the other way around. I did put the LLTD in the XP weeks ago.

Any more ideas?

Thanks

Menessis

#6 Sneakycyber

Sneakycyber

    Network Engineer


  • BC Advisor
  • 6,130 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Ohio
  • Local time:08:53 PM

Posted 01 December 2012 - 10:14 PM

Sorry I will update, to many things at once lol
Chad Mockensturm 
Network Engineer
Certified CompTia Network +, A +

#7 Sneakycyber

Sneakycyber

    Network Engineer


  • BC Advisor
  • 6,130 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Ohio
  • Local time:08:53 PM

Posted 01 December 2012 - 10:22 PM

What versions of XP and Windows 7 do you have? Home Premium, Pro, Ultimate?

Did you turn OFF Password protected Sharing on The windows 7 Computer?

Edited by Sneakycyber, 01 December 2012 - 10:25 PM.

Chad Mockensturm 
Network Engineer
Certified CompTia Network +, A +

#8 Menessis

Menessis
  • Topic Starter

  • Members
  • 127 posts
  • OFFLINE
  •  
  • Local time:07:53 PM

Posted 02 December 2012 - 01:46 AM

Well It's Win7 64 Home Premium and the XP is Home. And I did turn off the password protection.

When I started all this I had the router as 192.168.0.1
The Win7 machine as 192.168.0.2 static
The XP as 192.168.0.3 static

The XP is set up with a password but the Win7 doesn't use a password.

Thanks again.

Menessis

#9 Sneakycyber

Sneakycyber

    Network Engineer


  • BC Advisor
  • 6,130 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Ohio
  • Local time:08:53 PM

Posted 02 December 2012 - 04:14 PM

Ok, I will update later this after noon. I have a Network call I have to go on. :busy:
Chad Mockensturm 
Network Engineer
Certified CompTia Network +, A +

#10 Sneakycyber

Sneakycyber

    Network Engineer


  • BC Advisor
  • 6,130 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Ohio
  • Local time:08:53 PM

Posted 02 December 2012 - 05:24 PM

Earlier when I asked if you could access the folders did you try and access the folders on the windows 7 computer from the XP machine. I understand you cant see them.
On the Windows 7 computer Make sure the following is set
  • Network Discovery is turned ON
  • File and Folder sharing ON
  • Public Folder Sharing Is optional
  • Set File Encryption to 40 or 56 BIT
  • Password Protection is Turned off (this enables simple file sharing)
  • Home Group Connections- Allow Windows to Manage Home group

When sharing folders on Windows 7 Right click on the folder and Select Sharing, click on Specific People and Add make sure EVERYONE and Guest are listed. Next check the security tab and make sure the users listed on the sharing tab are also listed here and have the same permissions.

Edited by Sneakycyber, 02 December 2012 - 05:25 PM.

Chad Mockensturm 
Network Engineer
Certified CompTia Network +, A +

#11 Menessis

Menessis
  • Topic Starter

  • Members
  • 127 posts
  • OFFLINE
  •  
  • Local time:07:53 PM

Posted 02 December 2012 - 09:42 PM

Well I went through your list.

1) Network Discovery is turned ON ...if my firewall is on this is unchecked. I can check it but it doesn't stay checked

2) File and Folder sharing ON ...........Same as above
3) Public Folder Sharing Is optional
4) Set File Encryption to 40 or 56 BIT
5) Password Protection is Turned off (this enables simple file sharing)
6) Home Group Connections- Allow Windows to Manage Home group


EVERYONE and Guest are listed and have all permissions.

Turned off firewall. I still don't see the win7 folders from xp. I don't know how to go about finding the folder any other way.

Thanks again Sneaky

Menessis

#12 Sneakycyber

Sneakycyber

    Network Engineer


  • BC Advisor
  • 6,130 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Ohio
  • Local time:08:53 PM

Posted 02 December 2012 - 10:09 PM

On the Xp machine are you looking for the Windows 7 computer in Network Places? You may have to navigate down a few layers untill you see your work group. If your still unable to see the Windows 7 machine and your POSITVE your in the same "workgroup" (remember Windows xp by default is MSHOME, Windows 7 is WORKGROUP) as listed in System properties, Computer name and Domain Settings. Check for programs, Firewall software, Antivrus software blocking ports. Next check the Windows 7 Network adapter make sure LLTD protocol is installed.

To access a folder you can't see you can type \\Computer name in the address bar this will connect to the computer and show you available shares.
Chad Mockensturm 
Network Engineer
Certified CompTia Network +, A +

#13 Menessis

Menessis
  • Topic Starter

  • Members
  • 127 posts
  • OFFLINE
  •  
  • Local time:07:53 PM

Posted 03 December 2012 - 01:38 AM

OK.....On the Win7 machine, in the "local area connection properties" it shows the list of items and both LLTD driver and Responder with a check in the each box.

On the XP machine, I go to my network places and all I see is the router.

I typed in the name of the win7 machine "alieni5" and started a web search. I will go back and look again. I see there is a link on the left side under Network Tasks, View workgroup computers. When I click that nothing happens. And I mean nothing! I can ping "alieni5" from the prompt and it seems to work. 0 lost and min, max and average is 0ms????

There isn't any antivirus installed on the XP machine. The Firewall is turned off. I wonder if there are services that are needed that are not turned on??

Menessis

Edited by Menessis, 03 December 2012 - 08:57 AM.


#14 Sneakycyber

Sneakycyber

    Network Engineer


  • BC Advisor
  • 6,130 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Ohio
  • Local time:08:53 PM

Posted 03 December 2012 - 05:59 PM

Please download and run Mini Tool box
Also download Farbar Service scanner

Past both logs in your next reply.

Meanwhile I am creating a Windows xp home virtual PC to post screen shots

Edit: In your network protocols Do you see Client for Microsoft Networks on both machines? What about Netbios?

Edited by Sneakycyber, 03 December 2012 - 06:07 PM.

Chad Mockensturm 
Network Engineer
Certified CompTia Network +, A +

#15 Sneakycyber

Sneakycyber

    Network Engineer


  • BC Advisor
  • 6,130 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Ohio
  • Local time:08:53 PM

Posted 03 December 2012 - 08:43 PM

On My Windows 7 Ultimate Edition computer (office-pc) I have set 2 different shares. My Downloads Folder is Shared with my user account Logon name (cmockensturm) and the "EVERYONE" group is Removed. MY user folder is Shared with Everyone. Password protected sharing is ON, Public folders are on, Encryptions is 128. Allow Windows to controll Home Group Connections is selected.
Windows 7 home premium, user folder is shared with HomeGroup only
VM machine is up and running I have Windows xp pro , Windows xp Home, Windows 7 ultimate, Windows 7 home premium on my network. As of now My Xp Machine can not see my Windows 7 ultimate Shares in Network places. It CAN connect to the Windows 7 ultimate and be prompted for a password via Windows explorer (not to be confused with Internet explorer,Also known as My Computer). Windows 7 home premium Can not see my Windows 7 ulitmate computer, It CAN explore my shared folders via Explorer \\computername it is not prompted for a password because its in a "Homegroup" With the Windows 7 ultimate computer. The windows 7 home Premium does not have a Windows password assigned. Xp pro CAN see my Windows 7 ultimate Machine, and browse ALL of its shares it can not see the home premium,it also can not access the user shares from explorer. BOTH computers have the same user name and passwords. Windows 7 ultimate can see all shares on all computers.

Logging onto xp home edition with the same username and password as windows 7 ultimate gives me access to all shares and the computer now shows up in network places.

Disabling Password procted sharing in Windows 7 Allows Windows Home account with no password to access the user folder using Explorer. It still does not show up in Network places.

Edit: More to come.

Edited by Sneakycyber, 03 December 2012 - 08:43 PM.

Chad Mockensturm 
Network Engineer
Certified CompTia Network +, A +




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users