Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Macbook Pro Restore HD "This drive is locked"


  • Please log in to reply
No replies to this topic

#1 Justinohio614

Justinohio614

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:11:52 AM

Posted 29 November 2012 - 06:45 PM

MAC OS X
Lion 10.7.3
Buildversion: 11D2001

I do have the OS X disc but I'd really really like to not lose any of my data or ALL of my boyfriends movies. I am beginning to think that a full erase and reinstall may be the only fix. I'll let you tell me that though.

I'm a bit of a noob so please forgive me. In this post I will be as thorough as possible. If any additional info is needed I will glady supply it (if I can). This is my girlfriends computer so I am not ENTIRELY sure what all she has done to it but I think I have a decent idea. I will pretend I am her for the readers sake (swear I didn't do it, lol).

I forgot admin password and was attempting to recover/reset admin password. I booted while holding option, taking me to Mac OS X Utilities. From there I typed "resetpassword". When the reset password menu appeared, I selected the correct HD and selected the ADMIN user name. I typed in new password and attempted to save but could not. I then typed "reboot" into the terminal and sure enough, the password had not been changed. (I think she tried this 2 maybe 3 times in that same fashion).

After further search I found another method. Booted into Mac OS X Utilities and selected terminal. This time I typed in "rm /var/db/ .ApplesetupDone". Not sure if it matters, but any spaces in that command are intentional. To the best of her/my recollection that is how it was entered. When I hit enter it came back "this directory cannot be found", or something like that. For some unknown reason I held the power button down and turned of the computer. Upon rebooting it wouldn't get past the grey load screen with the apple, and load icon going clockwise.

I took it to geek squad and they assured me that re-installing OS X from the "Recovery HD" would fix the issue. We brought it home rather than leaving it thinking "problem solved". However, when I tried to select EITHER HD they both read "This drive is locked". I tried to repair the drive but it was unrepairable. I tried to verify "macintosh HD" and it said "disc cannot be repaired, backup as much data as possible and erase and reformatt disc". I hooked up an external hard drive and tried to copy the contents "using repair"?

I wasn't able to transfer any data and gave up. I'm told that's all I remember doing.

I know this is like a needle in a haystack considering I just do whatever google tells me but I think this is the long and veiny of it. Hopefully it's enough info to make something of.

Thanks in advance and again, I can get any info from Utilities as needed.

BC AdBot (Login to Remove)

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users