Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Cannot ping my local domain unless I specify dns 1 as my server ip


  • Please log in to reply
3 replies to this topic

#1 Anubee

Anubee

  • Members
  • 4 posts
  • OFFLINE
  •  
  • Local time:02:23 PM

Posted 27 November 2012 - 02:36 PM

I cannot ping mydomain.local from any computer on my network. In order to this, I have to set DNS 1 as my server's ip address, then I can ping it. The reason this is a problem is because in order to add a workstation to my domain, I have to manually configure DNS to my server's ip. I have two networks, all new systems and this occurs on both. So obviously it is the way im setting things up.

Here are some facts about my setup.

1) Server 2008
2) DNS Server
3) No static WAN, so my forwarder is pointing to my router.
4) I tried DHCP on my server and router (No difference except when my server is DHCP, the workstations don't have internet access).
5) I can ping by servername cannot ping by servername.mydomain.local

Thanks in advance!

BC AdBot (Login to Remove)

 


#2 Sneakycyber

Sneakycyber

    Network Engineer


  • BC Advisor
  • 6,135 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Ohio
  • Local time:02:23 PM

Posted 27 November 2012 - 11:11 PM

In order for the DNS server to work the workstations must have DNS 1 point to the domain server. Your server needs to have Fowarding enabled to send request not resolved locally to the internet DNS server. See This article for an explaination of why. After your computers are assigned the DNS server's IP by DHCP, log into the dns server and at the command prompt type nslookup it should list itself (the FQDNS name) as the server, change the setting if not. Then do a dns flush and refresh (ipconfig /flushdns, ipconfig /registerdns) try and ping a computer using its name. Now try and ping the server from a Work station. If the Nslook up is not reflecting servername.mydomain.local you need to set up your Zone file to reflect your server's FQDNS (server.mydomain.local)in the SOA record as the master name server.

Edited by Sneakycyber, 27 November 2012 - 11:12 PM.

Chad Mockensturm 
Network Engineer
Certified CompTia Network +, A +

#3 Anubee

Anubee
  • Topic Starter

  • Members
  • 4 posts
  • OFFLINE
  •  
  • Local time:02:23 PM

Posted 28 November 2012 - 09:29 AM

In order for the DNS server to work the workstations must have DNS 1 point to the domain server. Your server needs to have Fowarding enabled to send request not resolved locally to the internet DNS server. See This article for an explaination of why. After your computers are assigned the DNS server's IP by DHCP, log into the dns server and at the command prompt type nslookup it should list itself (the FQDNS name) as the server, change the setting if not. Then do a dns flush and refresh (ipconfig /flushdns, ipconfig /registerdns) try and ping a computer using its name. Now try and ping the server from a Work station. If the Nslook up is not reflecting servername.mydomain.local you need to set up your Zone file to reflect your server's FQDNS (server.mydomain.local)in the SOA record as the master name server.


How do I verify if I have forwarding setup correctly? When I goto DNS, right click on my server, properties, forwarders... I have my router's ip address there.

Keep in mind that I don't have a static WAN.

#4 Sneakycyber

Sneakycyber

    Network Engineer


  • BC Advisor
  • 6,135 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Ohio
  • Local time:02:23 PM

Posted 29 November 2012 - 01:33 AM

Is your DNS server your Active Directory controller?
Chad Mockensturm 
Network Engineer
Certified CompTia Network +, A +




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users