Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

drive letter reassignment


  • Please log in to reply
8 replies to this topic

#1 BennyBoy

BennyBoy

  • Members
  • 21 posts
  • OFFLINE
  •  
  • Local time:10:59 AM

Posted 23 November 2012 - 07:17 PM

I had a problem with xp and tried to re install it. Unfortunately, because my c drive had bad sectors, the xp installation went ahead on my d drive which has now become the boot drive. I disconnected that drive and managed to fix the c drive and reinstall xp on it - but if both drives are wired up the machine boots from the wrong one. If I disconnect it untill after boot up and then reconnect it, the computer can't see it.

Is there any way I can reassign the drive letter so that boot up happens from the correct c drive?

BC AdBot (Login to Remove)

 


#2 BennyBoy

BennyBoy
  • Topic Starter

  • Members
  • 21 posts
  • OFFLINE
  •  
  • Local time:10:59 AM

Posted 24 November 2012 - 06:24 AM

When I unplug the secondary drive, the machine boots normally from C drive. Then I can plug in the secondary drive and change the drive letter assignment of the secondary drive to G. But the computer still goes to the secondary drive to re-boot and reassigns itself as C drive - and of course I can't reassign it back to G as I cannot reassign the boot drive. So I have to switch off, disconnect the secondary drive, reboot successfully, reconnect the secondary drive and add it from device manager and it is recognised as G drive again.

I need to stop it booting from the secondary drive and I don't seem to be able to do that.

It's tricky to explain this stuff, isn't it? I've re-written this post about four times and I hope hope it makes sense. Any help with the drive letter reassignment would be appreciated.

Thanks

Benny

#3 hamluis

hamluis

    Moderator


  • Moderator
  • 56,393 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:09:59 AM

Posted 24 November 2012 - 07:54 AM

<<I disconnected that drive and managed to fix the c drive and reinstall xp on it - but if both drives are wired up the machine boots from the wrong one. If I disconnect it untill after boot up and then reconnect it, the computer can't see it.>>

Is this "second drive" an external drive?

FWIW: Any drive which reflects Windows...when booted into...is recognized as the C: partition/drive. The drive reflecing the working Windows O/S...will always be recognized as the C: partition/drive and drive letters for all other partitions may change if a multiboot situation exists.

I suggest you go to Disk Management and take/post a screen shot...reflecting both drives recognized by Windows.

How To Capture And Edit A Screen Shot - http://www.bleepingcomputer.com/forums/topic43088.html/page__gopid__2493350

Louis

#4 BennyBoy

BennyBoy
  • Topic Starter

  • Members
  • 21 posts
  • OFFLINE
  •  
  • Local time:10:59 AM

Posted 24 November 2012 - 12:30 PM

Thanks for the reply Louis

They are both internal drives

This is what it should look like (and it does after I disconnect the secondary drive (G) to boot
Posted Image

But when I reboot, the G drive (called "new Volume") becomes the boot drive and reassigns my main drive with letter D



Posted Image

#5 hamluis

hamluis

    Moderator


  • Moderator
  • 56,393 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:09:59 AM

Posted 24 November 2012 - 01:39 PM

It would seem that the boot.ini file must be edited, if I understand you correctly.

You do not want each drive to appear as boot options?

If so...I would simply delete the unwanted Windows folder...from the second drive...after booting into the Windows I want to keep.. That makes the drive unbootable (no O/S) and a mere storage container.

Or simply reformat that drive entirely.

Louis

#6 BennyBoy

BennyBoy
  • Topic Starter

  • Members
  • 21 posts
  • OFFLINE
  •  
  • Local time:10:59 AM

Posted 24 November 2012 - 09:16 PM

Thanks Louis

I just deleted the unwanted Windows folder, but when I rebooted I got a black screen with the message

"Windows could not start because the following file is missing or corrupt
<Windows root>\system32\hal.dll.
Please re-install a copy of the above file."

I guess I need to learn how to edit the boot.ini file and then decide if that is easier or more dangerous than backing up and re-formatting the drive

#7 AustrAlien

AustrAlien

    Inquisitor


  • Members
  • 6,772 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Cowra NSW Australia
  • Local time:01:59 AM

Posted 24 November 2012 - 09:24 PM

What you need to do may be as simple as entering the BIOS Setup Menu, and changing the boot order, so that the system boots first from the required hard drive. I think most BIOS menus will have the option to choose which HDD to boot from if you have more than one hard drive connected.
AustrAlien
Google is my friend. Make Google your friend too.

Posted Image

#8 BennyBoy

BennyBoy
  • Topic Starter

  • Members
  • 21 posts
  • OFFLINE
  •  
  • Local time:10:59 AM

Posted 25 November 2012 - 09:36 AM

Thanks AustrAlien

That was a simple fix (once you'd told me what the simple fix was - I would never have done it without your suggestion)

Thanks to you and Louis for taking the time to help me

Benny

#9 hamluis

hamluis

    Moderator


  • Moderator
  • 56,393 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:09:59 AM

Posted 25 November 2012 - 09:48 AM

:thumbup2: , all credit to AA ;), I would never have thought of that.

Louis




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users